aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosua Mayer <josua.mayer97@gmail.com>2017-05-22 17:04:19 +0200
committerFelix Fietkau <nbd@nbd.name>2017-05-30 14:00:30 +0200
commit3f72f3a8b129848e75cb80b11c04112a14ab31b2 (patch)
treefe479a1a5b3decce407a955c22f8ffd335195736
parent88389bfe4130e07833b41950abe5323a2fc5e6be (diff)
downloadupstream-3f72f3a8b129848e75cb80b11c04112a14ab31b2.tar.gz
upstream-3f72f3a8b129848e75cb80b11c04112a14ab31b2.tar.bz2
upstream-3f72f3a8b129848e75cb80b11c04112a14ab31b2.zip
mvebu: clearfog: include DTB for all variants in image
Installing all armada-388-clearfog-* DTBs in the same sdcard image, it now becomes much easier to swap sdcards between different device variants. Signed-off-by: Josua Mayer <josua.mayer97@gmail.com>
-rw-r--r--target/linux/mvebu/image/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index f112bb9a1e..b5014161c6 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -36,7 +36,7 @@ endef
define Build/boot-img
rm -f $@.boot
mkfs.fat -C $@.boot 16384
- $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb)
+ $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb;)
mcopy -i $@.boot $(IMAGE_KERNEL) ::zImage
mcopy -i $@.boot $@.bootscript ::boot.scr
endef
@@ -178,18 +178,19 @@ TARGET_DEVICES += armada-388-rd
define Device/armada-388-clearfog-pro
KERNEL_INSTALL := 1
- KERNEL := dtb | kernel-bin
+ KERNEL := kernel-bin
DEVICE_TITLE := SolidRun ClearFog Pro
DEVICE_PACKAGES := mkf2fs e2fsprogs swconfig kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := boot-scr-cfpro | boot-img | sdcard-img | gzip | append-metadata
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
+ DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
endef
TARGET_DEVICES += armada-388-clearfog-pro
define Device/armada-388-clearfog-base
KERNEL_INSTALL := 1
- KERNEL := dtb | kernel-bin
+ KERNEL := kernel-bin
DEVICE_TITLE := SolidRun ClearFog Base
DEVICE_PACKAGES := \
kmod-nls-cp437 kmod-nls-iso8859-1 \
@@ -199,6 +200,7 @@ define Device/armada-388-clearfog-base
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := boot-scr-cfbase | boot-img | sdcard-img | gzip
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
+ DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
endef
TARGET_DEVICES += armada-388-clearfog-base