aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-18 15:14:13 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-18 15:14:13 +0000
commit3dc9ea547217baa963f479b275182c4b282923b2 (patch)
treed7c07032e09c35f4d32b4f9dedb6e56cc4f2df15
parent92e1586bec3083edb189ff1ee3440081e243c10a (diff)
downloadupstream-3dc9ea547217baa963f479b275182c4b282923b2.tar.gz
upstream-3dc9ea547217baa963f479b275182c4b282923b2.tar.bz2
upstream-3dc9ea547217baa963f479b275182c4b282923b2.zip
Convert openntpd to new packaging style
SVN-Revision: 937
-rw-r--r--openwrt/package/openntpd/Config.in9
-rw-r--r--openwrt/package/openntpd/Makefile84
-rw-r--r--openwrt/package/openntpd/files/ntpd.conf (renamed from openwrt/package/openntpd/ipkg/etc/ntpd.conf)0
-rw-r--r--[-rwxr-xr-x]openwrt/package/openntpd/files/ntpd.init (renamed from openwrt/package/openntpd/files/S49ntpd)0
-rwxr-xr-xopenwrt/package/openntpd/ipkg/etc/init.d/S55ntpd3
-rw-r--r--openwrt/package/openntpd/ipkg/openntpd.control (renamed from openwrt/package/openntpd/openntpd.control)0
-rw-r--r--[-rwxr-xr-x]openwrt/package/openntpd/ipkg/openntpd.postinst (renamed from openwrt/package/openntpd/ipkg/CONTROL/postinst)4
7 files changed, 46 insertions, 54 deletions
diff --git a/openwrt/package/openntpd/Config.in b/openwrt/package/openntpd/Config.in
index d61b56fb35..edf077b834 100644
--- a/openwrt/package/openntpd/Config.in
+++ b/openwrt/package/openntpd/Config.in
@@ -1,6 +1,9 @@
config BR2_PACKAGE_OPENNTPD
- tristate "Openntpd"
+ tristate "openntpd - a FREE, easy to use implementation of NTP (Network Time Protocol)"
default m if CONFIG_DEVEL
help
- NTP server
- http://www.openntpd.org
+ NTP server
+
+ http://www.openntpd.org
+
+
diff --git a/openwrt/package/openntpd/Makefile b/openwrt/package/openntpd/Makefile
index 59b504fa4a..5902da95bb 100644
--- a/openwrt/package/openntpd/Makefile
+++ b/openwrt/package/openntpd/Makefile
@@ -11,62 +11,54 @@ PKG_MD5SUM:=4584f226523776a3cdd2fb6f8212ba8d
PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/ \
ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenNTPD/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
-$(DL_DIR)/$(PKG_SOURCE):
- $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
- $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- touch $(PKG_BUILD_DIR)/.unpacked
+$(eval $(call PKG_template,OPENNTPD,openntpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
- (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+$(PKG_BUILD_DIR)/.configured:
+ (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- --with-builtin-arc4random \
- --with-privsep-user=ntp \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
+ $(DISABLE_NLS) \
+ --with-builtin-arc4random \
+ --with-privsep-user=ntp \
);
touch $(PKG_BUILD_DIR)/.configured
-$(PKG_BUILD_DIR)/ntpd: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR)
+ touch $(PKG_BUILD_DIR)/.built
-$(PKG_IPK): $(PKG_BUILD_DIR)/ntpd
- mkdir -p $(PKG_IPK_DIR)/usr/sbin
- cp -a ./ipkg/* $(PKG_IPK_DIR)/
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
- cp $(PKG_BUILD_DIR)/ntpd $(PKG_IPK_DIR)/usr/sbin/
- $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
- mkdir -p $(PACKAGE_DIR)
- find $(PKG_IPK_DIR) -name CVS | xargs rm -rf
- $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
- $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+$(IPKG_OPENNTPD):
+ install -d -m0755 $(IDIR_OPENNTPD)/etc
+ install -m0644 ./files/ntpd.conf $(IDIR_OPENNTPD)/etc/
+ install -d -m0755 $(IDIR_OPENNTPD)/etc/init.d
+ install -m0755 ./files/ntpd.init $(IDIR_OPENNTPD)/etc/init.d/S55ntpd
+ install -d -m0755 $(IDIR_OPENNTPD)/usr/sbin/
+ install -m0755 $(PKG_BUILD_DIR)/ntpd $(IDIR_OPENNTPD)/usr/sbin/
+ $(RSTRIP) $(IDIR_OPENNTPD)
+ $(IPKG_BUILD) $(IDIR_OPENNTPD) $(PACKAGE_DIR)
-clean:
- rm -rf $(PKG_BUILD_DIR)
- rm -f $(PKG_IPK)
diff --git a/openwrt/package/openntpd/ipkg/etc/ntpd.conf b/openwrt/package/openntpd/files/ntpd.conf
index 6993b8eba2..6993b8eba2 100644
--- a/openwrt/package/openntpd/ipkg/etc/ntpd.conf
+++ b/openwrt/package/openntpd/files/ntpd.conf
diff --git a/openwrt/package/openntpd/files/S49ntpd b/openwrt/package/openntpd/files/ntpd.init
index e528748780..e528748780 100755..100644
--- a/openwrt/package/openntpd/files/S49ntpd
+++ b/openwrt/package/openntpd/files/ntpd.init
diff --git a/openwrt/package/openntpd/ipkg/etc/init.d/S55ntpd b/openwrt/package/openntpd/ipkg/etc/init.d/S55ntpd
deleted file mode 100755
index e528748780..0000000000
--- a/openwrt/package/openntpd/ipkg/etc/init.d/S55ntpd
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-mkdir -p `grep "^ntp:" /etc/passwd | cut -d: -f6`
-/usr/sbin/ntpd -s
diff --git a/openwrt/package/openntpd/openntpd.control b/openwrt/package/openntpd/ipkg/openntpd.control
index 8bc341f38e..8bc341f38e 100644
--- a/openwrt/package/openntpd/openntpd.control
+++ b/openwrt/package/openntpd/ipkg/openntpd.control
diff --git a/openwrt/package/openntpd/ipkg/CONTROL/postinst b/openwrt/package/openntpd/ipkg/openntpd.postinst
index daa0baf55d..4b2ffe9df6 100755..100644
--- a/openwrt/package/openntpd/ipkg/CONTROL/postinst
+++ b/openwrt/package/openntpd/ipkg/openntpd.postinst
@@ -11,11 +11,11 @@ if [ -z "${IPKG_INSTROOT}" ]; then
if [ "$rootfs" = "squashfs" ]; then
if [ -h /etc/group ]; then
rm /etc/group
- cp /rom/etc/group /etc/group
+ cp -p /rom/etc/group /etc/group
fi
if [ -h /etc/passwd ]; then
rm /etc/passwd
- cp /rom/etc/passwd /etc/passwd
+ cp -p /rom/etc/passwd /etc/passwd
fi
fi
fi