aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-08-22 08:31:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-08-22 08:31:49 +0000
commit36fa8ff606d05f6d755275c16f931ba270e968aa (patch)
tree19775a40d5f2e0c6092d34ef5c54c278204bd49a
parent5440728b06f5fd65a222e7dbab57596b39992451 (diff)
downloadupstream-36fa8ff606d05f6d755275c16f931ba270e968aa.tar.gz
upstream-36fa8ff606d05f6d755275c16f931ba270e968aa.tar.bz2
upstream-36fa8ff606d05f6d755275c16f931ba270e968aa.zip
Add kmod-ppp-synctty (#2231)
SVN-Revision: 8459
-rw-r--r--package/kernel/modules/network.mk13
-rw-r--r--target/linux/generic-2.4/config-template2
2 files changed, 14 insertions, 1 deletions
diff --git a/package/kernel/modules/network.mk b/package/kernel/modules/network.mk
index a7b93e1d4c..6da38e4e05 100644
--- a/package/kernel/modules/network.mk
+++ b/package/kernel/modules/network.mk
@@ -189,6 +189,19 @@ endef
$(eval $(call KernelPackage,ppp))
+define KernelPackage/ppp-synctty
+ TITLE:=PPP sync tty support
+ DESCRIPTION:=\
+ Kernel modules for PPP sync tty support
+ DEPENDS:=kmod-ppp
+ KCONFIG:=CONFIG_PPP_SYNC_TTY
+ SUBMENU:=$(NSMENU)
+ FILES:=$(LINUX_DIR)/drivers/net/ppp_synctty.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,40,ppp_synctty)
+endef
+$(eval $(call KernelPackage,ppp-synctty))
+
+
define KernelPackage/pppoe
TITLE:=PPPoE support
DESCRIPTION:=\
diff --git a/target/linux/generic-2.4/config-template b/target/linux/generic-2.4/config-template
index 1607f04508..9f33ef427e 100644
--- a/target/linux/generic-2.4/config-template
+++ b/target/linux/generic-2.4/config-template
@@ -579,7 +579,7 @@ CONFIG_PPP_DEFLATE=m
CONFIG_PPP_FILTER=y
CONFIG_PPP_MPPE_MPPC=m
# CONFIG_PPP_MULTILINK is not set
-# CONFIG_PPP_SYNC_TTY is not set
+CONFIG_PPP_SYNC_TTY=m
# CONFIG_PRISM54 is not set
CONFIG_PROC_FS=y
# CONFIG_QFMT_V2 is not set