aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-24 17:11:52 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-21 00:38:36 +0100
commit35fd7762b2771958d3fcf33863c753ee72ff214c (patch)
treeb0a4040c946c10ef48890b6da052152817092e23
parente453767535edd27aabb45038c967fab98fcc2d58 (diff)
downloadupstream-35fd7762b2771958d3fcf33863c753ee72ff214c.tar.gz
upstream-35fd7762b2771958d3fcf33863c753ee72ff214c.tar.bz2
upstream-35fd7762b2771958d3fcf33863c753ee72ff214c.zip
tools/expat: build with autotools again
Allows to set expat as a dependency to cmake and save on compilation time. Signed-off-by: Rosen Penev <rosenp@gmail.com> (cherry picked from commit 89df3589e6237e5ad9b5cdd9f87c82987b200e37)
-rw-r--r--tools/Makefile5
-rw-r--r--tools/expat/Makefile26
2 files changed, 15 insertions, 16 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 57a6530ba4..e1dfb8082d 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -22,13 +22,13 @@ ifneq ($(CONFIG_SDK)$(CONFIG_PACKAGE_kmod-b43)$(CONFIG_PACKAGE_b43legacy-firmwar
endif
tools-y += autoconf autoconf-archive automake bc bison cmake cpio dosfstools
-tools-y += e2fsprogs fakeroot findutils firmware-utils flex gengetopt
+tools-y += e2fsprogs expat fakeroot findutils firmware-utils flex gengetopt
tools-y += libressl libtool lzma m4 make-ext4fs meson missing-macros mkimage
tools-y += mklibs mtd-utils mtools ninja padjffs2 patch-image
tools-y += patchelf pkgconf quilt squashfskit4 sstrip zip zlib zstd
tools-$(BUILD_B43_TOOLS) += b43-tools
tools-$(BUILD_ISL) += isl
-tools-$(BUILD_TOOLCHAIN) += expat gmp mpc mpfr
+tools-$(BUILD_TOOLCHAIN) += gmp mpc mpfr
tools-$(CONFIG_TARGET_apm821xx)$(CONFIG_TARGET_gemini) += genext2fs
tools-$(CONFIG_TARGET_ath79) += lzma-old squashfs
tools-$(CONFIG_TARGET_mxs) += elftosb sdimage
@@ -46,7 +46,6 @@ $(curdir)/bison/compile := $(curdir)/flex/compile
$(curdir)/cbootimage/compile += $(curdir)/automake/compile
$(curdir)/cmake/compile += $(curdir)/libressl/compile $(curdir)/ninja/compile
$(curdir)/dosfstools/compile := $(curdir)/autoconf/compile $(curdir)/automake/compile
-$(curdir)/expat/compile := $(curdir)/cmake/compile
$(curdir)/e2fsprogs/compile := $(curdir)/libtool/compile
$(curdir)/fakeroot/compile := $(curdir)/libtool/compile
$(curdir)/findutils/compile := $(curdir)/bison/compile
diff --git a/tools/expat/Makefile b/tools/expat/Makefile
index 21548de442..c1a8cb8d97 100644
--- a/tools/expat/Makefile
+++ b/tools/expat/Makefile
@@ -15,19 +15,19 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_HASH:=ef2420f0232c087801abf705e89ae65f6257df6b7931d37846a193ef2e8cdcbe
PKG_SOURCE_URL:=https://github.com/libexpat/libexpat/releases/download/R_$(subst .,_,$(PKG_VERSION))
+HOST_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/host-build.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-CMAKE_HOST_OPTIONS += \
- -DDOCBOOK_TO_MAN=OFF \
- -DEXPAT_BUILD_TOOLS=OFF \
- -DEXPAT_BUILD_EXAMPLES=OFF \
- -DEXPAT_BUILD_TESTS=OFF \
- -DEXPAT_BUILD_DOCS=OFF \
- -DEXPAT_WITH_LIBBSD=OFF \
- -DEXPAT_ENABLE_INSTALL=ON \
- -DEXPAT_DTD=ON \
- -DEXPAT_NS=OFF \
- -DEXPAT_DEV_URANDOM=OFF
+
+HOSTCC := $(HOSTCC_NOCACHE)
+
+HOST_CONFIGURE_ARGS += \
+ --disable-shared \
+ --without-docbook \
+ --with-pic
+
+define Host/Uninstall
+ -$(call Host/Compile/Default,uninstall)
+endef
$(eval $(call HostBuild))