aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-08-25 10:52:22 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-08-31 11:26:10 +0100
commit35f2116519f6e40ee7acab23479912ccba91fcf6 (patch)
treeddd6c001435eabc8e2fc902b36b4df5865a45727
parent84024e245f346cdf1da955cea4ab4c2c0a0886b2 (diff)
downloadupstream-35f2116519f6e40ee7acab23479912ccba91fcf6.tar.gz
upstream-35f2116519f6e40ee7acab23479912ccba91fcf6.tar.bz2
upstream-35f2116519f6e40ee7acab23479912ccba91fcf6.zip
treewide: https for downloads.openwrt.org sources
Instead of using http and https for source downloads from downloads.openwrt.org, always use https for it's better security. Signed-off-by: Paul Spooren <mail@aparcar.org>
-rw-r--r--package/firmware/b43legacy-firmware/Makefile2
-rw-r--r--package/kernel/broadcom-wl/Makefile2
-rw-r--r--package/kernel/lantiq/ltq-vmmc/Makefile2
-rw-r--r--tools/lzma-old/Makefile2
-rw-r--r--tools/lzma/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/package/firmware/b43legacy-firmware/Makefile b/package/firmware/b43legacy-firmware/Makefile
index 07c584f014..9b9c0070b2 100644
--- a/package/firmware/b43legacy-firmware/Makefile
+++ b/package/firmware/b43legacy-firmware/Makefile
@@ -12,7 +12,7 @@ PKG_VERSION:=3.130.20.0
PKG_RELEASE:=1
PKG_SOURCE:=wl_apsta-$(PKG_VERSION).o
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
+PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
PKG_HASH:=7dba610b1d96dd14e901bcbce14cd6ecd1b1ac6f5c0035b0d6b6dc46a7c3ef90
include $(INCLUDE_DIR)/package.mk
diff --git a/package/kernel/broadcom-wl/Makefile b/package/kernel/broadcom-wl/Makefile
index 1e1447cde5..661c7f0589 100644
--- a/package/kernel/broadcom-wl/Makefile
+++ b/package/kernel/broadcom-wl/Makefile
@@ -13,7 +13,7 @@ PKG_VERSION:=5.10.56.27.3
PKG_RELEASE:=10
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_$(ARCH).tar.bz2
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
+PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
ifeq ($(ARCH),mipsel)
PKG_HASH:=26a8c370f48fc129d0731cfd751c36cae1419b0bc8ca35781126744e60eae009
diff --git a/package/kernel/lantiq/ltq-vmmc/Makefile b/package/kernel/lantiq/ltq-vmmc/Makefile
index def676b833..586d9f6c75 100644
--- a/package/kernel/lantiq/ltq-vmmc/Makefile
+++ b/package/kernel/lantiq/ltq-vmmc/Makefile
@@ -14,7 +14,7 @@ PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_HASH:=707f515eb727c032418c4da67d7e86884bb56cdc2a606e8f6ded6057d8767e57
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_SOURCE_URL:=https://mirror2.openwrt.org/sources
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
PKG_CHECK_FORMAT_SECURITY:=0
diff --git a/tools/lzma-old/Makefile b/tools/lzma-old/Makefile
index 5204127a80..4ccd336ed0 100644
--- a/tools/lzma-old/Makefile
+++ b/tools/lzma-old/Makefile
@@ -10,7 +10,7 @@ PKG_NAME:=lzma-old
PKG_VERSION:=4.32
PKG_SOURCE:=lzma-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
PKG_HASH:=49053e4bb5e0646a841d250d9cb81f7714f5fff04a133216c4748163567acc3d
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/lzma-$(PKG_VERSION)
diff --git a/tools/lzma/Makefile b/tools/lzma/Makefile
index 7d2669e95f..04c427a3a9 100644
--- a/tools/lzma/Makefile
+++ b/tools/lzma/Makefile
@@ -10,7 +10,7 @@ PKG_NAME:=lzma
PKG_VERSION:=4.65
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
+PKG_SOURCE_URL:=https://downloads.openwrt.org/sources
PKG_HASH:=dcbdb5f4843eff638e4a5e8be0e2486a3c5483df73c70823618db8e66f609ec2
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)