aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-09-28 23:09:22 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-09-30 03:26:12 +0100
commit359a4b46bb234166010b3e63b147d93db6c3b4f5 (patch)
tree3eae42acbcecc3e03c604d1022a86ba435387062
parent18acf62be1e128f60d48833687bb1bfe058c9ad5 (diff)
downloadupstream-359a4b46bb234166010b3e63b147d93db6c3b4f5.tar.gz
upstream-359a4b46bb234166010b3e63b147d93db6c3b4f5.tar.bz2
upstream-359a4b46bb234166010b3e63b147d93db6c3b4f5.zip
refpolicy: fix path to setfiles and checkpolicy
Directly set path via MAKE vars instead of defning TESTTOOLS. This way setfiles, which is required by the ImageBuilder, ends up in /host/bin while checkpolicy can stay in hostpkg/bin. Signed-off-by: Paul Spooren <mail@aparcar.org>
-rw-r--r--package/system/refpolicy/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/system/refpolicy/Makefile b/package/system/refpolicy/Makefile
index a80b4d043c..a431770955 100644
--- a/package/system/refpolicy/Makefile
+++ b/package/system/refpolicy/Makefile
@@ -56,9 +56,8 @@ endef
# builds is a small host tool that gets run as part of the build
# process.
MAKE_FLAGS += \
- TEST_TOOLCHAIN="$(STAGING_DIR_HOSTPKG)" \
- BINDIR=/bin \
- SBINDIR=/sbin \
+ SETFILES="$(STAGING_DIR_HOST)/bin/setfiles" \
+ CHECKPOLICY="$(STAGING_DIR_HOSTPKG)/bin/checkpolicy" \
CC="$(HOSTCC)" \
CFLAGS="$(HOST_CFLAGS)"