aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-02-03 21:25:48 +0000
committerNicolas Thill <nico@openwrt.org>2009-02-03 21:25:48 +0000
commit33a0eb3613da33aafd435eb4ed1e985944f42c78 (patch)
tree73adfaa44c084674b08e2c82942d3b3dfa330d9d
parent1716050f0c274d198abebf2b9e21fb9f754c199a (diff)
downloadupstream-33a0eb3613da33aafd435eb4ed1e985944f42c78.tar.gz
upstream-33a0eb3613da33aafd435eb4ed1e985944f42c78.tar.bz2
upstream-33a0eb3613da33aafd435eb4ed1e985944f42c78.zip
cosmetic & coherency fixes
SVN-Revision: 14397
-rw-r--r--toolchain/binutils/Makefile38
-rw-r--r--toolchain/eglibc/Makefile9
-rw-r--r--toolchain/gcc/Makefile22
-rw-r--r--toolchain/glibc-ports/Makefile3
-rw-r--r--toolchain/glibc/Makefile13
-rw-r--r--toolchain/kernel-headers/Makefile6
-rw-r--r--toolchain/uClibc/Makefile4
7 files changed, 52 insertions, 43 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 925478c414..dba6d45688 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -35,12 +35,30 @@ override CONFIG_AUTOREBUILD=
include $(INCLUDE_DIR)/host-build.mk
-EXTRA_TARGET=$(if $(CONFIG_EXTRA_TARGET_ARCH),--enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX))
+BINUTILS_CONFIGURE:= \
+ ./configure \
+ --prefix=$(TOOLCHAIN_DIR)/usr \
+ --build=$(GNU_HOST_NAME) \
+ --host=$(GNU_HOST_NAME) \
+ --target=$(REAL_GNU_TARGET_NAME) \
+ --with-sysroot=$(TOOLCHAIN_DIR) \
+ --disable-multilib \
+ --disable-werror \
+ --disable-nls \
+ $(SOFT_FLOAT_CONFIG_OPTION) \
+ $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \
ifneq ($(CONFIG_SSP_SUPPORT),)
- LIB_SSP:=--enable-libssp
+ BINUTILS_CONFIGURE+= \
+ --enable-libssp
else
- LIB_SSP:=--disable-libssp
+ BINUTILS_CONFIGURE+= \
+ --disable-libssp
+endif
+
+ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
+ BINUTILS_CONFIGURE+= \
+ --enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
endif
define Build/Prepare
@@ -51,19 +69,7 @@ endef
define Build/Configure
(cd $(PKG_BUILD_DIR); \
- ./configure \
- --prefix=$(TOOLCHAIN_DIR)/usr \
- --build=$(GNU_HOST_NAME) \
- --host=$(GNU_HOST_NAME) \
- --target=$(REAL_GNU_TARGET_NAME) \
- --with-sysroot=$(TOOLCHAIN_DIR) \
- --disable-multilib \
- --disable-werror \
- --disable-nls \
- $(LIB_SSP) \
- $(EXTRA_TARGET) \
- $(SOFT_FLOAT_CONFIG_OPTION) \
- $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS)) \
+ $(BINUTILS_CONFIGURE) \
);
endef
diff --git a/toolchain/eglibc/Makefile b/toolchain/eglibc/Makefile
index e9e1d00da5..6e4e3e025f 100644
--- a/toolchain/eglibc/Makefile
+++ b/toolchain/eglibc/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -14,6 +14,7 @@ PKG_SOURCE_PROTO:=svn
PKG_SOURCE_VERSION:=$(PKG_REVISION)
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
+
ifeq ($(PKG_VERSION),2.6.1)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_6
endif
@@ -65,9 +66,11 @@ EGLIBC_CONFIGURE:= \
--enable-add-ons \
ifeq ($(CONFIG_SOFT_FLOAT),)
- EGLIBC_CONFIGURE+= --with-fp
+ EGLIBC_CONFIGURE+= \
+ --with-fp
else
- EGLIBC_CONFIGURE+= --without-fp
+ EGLIBC_CONFIGURE+= \
+ --without-fp
endif
EGLIBC_MAKE:= \
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 0198e43641..039643db9b 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -63,7 +63,7 @@ PKG_BUILD_DIR2:=$(PKG_BUILD_DIR)-final
SEP:=,
TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
-GCC_CONFIGURE_COMMON:= \
+GCC_CONFIGURE:= \
SHELL="$(BASH)" \
$(PKG_BUILD_DIR)/configure \
--prefix=$(TOOLCHAIN_DIR)/usr \
@@ -80,37 +80,37 @@ GCC_CONFIGURE_COMMON:= \
$(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
ifneq ($(CONFIG_GCC_VERSION_4_3),)
- GCC_BUILD_TARGET_LIBGCC:=y
- GCC_CONFIGURE_COMMON+= \
+ GCC_BUILD_TARGET_LIBGCC:=y
+ GCC_CONFIGURE+= \
--with-gmp=$(TOPDIR)/staging_dir/host \
--with-mpfr=$(TOPDIR)/staging_dir/host \
--disable-decimal-float
endif
ifneq ($(CONFIG_SSP_SUPPORT),)
- GCC_CONFIGURE_COMMON+= \
+ GCC_CONFIGURE+= \
--enable-libssp
else
- GCC_CONFIGURE_COMMON+= \
+ GCC_CONFIGURE+= \
--disable-libssp
endif
ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
- GCC_CONFIGURE_COMMON+= \
+ GCC_CONFIGURE+= \
--enable-biarch \
--enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
endif
ifeq ($(LIBC),uClibc)
- GCC_CONFIGURE_COMMON+= \
+ GCC_CONFIGURE+= \
--disable-__cxa_atexit
else
- GCC_CONFIGURE_COMMON+= \
+ GCC_CONFIGURE+= \
--enable-__cxa_atexit
endif
GCC_CONFIGURE_STAGE0:= \
- $(GCC_CONFIGURE_COMMON) \
+ $(GCC_CONFIGURE) \
--with-newlib \
--without-headers \
--enable-languages=c \
@@ -119,7 +119,7 @@ GCC_CONFIGURE_STAGE0:= \
--disable-threads \
GCC_CONFIGURE_STAGE1:= \
- $(GCC_CONFIGURE_COMMON) \
+ $(GCC_CONFIGURE) \
--with-newlib \
--with-sysroot=$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev \
--enable-languages=c \
@@ -127,7 +127,7 @@ GCC_CONFIGURE_STAGE1:= \
--disable-threads \
GCC_CONFIGURE_STAGE2:= \
- $(GCC_CONFIGURE_COMMON) \
+ $(GCC_CONFIGURE) \
--enable-languages=$(TARGET_LANGUAGES) \
--enable-shared \
--enable-threads \
diff --git a/toolchain/glibc-ports/Makefile b/toolchain/glibc-ports/Makefile
index 2ddeb4e2be..d9e5d0d7f5 100644
--- a/toolchain/glibc-ports/Makefile
+++ b/toolchain/glibc-ports/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -21,7 +21,6 @@ endif
PKG_SOURCE_URL:=@GNU/glibc/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
PATCH_DIR:=./patches/$(PKG_VERSION)
diff --git a/toolchain/glibc/Makefile b/toolchain/glibc/Makefile
index fd6acc46b8..f808615cd4 100644
--- a/toolchain/glibc/Makefile
+++ b/toolchain/glibc/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -21,7 +21,6 @@ endif
PKG_SOURCE_URL:=@GNU/glibc/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
PATCH_DIR:=./patches/$(PKG_VERSION)
@@ -51,7 +50,7 @@ endif
# http://sourceware.org/bugzilla/show_bug.cgi?id=5203
GLIBC_CFLAGS:=$(subst -Os,-O2,$(TARGET_CFLAGS))
-GLIBC_CONFIGURE_COMMON:= \
+GLIBC_CONFIGURE:= \
BUILD_CC="$(HOSTCC)" \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(GLIBC_CFLAGS)" \
@@ -70,20 +69,20 @@ GLIBC_CONFIGURE_COMMON:= \
--without-cvs \
ifeq ($(CONFIG_SOFT_FLOAT),)
- GLIBC_CONFIGURE_COMMON+= \
+ GLIBC_CONFIGURE+= \
--with-fp
else
- GLIBC_CONFIGURE_COMMON+= \
+ GLIBC_CONFIGURE+= \
--without-fp
endif
GLIBC_CONFIGURE_STAGE1:= \
- $(GLIBC_CONFIGURE_COMMON) \
+ $(GLIBC_CONFIGURE) \
--disable-sanity-checks \
--enable-hacker-mode \
GLIBC_CONFIGURE_STAGE2:= \
- $(GLIBC_CONFIGURE_COMMON) \
+ $(GLIBC_CONFIGURE) \
GLIBC_MAKE:= \
$(MAKE) \
diff --git a/toolchain/kernel-headers/Makefile b/toolchain/kernel-headers/Makefile
index d787cf0a85..cf5a384295 100644
--- a/toolchain/kernel-headers/Makefile
+++ b/toolchain/kernel-headers/Makefile
@@ -32,6 +32,10 @@ ifeq ($(strip $(BOARD)),uml)
LINUX_KARCH:=$(ARCH)
endif
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.18)),1)
+ LINUX_HAS_HEADERS_INSTALL:=y
+endif
+
KMAKE := $(MAKE) -C $(PKG_BUILD_DIR) \
ARCH=$(LINUX_KARCH) \
KBUILD_HAVE_NLS=no \
@@ -50,7 +54,7 @@ define Build/Prepare/pre/powerpc
fi
endef
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.18)),1)
+ifneq ($(LINUX_HAS_HEADERS_INSTALL),)
define Build/Prepare/all
mkdir -p $(BUILD_DIR_TOOLCHAIN)/linux-dev/usr
$(KMAKE) \
diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 245383021f..45dbcef0c5 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -51,8 +51,6 @@ ifeq ($(PKG_VERSION_SNAPSHOT),y)
PKG_MD5SUM:=
endif
-PKG_CAT:=bzcat
-
STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
ifeq ($(PKG_VERSION_SNAPSHOT),y)