aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2021-01-30 13:32:43 +0100
committerPetr Štetiar <ynezz@true.cz>2021-01-31 11:39:19 +0100
commit337ff74894110b35b61118918b7eb30bb6e60756 (patch)
tree02a5840eca9a392553b6b690419a8af654a5d8ed
parentec0c6c11436d233c3e1f3c1b4461a46348a1a0c7 (diff)
downloadupstream-337ff74894110b35b61118918b7eb30bb6e60756.tar.gz
upstream-337ff74894110b35b61118918b7eb30bb6e60756.tar.bz2
upstream-337ff74894110b35b61118918b7eb30bb6e60756.zip
mvebu: omnia: make initramfs image usable out of the box
Currently it's not possible to boot the device with just initramfs image without additional effort as the initramfs image doesn't contain device tree. Fix it by producing FIT based image which could be booted with following commands: setenv bootargs earlyprintk console=ttyS0,115200 tftpboot ${kernel_addr_r} openwrt-mvebu-cortexa9-cznic_turris-omnia-initramfs-kernel.bin bootm ${kernel_addr_r} Acked-by: Klaus Kudielka <klaus.kudielka@gmail.com> Reviewed-by: Tomasz Maciej Nowak <tmn505@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--target/linux/mvebu/image/cortexa9.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index ea20a25a29..968e2a38f4 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -32,8 +32,9 @@ define Device/cznic_turris-omnia
DEVICE_VENDOR := CZ.NIC
DEVICE_MODEL := Turris Omnia
KERNEL_INSTALL := 1
+ SOC := armada-385
KERNEL := kernel-bin
- KERNEL_INITRAMFS := kernel-bin
+ KERNEL_INITRAMFS := kernel-bin | gzip | fit gzip $$(KDIR)/image-$$(DEVICE_DTS).dtb
DEVICE_PACKAGES := \
mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
wpad-basic-wolfssl kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \
@@ -42,7 +43,6 @@ define Device/cznic_turris-omnia
IMAGE/$$(IMAGE_PREFIX)-sysupgrade.img.gz := boot-scr | boot-img | sdcard-img | gzip | append-metadata
IMAGE/omnia-medkit-$$(IMAGE_PREFIX)-initramfs.tar.gz := omnia-medkit-initramfs | gzip
IMAGE_NAME = $$(2)
- SOC := armada-385
SUPPORTED_DEVICES += armada-385-turris-omnia
BOOT_SCRIPT := turris-omnia
endef