aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2006-03-15 16:52:29 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2006-03-15 16:52:29 +0000
commit32f1da72e84c12e1affdff26a5e48a34cbbb4b0e (patch)
tree0cccc584cc23d1ca034f5fbededfcd47b5d3e640
parent8c80efabd4c74477ec222df669c61f65351110c5 (diff)
downloadupstream-32f1da72e84c12e1affdff26a5e48a34cbbb4b0e.tar.gz
upstream-32f1da72e84c12e1affdff26a5e48a34cbbb4b0e.tar.bz2
upstream-32f1da72e84c12e1affdff26a5e48a34cbbb4b0e.zip
add elinks, mutt, fetchmail and procmail, thx Michael Cohen, procmail disabled, compile problem
SVN-Revision: 3379
-rw-r--r--openwrt/package/Config.in5
-rw-r--r--openwrt/package/Makefile5
-rw-r--r--openwrt/package/elinks/Config.in9
-rw-r--r--openwrt/package/elinks/Makefile56
-rw-r--r--openwrt/package/elinks/ipkg/elinks.control4
-rw-r--r--openwrt/package/fetchmail/Config.in8
-rw-r--r--openwrt/package/fetchmail/Makefile59
-rw-r--r--openwrt/package/fetchmail/ipkg/fetchmail.control5
-rw-r--r--openwrt/package/jamvm/Config.in14
-rw-r--r--openwrt/package/mutt/Config.in11
-rw-r--r--openwrt/package/mutt/Makefile63
-rw-r--r--openwrt/package/mutt/ipkg/mutt.control5
-rw-r--r--openwrt/package/procmail/Config.in11
-rw-r--r--openwrt/package/procmail/Makefile33
-rw-r--r--openwrt/package/procmail/ipkg/procmail.control4
15 files changed, 286 insertions, 6 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 05b736f810..9c63091e70 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -20,6 +20,8 @@ source "package/collectd/Config.in"
source "package/cbtt/Config.in"
source "package/ctorrent/Config.in"
source "package/deco/Config.in"
+source "package/elinks/Config.in"
+source "package/fetchmail/Config.in"
source "package/gpsd/Config.in"
source "package/haserl/Config.in"
source "package/irssi/Config.in"
@@ -29,6 +31,9 @@ source "package/less/Config.in"
source "package/lua/Config.in"
source "package/microperl/Config.in"
source "package/monit/Config.in"
+source "package/mutt/Config.in"
+source "package/procmail/Config.in"
+
source "package/nano/Config.in"
source "package/osiris/Config.in"
source "package/php4/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 856b7eb900..94c0ebfa7e 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -43,9 +43,11 @@ package-$(BR2_PACKAGE_DROPBEAR) += dropbear
package-$(BR2_PACKAGE_DSNIFF) += dsniff
package-$(BR2_PACKAGE_E2FSPROGS) += e2fsprogs
package-$(BR2_PACKAGE_EBTABLES) += ebtables
+package-$(BR2_PACKAGE_ELINKS) += elinks
package-$(BR2_PACKAGE_ETHER_WAKE) += ether-wake
package-$(BR2_COMPILE_EXPAT) += expat
package-$(BR2_PACKAGE_EZIPUPDATE) += ez-ipupdate
+package-$(BR2_PACKAGE_FETCHMAIL) += fetchmail
package-$(BR2_COMPILE_FLAC) += flac
package-$(BR2_PACKAGE_FPING) += fping
package-$(BR2_PACKAGE_FPROBE) += fprobe
@@ -145,6 +147,7 @@ package-$(BR2_PACKAGE_MRD6) += mrd6
package-$(BR2_PACKAGE_MT_DAAPD) += mt-daapd
package-$(BR2_PACKAGE_MTD) += mtd
package-$(BR2_PACKAGE_MTR) += mtr
+package-$(BR2_PACKAGE_MUTT) += mutt
package-$(BR2_COMPILE_MYSQL) += mysql
package-$(BR2_PACKAGE_NANO) += nano
package-$(BR2_COMPILE_NCURSES) += ncurses
@@ -188,6 +191,7 @@ package-$(BR2_PACKAGE_PPP) += ppp
package-$(BR2_PACKAGE_PPTP) += pptp
package-$(BR2_PACKAGE_PPTPD) += pptpd
package-$(BR2_PACKAGE_PRIVOXY) += privoxy
+package-$(BR2_PACKAGE_PROCMAIL) += procmail
package-$(BR2_PACKAGE_PSYBNC) += psybnc
package-$(BR2_PACKAGE_PTUNNEL) += ptunnel
package-$(BR2_PACKAGE_QUAGGA) += quagga
@@ -337,6 +341,7 @@ miredo-compile: uclibc++-compile
monit-compile: openssl-compile
mt-daapd-compile: howl-compile libgdbm-compile libid3tag-compile
mtr-compile: ncurses-compile
+mutt-compile: ncurses-compile openssl-compile
mysql-compile: ncurses-compile zlib-compile readline-compile
nano-compile: ncurses-compile
net-snmp-compile: libelf-compile
diff --git a/openwrt/package/elinks/Config.in b/openwrt/package/elinks/Config.in
new file mode 100644
index 0000000000..3e0b28cf10
--- /dev/null
+++ b/openwrt/package/elinks/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_ELINKS
+ prompt "elinks............................ A text based web browser"
+ tristate
+ default m if CONFIG_DEVEL
+ help
+ An advanced text based web browser
+
+ http://elinks.or.cz/
+
diff --git a/openwrt/package/elinks/Makefile b/openwrt/package/elinks/Makefile
new file mode 100644
index 0000000000..07fc51606c
--- /dev/null
+++ b/openwrt/package/elinks/Makefile
@@ -0,0 +1,56 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=elinks
+PKG_VERSION:=0.11.1
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://elinks.or.cz/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=c09d726075e4b5810fa07f8654088755
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,ELINKS,elinks,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+ x=`echo ac_cv_file_$(PKG_BUILD_DIR)/features.conf | tr [:blank:]-/. _` && export $${x}=yes && \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+ ac_cv_c_bigendian=no \
+ ac_cv_sizeof_off_t=8 \
+ ac_cv_file___features_conf=yes \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --disable-largefile\
+ --disable-formhist\
+ --disable-mailcap\
+ --disable-data\
+ --disable-uri-rewrite\
+ --enable-256-colors\
+ --disable-backtrace\
+ --enable-small\
+ --without-spidermonkey\
+ --without-x\
+ --disable-ipv6 \
+ $(DISABLE_NLS) \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+ $(MAKE) -C $(PKG_BUILD_DIR)\
+ CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld
+ touch $@
+
+$(IPKG_ELINKS):
+ mkdir -p $(IDIR_ELINKS)/usr/bin
+ $(CP) $(PKG_BUILD_DIR)/src/elinks $(IDIR_ELINKS)/usr/bin/
+ $(RSTRIP) $(IDIR_ELINKS)
+ $(IPKG_BUILD) $(IDIR_ELINKS) $(PACKAGE_DIR)
diff --git a/openwrt/package/elinks/ipkg/elinks.control b/openwrt/package/elinks/ipkg/elinks.control
new file mode 100644
index 0000000000..f3de4e564d
--- /dev/null
+++ b/openwrt/package/elinks/ipkg/elinks.control
@@ -0,0 +1,4 @@
+Package: elinks
+Priority: optional
+Section: text
+Description: An advanced text web browser
diff --git a/openwrt/package/fetchmail/Config.in b/openwrt/package/fetchmail/Config.in
new file mode 100644
index 0000000000..bc6cdfe8aa
--- /dev/null
+++ b/openwrt/package/fetchmail/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_FETCHMAIL
+ prompt "fetchmail......................... Remote mail retriever"
+ tristate
+ default m if CONFIG_DEVEL
+ help
+ Retrieves remote mail via POP/IMAP
+
+ Very useful in conjunction with mutt.
diff --git a/openwrt/package/fetchmail/Makefile b/openwrt/package/fetchmail/Makefile
new file mode 100644
index 0000000000..1ca6cd76cd
--- /dev/null
+++ b/openwrt/package/fetchmail/Makefile
@@ -0,0 +1,59 @@
+# $Id: Makefile 3112 2006-02-01 23:53:19Z mbm $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fetchmail
+PKG_VERSION:=6.2.5
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://www.catb.org/~esr/fetchmail/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=9956b30139edaa4f5f77c4d0dbd80225
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,FETCHMAIL,fetchmail,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ ac_cv_c_bigendian=no \
+ ac_cv_sizeof_off_t=8 \
+ ac_cv_sizeof_int=4 \
+ ac_cv_sizeof_long=4 \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --program-prefix="" \
+ --enable-fallback=procmail \
+ $(DISABLE_NLS) \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC=$(TARGET_CC)
+ touch $@
+
+$(IPKG_FETCHMAIL):
+ mkdir -p $(IDIR_FETCHMAIL)/usr/bin
+ $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_FETCHMAIL)/usr/bin/
+ $(RSTRIP) $(IDIR_FETCHMAIL)
+ $(IPKG_BUILD) $(IDIR_FETCHMAIL) $(PACKAGE_DIR)
diff --git a/openwrt/package/fetchmail/ipkg/fetchmail.control b/openwrt/package/fetchmail/ipkg/fetchmail.control
new file mode 100644
index 0000000000..ea664fa6e6
--- /dev/null
+++ b/openwrt/package/fetchmail/ipkg/fetchmail.control
@@ -0,0 +1,5 @@
+Package: fetchmail
+Priority: optional
+Section: text
+Depends:
+Description: Mail text client
diff --git a/openwrt/package/jamvm/Config.in b/openwrt/package/jamvm/Config.in
index befdfa9e6f..15af752312 100644
--- a/openwrt/package/jamvm/Config.in
+++ b/openwrt/package/jamvm/Config.in
@@ -1,15 +1,17 @@
config BR2_PACKAGE_JAMVM
- prompt "jamvm .............................A compact Java Virtual Machine"
+ prompt "jamvm ............................A compact Java Virtual Machine"
tristate
default m if CONFIG_DEVEL
select BR2_PACKAGE_ZLIB
select BR2_PACKAGE_LIBFFI_SABLE
select BR2_PACKAGE_LIBSABLEVM_CLASSPATH
help
- JamVM is a new Java Virtual Machine which conforms to the JVM specification version
- (blue book). In comparison to most other VM's (free and commercial) it is extremely
- small.However, unlike other small VMs (e.g. KVM) it is designed to support the full
- specification, and includes support for object finalisation, Soft/Weak/Phantom
- References, the Java Native Interface (JNI) and the Reflection API.
+ JamVM is a new Java Virtual Machine which conforms to the JVM
+ specification version (blue book). In comparison to most other VM's
+ (free and commercial) it is extremely small.However, unlike other
+ small VMs (e.g. KVM) it is designed to support the full
+ specification, and includes support for object finalisation,
+ Soft/Weak/Phantom References, the Java Native Interface (JNI) and the
+ Reflection API.
http://sourceforge.net/projects/jamvm
diff --git a/openwrt/package/mutt/Config.in b/openwrt/package/mutt/Config.in
new file mode 100644
index 0000000000..211d58c6e9
--- /dev/null
+++ b/openwrt/package/mutt/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_MUTT
+ prompt "mutt.............................. console mail client"
+ tristate
+ default m if CONFIG_DEVEL
+ select BR2_PACKAGE_LIBNCURSES
+ select BR2_PACKAGE_LIBOPENSSL
+ help
+ Mail client for the text console
+
+ http://www.mutt.org
+
diff --git a/openwrt/package/mutt/Makefile b/openwrt/package/mutt/Makefile
new file mode 100644
index 0000000000..b338963a74
--- /dev/null
+++ b/openwrt/package/mutt/Makefile
@@ -0,0 +1,63 @@
+# $Id: Makefile 3112 2006-02-01 23:53:19Z mbm $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mutt
+PKG_VERSION:=1.4.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=ftp://ftp.mutt.org/mutt/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)i.tar.gz
+PKG_MD5SUM:=710bd56d3c4c4bcd1403bc4e053f7476
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MUTT,mutt,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ ac_cv_c_bigendian=no \
+ ac_cv_sizeof_off_t=8 \
+ ac_cv_sizeof_int=4 \
+ ac_cv_sizeof_long=4 \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --program-prefix="" \
+ --includedir=. \
+ --oldincludedir=. \
+ --enable-pop \
+ --enable-imap \
+ --with-ssl \
+ $(DISABLE_NLS) \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC=$(TARGET_CC)
+ touch $@
+
+$(IPKG_MUTT):
+ mkdir -p $(IDIR_MUTT)/usr/bin
+ $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_MUTT)/usr/bin/
+ $(RSTRIP) $(IDIR_MUTT)
+ $(IPKG_BUILD) $(IDIR_MUTT) $(PACKAGE_DIR)
diff --git a/openwrt/package/mutt/ipkg/mutt.control b/openwrt/package/mutt/ipkg/mutt.control
new file mode 100644
index 0000000000..493074895f
--- /dev/null
+++ b/openwrt/package/mutt/ipkg/mutt.control
@@ -0,0 +1,5 @@
+Package: mutt
+Priority: optional
+Section: text
+Depends: libncurses, libopenssl
+Description: Mail text client
diff --git a/openwrt/package/procmail/Config.in b/openwrt/package/procmail/Config.in
new file mode 100644
index 0000000000..548b8e6001
--- /dev/null
+++ b/openwrt/package/procmail/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PROCMAIL
+ prompt "procmail.......................... mail processing tool"
+ tristate
+ default n
+ help
+ Procmail is able to process and classify incoming mail into
+ different mail boxes.
+
+ Very useful in conjunction with mutt.
+
+ http://www.procmail.org
diff --git a/openwrt/package/procmail/Makefile b/openwrt/package/procmail/Makefile
new file mode 100644
index 0000000000..ce7909cb39
--- /dev/null
+++ b/openwrt/package/procmail/Makefile
@@ -0,0 +1,33 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=procmail
+PKG_VERSION:=3.22
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://www.procmail.org/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=1678ea99b973eb77eda4ecf6acae53f1
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PROCMAIL,procmail,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) -C $(PKG_BUILD_DIR)/ init \
+ CC=$(TARGET_CC)
+
+ echo yes | $(MAKE) -C $(PKG_BUILD_DIR)/src/ procmail formail \
+ CC=$(TARGET_CC)
+ touch $@
+
+$(IPKG_PROCMAIL):
+ mkdir -p $(IDIR_PROCMAIL)/usr/bin
+ $(CP) $(PKG_BUILD_DIR)/src/procmail $(IDIR_PROCMAIL)/usr/bin/
+ $(CP) $(PKG_BUILD_DIR)/src/formail $(IDIR_PROCMAIL)/usr/bin/
+ $(RSTRIP) $(IDIR_PROCMAIL)
+ $(IPKG_BUILD) $(IDIR_PROCMAIL) $(PACKAGE_DIR)
diff --git a/openwrt/package/procmail/ipkg/procmail.control b/openwrt/package/procmail/ipkg/procmail.control
new file mode 100644
index 0000000000..6a87f9ff5e
--- /dev/null
+++ b/openwrt/package/procmail/ipkg/procmail.control
@@ -0,0 +1,4 @@
+Package: procmail
+Priority: optional
+Section: text
+Description: Mail processing tool