aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-03 23:22:08 +0200
committerDaniel Golle <daniel@makrotopia.org>2019-07-10 17:36:29 +0200
commit2f2a319f82ec86e2008fd056987d74189d5c147b (patch)
tree5f4109a93189e3c5374782287c6e8c34f1d79b78
parent9f990001653a0c45a17f15c1ed67ab91fa6aa91b (diff)
downloadupstream-2f2a319f82ec86e2008fd056987d74189d5c147b.tar.gz
upstream-2f2a319f82ec86e2008fd056987d74189d5c147b.tar.bz2
upstream-2f2a319f82ec86e2008fd056987d74189d5c147b.zip
ramips/mt7621: Synchronize Makefiles with DTS compatible
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds10
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network72
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/03_gpio_switches4
-rwxr-xr-xtarget/linux/ramips/base-files/etc/init.d/bootcount2
-rw-r--r--target/linux/ramips/base-files/etc/uci-defaults/09_fix-checksum2
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh81
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh12
-rw-r--r--target/linux/ramips/image/mt7621.mk143
8 files changed, 135 insertions, 191 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index b34fa8c978..a2ecc0fc69 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -164,7 +164,7 @@ dlink,dwr-922-e2)
ucidef_set_led_netdev "signalstrength" "signalstrength" "$boardname:green:sigstrength" "wwan0" "link"
ucidef_set_led_netdev "4g" "4g" "$boardname:green:4g" "wwan0" "tx rx"
;;
-dir-860l-b1)
+dlink,dir-860l-b1)
ucidef_set_led_netdev "wan" "wan" "$boardname:green:net" "eth0.2"
;;
netgear,ex2700|\
@@ -268,7 +268,7 @@ netgear,r6120)
ucidef_set_led_wlan "wlan2g" "WiFi 2.4GHz" "$boardname:green:wlan2g" "phy0tpt"
;;
gehua,ghl-r-001|\
-pbr-m1)
+d-team,pbr-m1)
ucidef_set_led_netdev "internet" "internet" "$boardname:blue:internet" "eth0.2"
;;
d-team,newifi-d2)
@@ -283,13 +283,13 @@ px-4885-4M|\
px-4885-8M)
set_wifi_led "px-4885:orange:wifi"
;;
-r6220|\
+netgear,r6220|\
netgear,r6350|\
-wndr3700v5)
+netgear,wndr3700-v5)
ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x10"
set_wifi_led "$boardname:green:wifi"
;;
-re350-v1)
+tplink,re350-v1)
ucidef_set_led_netdev "wifi2g" "Wifi 2.4G" "$boardname:blue:wifi2G" "wlan0"
ucidef_set_led_netdev "wifi5g" "Wifi 5G" "$boardname:blue:wifi5G" "wlan1"
ucidef_set_led_netdev "eth_act" "LAN act" "$boardname:green:eth_act" "eth0" "tx rx"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index e5bfa88f65..ee2ce3c1fb 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -31,10 +31,10 @@ ramips_setup_interfaces()
local board="$1"
case $board in
- 11acnas|\
+ wevo,11acnas|\
d-team,newifi-d2|\
dir-615-h1|\
- w2914nsv2|\
+ wevo,w2914ns-v2|\
zbtlink,zbt-we2026)
ucidef_add_switch "switch0" \
"0:lan:4" "1:lan:3" "2:lan:2" "3:lan:1" "4:wan:5" "6@eth0"
@@ -65,7 +65,7 @@ ramips_setup_interfaces()
ncs601w|\
omega2 | \
omega2p | \
- timecloud|\
+ thunder,timecloud|\
tplink,tl-wa801nd-v5|\
w150m|\
widora,neo-16m|\
@@ -97,18 +97,18 @@ ramips_setup_interfaces()
dlink,dwr-116-a1|\
dlink,dwr-921-c1|\
dlink,dwr-922-e2|\
- ew1200|\
- firewrt|\
+ afoundry,ew1200|\
+ firefly,firewrt|\
hc5661a|\
- hc5962|\
+ hiwifi,hc5962|\
hlk-rm04|\
- k2p|\
+ phicomm,k2p|\
kn|\
zyxel,keenetic-omni|\
mac1200rv2|\
xiaomi,miwifi-mini|\
miwifi-nano|\
- mt7621|\
+ mediatek,mt7621-eval-board|\
mt7628|\
mtc,wr1201|\
planex,mzk-750dhp|\
@@ -116,38 +116,38 @@ ramips_setup_interfaces()
nixcore-x1-8M|\
nixcore-x1-16M|\
ohyeah,oy-0001|\
- pbr-m1|\
+ d-team,pbr-m1|\
phicomm,psg1208|\
phicomm,psg1218a|\
- r6220|\
+ netgear,r6220|\
netgear,r6350|\
asus,rt-n12p|\
- sap-g3200u3|\
- sk-wb8|\
+ storylink,sap-g3200u3|\
+ samknows,whitebox-v8|\
telco-electronics,x1|\
totolink,a7000r|\
totolink,lr1200|\
unielec,u7621-06-256m-16m|\
unielec,u7621-06-512m-64m|\
- vr500|\
+ planex,vr500|\
wavlink,wl-wn570ha1|\
wavlink,wl-wn575a3|\
- wf-2881|\
+ netis,wf-2881|\
whr-g300n|\
mqmaker,witi-256m|\
mqmaker,witi-512m|\
- wndr3700v5|\
+ netgear,wndr3700-v5|\
youku,yk1|\
youku,yk-l2|\
zbtlink,zbt-ape522ii|\
- zbt-we1326|\
+ zbtlink,zbt-we1326|\
zbtlink,zbt-we826-e|\
zbtlink,zbt-we3526|\
zbtlink,zbt-we826-16m|\
zbtlink,zbt-we826-32m|\
- zbt-wg2626|\
- zbt-wg3526-16M|\
- zbt-wg3526-32M|\
+ zbtlink,zbt-wg2626|\
+ zbtlink,zbt-wg3526-16m|\
+ zbtlink,zbt-wg3526-32m|\
zbtlink,zbt-wr8305rt)
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "6@eth0"
@@ -195,8 +195,8 @@ ramips_setup_interfaces()
;;
buffalo,whr-300hp2|\
buffalo,whr-600d|\
- wsr-1166|\
- wsr-600)
+ buffalo,wsr-1166dhp|\
+ buffalo,wsr-600dhp)
ucidef_add_switch "switch0" \
"0:lan:1" "1:lan:2" "2:lan:3" "3:lan:4" "4:wan:5" "6@eth0"
;;
@@ -248,8 +248,8 @@ ramips_setup_interfaces()
tl-wr841n-v13|\
tplink,tl-wr841n-v14|\
u7628-01-128M-16M|\
- ubnt-erx|\
- ubnt-erx-sfp|\
+ ubiquiti,edgerouterx|\
+ ubiquiti,edgerouterx-sfp|\
ur-326n4g|\
wrtnode,wrtnode|\
wrtnode2p | \
@@ -265,7 +265,7 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"1:lan:3" "2:lan:4" "3:lan:1" "4:lan:2" "0:wan" "6@eth0"
;;
- dir-860l-b1|\
+ dlink,dir-860l-b1|\
elecom,wrc-1167ghbk2-s|\
elecom,wrc-2533gst|\
elecom,wrc-1900gst|\
@@ -375,7 +375,7 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"0:lan" "4:lan" "6t@eth0"
;;
- newifi-d1)
+ lenovo,newifi-d1)
ucidef_add_switch "switch0" \
"1:lan:2" "2:lan:1" "4:wan" "6@eth0"
;;
@@ -386,11 +386,11 @@ ramips_setup_interfaces()
dlink,dir-510l|\
glinet,vixmini|\
netgear,ex6150|\
- re350-v1)
+ tplink,re350-v1)
ucidef_add_switch "switch0" \
"0:lan" "6@eth0"
;;
- re6500)
+ linksys,re6500)
ucidef_add_switch "switch0" \
"0:lan:1" "1:lan:2" "2:lan:3" "3:lan:4" "6@eth0"
;;
@@ -543,7 +543,7 @@ ramips_setup_macs()
lan_mac=$(mtd_get_mac_ascii nvram lanmac)
wan_mac=$(mtd_get_mac_ascii nvram wanmac)
;;
- dir-860l-b1)
+ dlink,dir-860l-b1)
lan_mac=$(mtd_get_mac_ascii factory lanmac)
wan_mac=$(mtd_get_mac_ascii factory wanmac)
;;
@@ -567,7 +567,7 @@ ramips_setup_macs()
elecom,wrc-1167ghbk2-s|\
elecom,wrc-2533gst|\
elecom,wrc-1900gst|\
- sk-wb8)
+ samknows,whitebox-v8)
wan_mac=$(mtd_get_mac_binary factory 57350)
;;
gl-mt300n-v2|\
@@ -578,7 +578,7 @@ ramips_setup_macs()
hiwifi,hc5761|\
hiwifi,hc5861|\
hc5661a|\
- hc5962|\
+ hiwifi,hc5962|\
hiwifi,hc5861b)
lan_mac=`mtd_get_mac_ascii bdinfo "Vfac_mac "`
[ -n "$lan_mac" ] || lan_mac=$(cat /sys/class/net/eth0/address)
@@ -617,7 +617,7 @@ ramips_setup_macs()
lan_mac=$(cat /sys/class/net/eth0/address)
lan_mac=$(macaddr_add "$lan_mac" -2)
;;
- newifi-d1)
+ lenovo,newifi-d1)
lan_mac=$(cat /sys/class/net/eth0/address)
lan_mac=$(macaddr_add "$lan_mac" 2)
;;
@@ -631,9 +631,9 @@ ramips_setup_macs()
lan_mac=$(mtd_get_mac_binary factory 40)
wan_mac=$(mtd_get_mac_binary factory 46)
;;
- r6220|\
+ netgear,r6220|\
netgear,r6350|\
- wndr3700v5)
+ netgear,wndr3700-v5)
wan_mac=$(mtd_get_mac_binary factory 4)
lan_mac=$(macaddr_add "$wan_mac" 1)
;;
@@ -656,7 +656,7 @@ ramips_setup_macs()
lan_mac=$(mtd_get_mac_ascii u-boot-env LAN_MAC_ADDR)
wan_mac=$(mtd_get_mac_ascii u-boot-env WAN_MAC_ADDR)
;;
- vr500)
+ planex,vr500)
lan_mac=$(mtd_get_mac_binary factory 57344)
wan_mac=$(mtd_get_mac_binary factory 57350)
;;
@@ -665,7 +665,7 @@ ramips_setup_macs()
wan_mac=$(macaddr_add "$lan_mac" 5)
;;
wcr-1166ds|\
- wsr-1166)
+ buffalo,wsr-1166dhp)
local index="$(find_mtd_index "board_data")"
wan_mac="$(grep -m1 mac= "/dev/mtd${index}" | cut -d= -f2)"
lan_mac=$wan_mac
@@ -676,7 +676,7 @@ ramips_setup_macs()
buffalo,whr-1166d|\
buffalo,whr-300hp2|\
buffalo,whr-600d|\
- wsr-600)
+ buffalo,wsr-600dhp)
wan_mac=$(mtd_get_mac_binary factory 4)
lan_mac=$wan_mac
;;
diff --git a/target/linux/ramips/base-files/etc/board.d/03_gpio_switches b/target/linux/ramips/base-files/etc/board.d/03_gpio_switches
index 1406f91f8f..9acd78ea0b 100755
--- a/target/linux/ramips/base-files/etc/board.d/03_gpio_switches
+++ b/target/linux/ramips/base-files/etc/board.d/03_gpio_switches
@@ -25,10 +25,10 @@ mikrotik,rb750gr3)
telco-electronics,x1)
ucidef_add_gpio_switch "modem_reset" "Modem Reset" "16"
;;
-ubnt-erx)
+ubiquiti,edgerouterx)
ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "0"
;;
-ubnt-erx-sfp)
+ubiquiti,edgerouterx-sfp)
ucidef_add_gpio_switch "poe_power_port0" "PoE Power Port0" "496"
ucidef_add_gpio_switch "poe_power_port1" "PoE Power Port1" "497"
ucidef_add_gpio_switch "poe_power_port2" "PoE Power Port2" "498"
diff --git a/target/linux/ramips/base-files/etc/init.d/bootcount b/target/linux/ramips/base-files/etc/init.d/bootcount
index 0f260fa3fc..60b93f72b3 100755
--- a/target/linux/ramips/base-files/etc/init.d/bootcount
+++ b/target/linux/ramips/base-files/etc/init.d/bootcount
@@ -6,7 +6,7 @@ start() {
. /lib/functions.sh
local board=$(board_name)
- if [ $board = "sk-wb8" ]; then
+ if [ $board = "samknows,whitebox-v8" ]; then
fw_setenv bootcount 0
fi
}
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/09_fix-checksum b/target/linux/ramips/base-files/etc/uci-defaults/09_fix-checksum
index 8fa668c2e2..48ffcdd01f 100644
--- a/target/linux/ramips/base-files/etc/uci-defaults/09_fix-checksum
+++ b/target/linux/ramips/base-files/etc/uci-defaults/09_fix-checksum
@@ -17,7 +17,7 @@ case "$board" in
cy-swr1100 | \
dlink,dch-m225|\
dir-645 | \
-dir-860l-b1)
+dlink,dir-860l-b1)
fix_checksum seama
;;
dlink,dap-1522-a1)
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index fdfb454d79..2ad92fd26b 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -10,9 +10,6 @@ ramips_board_detect() {
machine=$(awk 'BEGIN{FS="[ \t]+:[ \t]"} /machine/ {print $2}' /proc/cpuinfo)
case "$machine" in
- *"11AC NAS Router")
- name="11acnas"
- ;;
*"3G150B")
name="3g150b"
;;
@@ -124,9 +121,6 @@ ramips_board_detect() {
*"DIR-645")
name="dir-645"
;;
- *"DIR-860L B1")
- name="dir-860l-b1"
- ;;
*"DuZun DM06")
name="duzun-dm06"
;;
@@ -136,9 +130,6 @@ ramips_board_detect() {
*"ESR-9753")
name="esr-9753"
;;
- *"EW1200")
- name="ew1200"
- ;;
*"F5D8235 v1")
name="f5d8235-v1"
;;
@@ -148,9 +139,6 @@ ramips_board_detect() {
*"F7C027")
name="f7c027"
;;
- *"FireWRT")
- name="firewrt"
- ;;
*"Fonera 2.0N")
name="fonera20n"
;;
@@ -163,9 +151,6 @@ ramips_board_detect() {
*"HC5661A")
name="hc5661a"
;;
- *"HC5962")
- name="hc5962"
- ;;
*"HG255D")
name="hg255d"
;;
@@ -193,9 +178,6 @@ ramips_board_detect() {
*"JHR-N926R")
name="jhr-n926r"
;;
- *"K2P")
- name="k2p"
- ;;
*"M3")
name="m3"
;;
@@ -235,9 +217,6 @@ ramips_board_detect() {
*"MR-102N")
name="mr-102n"
;;
- *"MT7621 evaluation"*)
- name="mt7621"
- ;;
*"MT7628AN evaluation"*)
name="mt7628"
;;
@@ -259,9 +238,6 @@ ramips_board_detect() {
*"NBG-419N v2")
name="nbg-419n2"
;;
- *"Newifi-D1")
- name="newifi-d1"
- ;;
*"NCS601W")
name="ncs601w"
;;
@@ -283,9 +259,6 @@ ramips_board_detect() {
*"PBR-D1")
name="pbr-d1"
;;
- *"PBR-M1")
- name="pbr-m1"
- ;;
*"PSR-680W"*)
name="psr-680w"
;;
@@ -298,15 +271,6 @@ ramips_board_detect() {
*"PX-4885 (8M)")
name="px-4885-8M"
;;
- *"R6220")
- name="r6220"
- ;;
- *"RE350 v1")
- name="re350-v1"
- ;;
- *"RE6500")
- name="re6500"
- ;;
*"RN502J")
name="xdxrn502j"
;;
@@ -334,12 +298,6 @@ ramips_board_detect() {
*"RUT5XX")
name="rut5xx"
;;
- *"SamKnows Whitebox 8")
- name="sk-wb8"
- ;;
- *"SAP-G3200U3")
- name="sap-g3200u3"
- ;;
*"SL-R7205"*)
name="sl-r7205"
;;
@@ -355,9 +313,6 @@ ramips_board_detect() {
*"TEW-714TRU")
name="tew-714tru"
;;
- *"Timecloud")
- name="timecloud"
- ;;
*"TL-WR840N v4")
name="tl-wr840n-v4"
;;
@@ -370,12 +325,6 @@ ramips_board_detect() {
*"U7628-01 (128M RAM/16M flash)")
name="u7628-01-128M-16M"
;;
- *"UBNT-ERX")
- name="ubnt-erx"
- ;;
- *"UBNT-ERX-SFP")
- name="ubnt-erx-sfp"
- ;;
*"UR-326N4G")
name="ur-326n4g"
;;
@@ -400,15 +349,9 @@ ramips_board_detect() {
*"VoCore2-Lite")
name="vocore2lite"
;;
- *"VR500")
- name="vr500"
- ;;
*"W150M")
name="w150m"
;;
- *"W2914NS v2")
- name="w2914nsv2"
- ;;
*"W306R V2.0")
name="w306r-v20"
;;
@@ -421,9 +364,6 @@ ramips_board_detect() {
*"WCR-150GN")
name="wcr-150gn"
;;
- *"WF-2881")
- name="wf-2881"
- ;;
*"WHR-G300N")
name="whr-g300n"
;;
@@ -454,9 +394,6 @@ ramips_board_detect() {
*"WNCE2001")
name="wnce2001"
;;
- *"WNDR3700v5")
- name="wndr3700v5"
- ;;
*"WR512-3GN (4M)")
name="wr512-3gn-4M"
;;
@@ -472,12 +409,6 @@ ramips_board_detect() {
*"WRTnode2P")
name="wrtnode2p"
;;
- *"WSR-1166DHP")
- name="wsr-1166"
- ;;
- *"WSR-600DHP")
- name="wsr-600"
- ;;
*"WT1520 (4M)")
name="wt1520-4M"
;;
@@ -493,18 +424,6 @@ ramips_board_detect() {
*"X8")
name="x8"
;;
- *"ZBT-WE1326")
- name="zbt-we1326"
- ;;
- *"ZBT-WG2626")
- name="zbt-wg2626"
- ;;
- *"ZBT-WG3526 (16M)")
- name="zbt-wg3526-16M"
- ;;
- *"ZBT-WG3526 (32M)")
- name="zbt-wg3526-32M"
- ;;
*"ZyXEL Keenetic")
name="kn"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 65522b23fd..c71ffc0321 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -25,8 +25,8 @@ platform_nand_pre_upgrade() {
local board=$(board_name)
case "$board" in
- ubnt-erx|\
- ubnt-erx-sfp)
+ ubiquiti,edgerouterx|\
+ ubiquiti,edgerouterx-sfp)
platform_upgrade_ubnt_erx "$ARGV"
;;
esac
@@ -36,11 +36,11 @@ platform_do_upgrade() {
local board=$(board_name)
case "$board" in
- hc5962|\
- r6220|\
+ hiwifi,hc5962|\
+ netgear,r6220|\
netgear,r6350|\
- ubnt-erx|\
- ubnt-erx-sfp|\
+ ubiquiti,edgerouterx|\
+ ubiquiti,edgerouterx-sfp|\
xiaomi,mir3g|\
xiaomi,mir3p)
nand_do_upgrade "$ARGV"
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 69f0e279d8..5fb07e17eb 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -84,16 +84,17 @@ define Build/ubnt-erx-factory-image
fi
endef
-define Device/11acnas
+define Device/wevo_11acnas
DTS := 11ACNAS
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := WeVO
DEVICE_MODEL := 11AC NAS Router
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += 11acnas
endef
-TARGET_DEVICES += 11acnas
+TARGET_DEVICES += wevo_11acnas
-define Device/dir-860l-b1
+define Device/dlink_dir-860l-b1
$(Device/seama)
DTS := DIR-860L-B1
BLOCKSIZE := 64k
@@ -104,8 +105,9 @@ define Device/dir-860l-b1
DEVICE_MODEL := DIR-860L
DEVICE_VARIANT := B1
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += dir-860l-b1
endef
-TARGET_DEVICES += dir-860l-b1
+TARGET_DEVICES += dlink_dir-860l-b1
define Device/mediatek_ap-mt7621a-v60
DTS := AP-MT7621A-V60
@@ -160,7 +162,7 @@ define Device/elecom_wrc-1900gst
endef
TARGET_DEVICES += elecom_wrc-1900gst
-define Device/ew1200
+define Device/afoundry_ew1200
DTS := EW1200
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := AFOUNDRY
@@ -168,17 +170,19 @@ define Device/ew1200
DEVICE_PACKAGES := \
kmod-ata-core kmod-ata-ahci kmod-mt76x2 kmod-mt7603 kmod-usb3 \
kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += ew1200
endef
-TARGET_DEVICES += ew1200
+TARGET_DEVICES += afoundry_ew1200
-define Device/firewrt
+define Device/firefly_firewrt
DTS := FIREWRT
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := Firefly
DEVICE_MODEL := FireWRT
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += firewrt
endef
-TARGET_DEVICES += firewrt
+TARGET_DEVICES += firefly_firewrt
define Device/gehua_ghl-r-001
DTS := GHL-R-001
@@ -208,7 +212,7 @@ define Device/gnubee_gb-pc2
endef
TARGET_DEVICES += gnubee_gb-pc2
-define Device/hc5962
+define Device/hiwifi_hc5962
DTS := HC5962
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -221,8 +225,9 @@ define Device/hc5962
DEVICE_VENDOR := HiWiFi
DEVICE_MODEL := HC5962
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 wpad-basic
+ SUPPORTED_DEVICES += hc5962
endef
-TARGET_DEVICES += hc5962
+TARGET_DEVICES += hiwifi_hc5962
define Device/iodata_wn-ax1167gr
DTS := WN-AX1167GR
@@ -244,13 +249,14 @@ define Device/iodata_wn-gx300gr
endef
TARGET_DEVICES += iodata_wn-gx300gr
-define Device/k2p
+define Device/phicomm_k2p
DTS := K2P
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := Phicomm
DEVICE_MODEL := K2P
+ SUPPORTED_DEVICES += k2p
endef
-TARGET_DEVICES += k2p
+TARGET_DEVICES += phicomm_k2p
define Device/totolink_a7000r
DTS := TOTOLINK-A7000R
@@ -300,24 +306,26 @@ define Device/xiaomi_mir3g
endef
TARGET_DEVICES += xiaomi_mir3g
-define Device/mt7621
+define Device/mediatek_mt7621-eval-board
DTS := MT7621
BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_VENDOR := MediaTek
DEVICE_MODEL := MT7621 EVB
+ SUPPORTED_DEVICES += mt7621
endef
-TARGET_DEVICES += mt7621
+TARGET_DEVICES += mediatek_mt7621-eval-board
-define Device/newifi-d1
+define Device/lenovo_newifi-d1
DTS := Newifi-D1
IMAGE_SIZE := $(ralink_default_fw_size_32M)
DEVICE_VENDOR := Newifi
DEVICE_MODEL := D1
DEVICE_PACKAGES := \
kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += newifi-d1
endef
-TARGET_DEVICES += newifi-d1
+TARGET_DEVICES += lenovo_newifi-d1
define Device/d-team_newifi-d2
DTS := Newifi-D2
@@ -329,7 +337,7 @@ define Device/d-team_newifi-d2
endef
TARGET_DEVICES += d-team_newifi-d2
-define Device/pbr-m1
+define Device/d-team_pbr-m1
DTS := PBR-M1
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := PandoraBox
@@ -337,10 +345,11 @@ define Device/pbr-m1
DEVICE_PACKAGES := \
kmod-ata-core kmod-ata-ahci kmod-mt7603 kmod-mt76x2 kmod-sdhci-mt7620 \
kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += pbr-m1
endef
-TARGET_DEVICES += pbr-m1
+TARGET_DEVICES += d-team_pbr-m1
-define Device/r6220
+define Device/netgear_r6220
DTS := R6220
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -355,8 +364,9 @@ define Device/r6220
DEVICE_MODEL := R6220
DEVICE_PACKAGES := \
kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += r6220
endef
-TARGET_DEVICES += r6220
+TARGET_DEVICES += netgear_r6220
define Device/netgear_ex6150
DTS := EX6150
@@ -434,7 +444,7 @@ define Device/mtc_wr1201
endef
TARGET_DEVICES += mtc_wr1201
-define Device/re350-v1
+define Device/tplink_re350-v1
DTS := RE350
DEVICE_VENDOR := TP-Link
DEVICE_MODEL := RE350
@@ -449,26 +459,29 @@ define Device/re350-v1
IMAGES += factory.bin
IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
+ SUPPORTED_DEVICES += re350-v1
endef
-TARGET_DEVICES += re350-v1
+TARGET_DEVICES += tplink_re350-v1
-define Device/re6500
+define Device/linksys_re6500
DTS := RE6500
DEVICE_VENDOR := Linksys
DEVICE_MODEL := RE6500
DEVICE_PACKAGES := kmod-mt76x2 wpad-basic
+ SUPPORTED_DEVICES += re6500
endef
-TARGET_DEVICES += re6500
+TARGET_DEVICES += linksys_re6500
-define Device/sap-g3200u3
+define Device/storylink_sap-g3200u3
DTS := SAP-G3200U3
DEVICE_VENDOR := STORYLiNK
DEVICE_MODEL := SAP-G3200U3
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += sap-g3200u3
endef
-TARGET_DEVICES += sap-g3200u3
+TARGET_DEVICES += storylink_sap-g3200u3
-define Device/sk-wb8
+define Device/samknows_whitebox-v8
DTS := SK-WB8
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := SamKnows
@@ -476,8 +489,9 @@ define Device/sk-wb8
DEVICE_PACKAGES := \
kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport \
uboot-envtools wpad-basic
+ SUPPORTED_DEVICES += sk-wb8
endef
-TARGET_DEVICES += sk-wb8
+TARGET_DEVICES += samknows_whitebox-v8
define Device/telco-electronics_x1
DTS := Telco-Electronics-X1
@@ -488,15 +502,16 @@ define Device/telco-electronics_x1
endef
TARGET_DEVICES += telco-electronics_x1
-define Device/timecloud
+define Device/thunder_timecloud
DTS := Timecloud
DEVICE_VENDOR := Thunder
DEVICE_MODEL := Timecloud
DEVICE_PACKAGES := kmod-usb3
+ SUPPORTED_DEVICES += timecloud
endef
-TARGET_DEVICES += timecloud
+TARGET_DEVICES += thunder_timecloud
-define Device/ubnt-erx
+define Device/ubiquiti_edgerouterx
DTS := UBNT-ERX
FILESYSTEMS := squashfs
KERNEL_SIZE := 3145728
@@ -504,17 +519,19 @@ define Device/ubnt-erx
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := EdgeRouter X
+ SUPPORTED_DEVICES += ubnt-erx
endef
-TARGET_DEVICES += ubnt-erx
+TARGET_DEVICES += ubiquiti_edgerouterx
-define Device/ubnt-erx-sfp
- $(Device/ubnt-erx)
+define Device/ubiquiti_edgerouterx-sfp
+ $(Device/ubiquiti_edgerouterx)
DTS := UBNT-ERX-SFP
DEVICE_VENDOR := Ubiquiti
DEVICE_MODEL := EdgeRouter X-SFP
DEVICE_PACKAGES += kmod-i2c-algo-pca kmod-gpio-pca953x kmod-i2c-gpio-custom
+ SUPPORTED_DEVICES += ubnt-erx-sfp
endef
-TARGET_DEVICES += ubnt-erx-sfp
+TARGET_DEVICES += ubiquiti_edgerouterx-sfp
define Device/unielec_u7621-06-256m-16m
DTS := U7621-06-256M-16M
@@ -537,16 +554,17 @@ define Device/unielec_u7621-06-512m-64m
endef
TARGET_DEVICES += unielec_u7621-06-512m-64m
-define Device/vr500
+define Device/planex_vr500
DTS := VR500
IMAGE_SIZE := 66453504
DEVICE_VENDOR := Planex
DEVICE_MODEL := VR500
DEVICE_PACKAGES := kmod-usb3
+ SUPPORTED_DEVICES += vr500
endef
-TARGET_DEVICES += vr500
+TARGET_DEVICES += planex_vr500
-define Device/w2914nsv2
+define Device/wevo_w2914ns-v2
DTS := W2914NSV2
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := WeVO
@@ -554,10 +572,11 @@ define Device/w2914nsv2
DEVICE_VARIANT := v2
DEVICE_PACKAGES := \
kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += w2914nsv2
endef
-TARGET_DEVICES += w2914nsv2
+TARGET_DEVICES += wevo_w2914ns-v2
-define Device/wf-2881
+define Device/netis_wf-2881
DTS := WF-2881
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -569,8 +588,9 @@ define Device/wf-2881
DEVICE_VENDOR := NETIS
DEVICE_MODEL := WF-2881
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += wf-2881
endef
-TARGET_DEVICES += wf-2881
+TARGET_DEVICES += netis_wf-2881
define Device/mqmaker_witi-256m
DTS := WITI-256M
@@ -597,7 +617,7 @@ define Device/mqmaker_witi-512m
endef
TARGET_DEVICES += mqmaker_witi-512m
-define Device/wndr3700v5
+define Device/netgear_wndr3700-v5
DTS := WNDR3700V5
BLOCKSIZE := 64k
IMAGE_SIZE := 15232k
@@ -614,8 +634,9 @@ define Device/wndr3700v5
DEVICE_VARIANT := v5
DEVICE_PACKAGES := \
kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += wndr3700v5
endef
-TARGET_DEVICES += wndr3700v5
+TARGET_DEVICES += netgear_wndr3700-v5
define Device/youhua_wr1200js
DTS := WR1200JS
@@ -637,34 +658,37 @@ define Device/youku_yk-l2
endef
TARGET_DEVICES += youku_yk-l2
-define Device/wsr-1166
+define Device/buffalo_wsr-1166dhp
DTS := WSR-1166
IMAGE/sysupgrade.bin := trx | pad-rootfs | append-metadata
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := Buffalo
- DEVICE_MODEL := WSR-1166
+ DEVICE_MODEL := WSR-1166DHP
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 wpad-basic
+ SUPPORTED_DEVICES += wsr-1166
endef
-TARGET_DEVICES += wsr-1166
+TARGET_DEVICES += buffalo_wsr-1166dhp
-define Device/wsr-600
+define Device/buffalo_wsr-600dhp
DTS := WSR-600
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := Buffalo
- DEVICE_MODEL := WSR-600
+ DEVICE_MODEL := WSR-600DHP
DEVICE_PACKAGES := kmod-mt7603 kmod-rt2800-pci wpad-basic
+ SUPPORTED_DEVICES += wsr-600
endef
-TARGET_DEVICES += wsr-600
+TARGET_DEVICES += buffalo_wsr-600dhp
-define Device/zbt-we1326
+define Device/zbtlink_zbt-we1326
DTS := ZBT-WE1326
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := ZBT
DEVICE_MODEL := ZBT-WE1326
DEVICE_PACKAGES := \
kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-sdhci-mt7620 wpad-basic
+ SUPPORTED_DEVICES += zbt-we1326
endef
-TARGET_DEVICES += zbt-we1326
+TARGET_DEVICES += zbtlink_zbt-we1326
define Device/zbtlink_zbt-we3526
DTS := ZBT-WE3526
@@ -677,7 +701,7 @@ define Device/zbtlink_zbt-we3526
endef
TARGET_DEVICES += zbtlink_zbt-we3526
-define Device/zbt-wg2626
+define Device/zbtlink_zbt-wg2626
DTS := ZBT-WG2626
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_VENDOR := ZBT
@@ -685,34 +709,35 @@ define Device/zbt-wg2626
DEVICE_PACKAGES := \
kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-mt76x2 kmod-usb3 \
kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += zbt-wg2626
endef
-TARGET_DEVICES += zbt-wg2626
+TARGET_DEVICES += zbtlink_zbt-wg2626
-define Device/zbt-wg3526-16M
+define Device/zbtlink_zbt-wg3526-16m
DTS := ZBT-WG3526-16M
IMAGE_SIZE := $(ralink_default_fw_size_16M)
- SUPPORTED_DEVICES += zbt-wg3526
DEVICE_VENDOR := ZBT
DEVICE_MODEL := ZBT-WG3526
DEVICE_VARIANT := 16M
DEVICE_PACKAGES := \
kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += zbt-wg3526 zbt-wg3526-16M
endef
-TARGET_DEVICES += zbt-wg3526-16M
+TARGET_DEVICES += zbtlink_zbt-wg3526-16m
-define Device/zbt-wg3526-32M
+define Device/zbtlink_zbt-wg3526-32m
DTS := ZBT-WG3526-32M
IMAGE_SIZE := $(ralink_default_fw_size_32M)
- SUPPORTED_DEVICES += ac1200pro
DEVICE_VENDOR := ZBT
DEVICE_MODEL := ZBT-WG3526
DEVICE_VARIANT := 32M
DEVICE_PACKAGES := \
kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+ SUPPORTED_DEVICES += ac1200pro zbt-wg3526-32M
endef
-TARGET_DEVICES += zbt-wg3526-32M
+TARGET_DEVICES += zbtlink_zbt-wg3526-32m
define Device/asiarf_ap7621-001
DTS := AP7621-001