aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-04-20 12:27:34 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-04-20 12:27:34 +0000
commit2dcb4708a86f6b34d7c6d78aab771938479bb539 (patch)
treef278146a86edd75065d6c04fc0fff96241b67469
parent64b8d6ae89edbe57f93bb88080d39d1dcceb7301 (diff)
downloadupstream-2dcb4708a86f6b34d7c6d78aab771938479bb539.tar.gz
upstream-2dcb4708a86f6b34d7c6d78aab771938479bb539.tar.bz2
upstream-2dcb4708a86f6b34d7c6d78aab771938479bb539.zip
add hidp support
SVN-Revision: 15293
-rw-r--r--package/kernel/modules/other.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 60b6e037b8..69f0cb7e5f 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -243,13 +243,15 @@ define KernelPackage/bluetooth
CONFIG_BLUEZ_BNEP \
CONFIG_BLUEZ_HCIUART \
CONFIG_BLUEZ_HCIUSB \
+ CONFIG_BLUEZ_HIDP \
CONFIG_BT \
CONFIG_BT_L2CAP \
CONFIG_BT_SCO \
CONFIG_BT_RFCOMM \
CONFIG_BT_BNEP \
CONFIG_BT_HCIUSB \
- CONFIG_BT_HCIUART
+ CONFIG_BT_HCIUART \
+ CONFIG_BT_HIDP
endef
define KernelPackage/bluetooth/2.4
@@ -287,9 +289,10 @@ define KernelPackage/bluetooth/2.6
$(LINUX_DIR)/net/bluetooth/sco.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/net/bluetooth/rfcomm/rfcomm.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/net/bluetooth/bnep/bnep.$(LINUX_KMOD_SUFFIX) \
+ $(LINUX_DIR)/net/bluetooth/hidp/hidp.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/drivers/bluetooth/hci_uart.$(LINUX_KMOD_SUFFIX) \
$(LINUX_DIR)/drivers/bluetooth/hci_usb.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hci_uart hci_usb)
+ AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hidp hci_uart hci_usb)
endef
define KernelPackage/bluetooth/description