aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-01-18 12:32:57 +0100
committerJo-Philipp Wich <jo@mein.io>2019-01-19 14:31:56 +0100
commit2d9d57b9de230e1f397c1396f4fb7dfae34d3855 (patch)
treed80c10e4e44c4b81a5d453db222094529224bb7a
parent797e5c1c48e6a5b8866504ea42bd7298c63ad3d5 (diff)
downloadupstream-2d9d57b9de230e1f397c1396f4fb7dfae34d3855.tar.gz
upstream-2d9d57b9de230e1f397c1396f4fb7dfae34d3855.tar.bz2
upstream-2d9d57b9de230e1f397c1396f4fb7dfae34d3855.zip
build: rename .packagesubdirs to .packageauxvars
Subsequent commits will put more auxiliary information into this file, such as the per-package ABI version, so rename the metadata script subcommand and file names accordingly. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--include/feeds.mk2
-rw-r--r--include/toplevel.mk4
-rwxr-xr-xscripts/package-metadata.pl6
3 files changed, 6 insertions, 6 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index d20cdfe069..a908a5720a 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -6,7 +6,7 @@
# See /LICENSE for more information.
#
--include $(TMP_DIR)/.packagesubdirs
+-include $(TMP_DIR)/.packageauxvars
FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
FEEDS_AVAILABLE:=$(sort $(FEEDS_INSTALLED) $(shell $(SCRIPT_DIR)/feeds list -n))
diff --git a/include/toplevel.mk b/include/toplevel.mk
index b57dcd8544..36f790f807 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -88,9 +88,9 @@ prepare-tmpinfo: FORCE
f=tmp/.$${type}info; t=tmp/.config-$${type}.in; \
[ "$$t" -nt "$$f" ] || ./scripts/$${type}-metadata.pl $(_ignore) config "$$f" > "$$t" || { rm -f "$$t"; echo "Failed to build $$t"; false; break; }; \
done
- [ tmp/.config-feeds.in -nt tmp/.packagesubdirs ] || ./scripts/feeds feed_config > tmp/.config-feeds.in
+ [ tmp/.config-feeds.in -nt tmp/.packageauxvars ] || ./scripts/feeds feed_config > tmp/.config-feeds.in
./scripts/package-metadata.pl mk tmp/.packageinfo > tmp/.packagedeps || { rm -f tmp/.packagedeps; false; }
- ./scripts/package-metadata.pl subdirs tmp/.packageinfo > tmp/.packagesubdirs || { rm -f tmp/.packagesubdirs; false; }
+ ./scripts/package-metadata.pl pkgaux tmp/.packageinfo > tmp/.packageauxvars || { rm -f tmp/.packageauxvars; false; }
touch $(TOPDIR)/tmp/.build
.config: ./scripts/config/conf $(if $(CONFIG_HAVE_DOT_CONFIG),,prepare-tmpinfo)
diff --git a/scripts/package-metadata.pl b/scripts/package-metadata.pl
index 53bb45a62c..b8c5de298a 100755
--- a/scripts/package-metadata.pl
+++ b/scripts/package-metadata.pl
@@ -509,7 +509,7 @@ sub gen_package_source() {
}
}
-sub gen_package_subdirs() {
+sub gen_package_auxiliary() {
parse_package_metadata($ARGV[0]) or exit 1;
foreach my $name (sort {uc($a) cmp uc($b)} keys %package) {
my $pkg = $package{$name};
@@ -565,7 +565,7 @@ sub parse_command() {
/^config$/ and return gen_package_config();
/^kconfig/ and return gen_kconfig_overrides();
/^source$/ and return gen_package_source();
- /^subdirs$/ and return gen_package_subdirs();
+ /^pkgaux$/ and return gen_package_auxiliary();
/^license$/ and return gen_package_license(0);
/^licensefull$/ and return gen_package_license(1);
/^usergroup$/ and return gen_usergroup_list();
@@ -577,7 +577,7 @@ Available Commands:
$0 config [file] Package metadata in Kconfig format
$0 kconfig [file] [config] [patchver] Kernel config overrides
$0 source [file] Package source file information
- $0 subdirs [file] Package subdir information in makefile format
+ $0 pkgaux [file] Package auxiliary variables in makefile format
$0 license [file] Package license information
$0 licensefull [file] Package license information (full list)
$0 usergroup [file] Package usergroup allocation list