aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2017-05-29 09:41:15 +0200
committerJohn Crispin <john@phrozen.org>2017-05-29 09:57:18 +0200
commit2cf4e3c420ef452e6a687615ab865eae200ed89a (patch)
tree31478f660925feda7cebcdee048a75853e8c6df2
parent82f7fd745715c647685b9a7758d0f66ed6bf345a (diff)
downloadupstream-2cf4e3c420ef452e6a687615ab865eae200ed89a.tar.gz
upstream-2cf4e3c420ef452e6a687615ab865eae200ed89a.tar.bz2
upstream-2cf4e3c420ef452e6a687615ab865eae200ed89a.zip
toolchain/insight: Remove from tree
Insight hasn't been touched since 2009 and I can't find any references at least 6 years back of being used. Ubuntu and Debian removed insight years ago from their repos so I think we can safely remove this too. Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
-rw-r--r--toolchain/Config.in8
-rw-r--r--toolchain/Makefile2
-rw-r--r--toolchain/insight/Makefile51
-rw-r--r--toolchain/insight/patches/600-fix-compile-flag-mismatch.patch31
4 files changed, 1 insertions, 91 deletions
diff --git a/toolchain/Config.in b/toolchain/Config.in
index cb645877de..f6753ad8ba 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -276,14 +276,6 @@ config GDB
help
Enable if you want to build the gdb.
-config INSIGHT
- bool
- prompt "Build insight-gdb" if TOOLCHAINOPTS
- select GDB
- default n
- help
- Enable if you want to build insight-gdb.
-
config USE_GLIBC
bool
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 7a9730fd68..409955c23a 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -29,7 +29,7 @@
curdir:=toolchain
# subdirectories to descend into
-$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_YASM),yasm)
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_YASM),yasm)
ifdef CONFIG_USE_UCLIBC
$(curdir)/builddirs += $(LIBC)/utils
endif
diff --git a/toolchain/insight/Makefile b/toolchain/insight/Makefile
deleted file mode 100644
index 63a0e27ced..0000000000
--- a/toolchain/insight/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# Copyright (C) 2006-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=insight
-PKG_VERSION:=6.8-1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)a.tar.bz2
-PKG_HASH:=51216df73adc4f68c67b60356270d5073f0ff094c1b477ecd96560f49707ea2a
-PKG_SOURCE_URL:=ftp://sourceware.org/pub/insight/releases
-PKG_CAT:=bzcat
-
-include $(INCLUDE_DIR)/toolchain-build.mk
-
-define Host/Configure
- (cd $(HOST_BUILD_DIR); \
- gdb_cv_func_sigsetjmp=yes \
- CFLAGS="-O2" \
- $(HOST_BUILD_DIR)/configure \
- --prefix=$(TOOLCHAIN_DIR) \
- --build=$(GNU_HOST_NAME) \
- --host=$(GNU_HOST_NAME) \
- --target=$(REAL_GNU_TARGET_NAME) \
- --enable-threads \
- --enable-werror=no \
- );
-endef
-
-define Host/Compile
- $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
-define Host/Install
- mkdir -p $(TOOLCHAIN_DIR)/bin
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/gdb/insight $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)insight
- ln -fs $(TARGET_CROSS)insight $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-insight
- strip $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)insight
-endef
-
-define Host/Clean
- rm -rf \
- $(HOST_BUILD_DIR) \
- $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)insight \
- $(TOOLCHAIN_DIR)/bin/$(GNU_TARGET_NAME)-insight
-endef
-
-$(eval $(call HostBuild))
diff --git a/toolchain/insight/patches/600-fix-compile-flag-mismatch.patch b/toolchain/insight/patches/600-fix-compile-flag-mismatch.patch
deleted file mode 100644
index 13b72bb96d..0000000000
--- a/toolchain/insight/patches/600-fix-compile-flag-mismatch.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/gdb/gdbserver/configure
-+++ b/gdb/gdbserver/configure
-@@ -1239,7 +1239,7 @@
- ac_cache_corrupted=: ;;
- ,);;
- *)
-- if test "x$ac_old_val" != "x$ac_new_val"; then
-+ if test "`echo x$ac_old_val`" != "`echo x$ac_new_val`"; then
- { echo "$as_me:$LINENO: error: \`$ac_var' has changed since the previous run:" >&5
- echo "$as_me: error: \`$ac_var' has changed since the previous run:" >&2;}
- { echo "$as_me:$LINENO: former value: $ac_old_val" >&5
---- a/gdb/configure
-+++ b/gdb/configure
-@@ -272,7 +272,7 @@
- PACKAGE_BUGREPORT=
-
- ac_unique_file="main.c"
--ac_subdirs_all="$ac_subdirs_all doc testsuite"
-+ac_subdirs_all="$ac_subdirs_all doc"
- # Factoring default headers for most tests.
- ac_includes_default="\
- #include <stdio.h>
-@@ -3077,7 +3077,7 @@
-
-
-
--subdirs="$subdirs doc testsuite"
-+subdirs="$subdirs doc"
-
-
- # Provide defaults for some variables set by the per-host and per-target