aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Lippers-Hollmann <s.l-h@gmx.de>2017-10-19 21:40:26 +0200
committerMathias Kresin <dev@kresin.me>2017-11-03 22:59:19 +0100
commit2aff2add3116906b666da69bfff42a7aeeaee080 (patch)
tree0a25d77987f97b139bd37ac450253175fbb6b2ca
parent63f6408ccc067ba992ce8595d9880fbf33e0e35d (diff)
downloadupstream-2aff2add3116906b666da69bfff42a7aeeaee080.tar.gz
upstream-2aff2add3116906b666da69bfff42a7aeeaee080.tar.bz2
upstream-2aff2add3116906b666da69bfff42a7aeeaee080.zip
ipq806x: nbg6817: add kmod-fs-ext4 to device packages
The ZyXEL NBG6817 uses an eMMC flash for the rootfs, which is split into the readonly squashfs and ext4 for the overlay. This adds the required package to the device packages to allow mounting the overlay by default. /dev/root on /rom type squashfs (ro,relatime) proc on /proc type proc (rw,nosuid,nodev,noexec,noatime) sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime) tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime) /dev/loop0 on /overlay type ext4 (rw,noatime,data=ordered) overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work) tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755) devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000) debugfs on /sys/kernel/debug type debugfs (rw,noatime) mountd(pid1040) on /tmp/run/blockd type autofs (rw,relatime,fd=7,pgrp=1,timeout=30,minproto=5,maxproto=5,indirect) Before this commit, the ext4 based overlayfs could not be mounted, which left only the tmpfs based/ volatile emergency overlay in place. Fixes: https://forum.lede-project.org/t/zyxel-nbg6817-flashing-from-oem/768 Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
-rw-r--r--target/linux/ipq806x/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index e834b25098..01bdb6580f 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -220,7 +220,7 @@ define Device/NBG6817
BLOCKSIZE := 64k
BOARD_NAME := nbg6817
DEVICE_TITLE := ZyXEL NBG6817
- DEVICE_PACKAGES := ath10k-firmware-qca9984 e2fsprogs losetup
+ DEVICE_PACKAGES := ath10k-firmware-qca9984 e2fsprogs kmod-fs-ext4 losetup
$(call Device/ZyXELImage)
endef