aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-07-12 16:14:45 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-07-12 16:17:28 +0800
commit28893f5878a2afbfe91b5dd6027488d35bf43ed1 (patch)
tree47d8b6fababc3acbeb03566aa5897a9bfb31409d
parent0997342f24a001af2638e6b740eb24c965ae073a (diff)
downloadupstream-28893f5878a2afbfe91b5dd6027488d35bf43ed1.tar.gz
upstream-28893f5878a2afbfe91b5dd6027488d35bf43ed1.tar.bz2
upstream-28893f5878a2afbfe91b5dd6027488d35bf43ed1.zip
ath79: fix dsa binding for TP-Link TL-WR941ND v2
upstream changed dt-bindings for marvell 88e6060 to use mdio-device and dropped support for legacy bindings. fix it in our local dts. Fixes: FS#2524 Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
-rw-r--r--target/linux/ath79/dts/ar9132_tplink_tl-wr941-v2.dts20
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk2
2 files changed, 9 insertions, 13 deletions
diff --git a/target/linux/ath79/dts/ar9132_tplink_tl-wr941-v2.dts b/target/linux/ath79/dts/ar9132_tplink_tl-wr941-v2.dts
index 1be4d6183a..11de522ae2 100644
--- a/target/linux/ath79/dts/ar9132_tplink_tl-wr941-v2.dts
+++ b/target/linux/ath79/dts/ar9132_tplink_tl-wr941-v2.dts
@@ -60,19 +60,18 @@
linux,default-trigger = "phy0tpt";
};
};
+};
- dsa {
- compatible = "marvell,dsa";
- #address-cells = <1>;
- #size-cells = <0>;
+&mdio0 {
+ status = "okay";
- dsa,mii-bus = <&mdio0>;
- dsa,ethernet = <&eth0>;
+ switch@0 {
+ compatible = "marvell,mv88e6060";
+ reg = <0>;
- switch@0 {
+ ports {
#address-cells = <1>;
#size-cells = <0>;
- reg = <0>;
port@0 {
reg = <0>;
@@ -102,6 +101,7 @@
port@5 {
reg = <5>;
label = "cpu";
+ ethernet = <&eth0>;
};
};
};
@@ -145,10 +145,6 @@
};
};
-&mdio0 {
- status = "okay";
-};
-
&eth0 {
status = "okay";
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index 128ed9882e..0da712c5d4 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -443,7 +443,7 @@ define Device/tplink_tl-wr941-v2
TPLINK_HWREV := 2
SUPPORTED_DEVICES += tl-wr941nd
endef
-#TARGET_DEVICES += tplink_tl-wr941-v2
+TARGET_DEVICES += tplink_tl-wr941-v2
define Device/tplink_tl-wr941-v4
$(Device/tplink-4m)