aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-01 00:34:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-01 00:34:13 +0000
commit287d56921d76d839da53bd2af616efb22779e224 (patch)
treea685478f8cc5288b1a5bbe908f9df672f020b4b8
parent89464e5e3f7d3bdfb80bea82192437871466a8d1 (diff)
downloadupstream-287d56921d76d839da53bd2af616efb22779e224.tar.gz
upstream-287d56921d76d839da53bd2af616efb22779e224.tar.bz2
upstream-287d56921d76d839da53bd2af616efb22779e224.zip
add chillispot
SVN-Revision: 501
-rw-r--r--openwrt/package/Config.in1
-rw-r--r--openwrt/package/Makefile1
-rw-r--r--openwrt/package/chillispot/Config.in10
-rw-r--r--openwrt/package/chillispot/Makefile76
-rw-r--r--openwrt/package/chillispot/chillispot.control7
-rw-r--r--openwrt/package/chillispot/ipkg/CONTROL/conffiles1
-rwxr-xr-xopenwrt/package/chillispot/ipkg/etc/init.d/S60chilli16
7 files changed, 112 insertions, 0 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 24b3d0da0a..dca12b8ef3 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -35,6 +35,7 @@ source "package/portmap/Config.in"
source "package/nfs-server/Config.in"
source "package/ser/Config.in"
source "package/wol/Config.in"
+source "package/chillispot/Config.in"
comment "Libraries"
source "package/zlib/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 93bc833a50..c42e582098 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -5,6 +5,7 @@ package-y:=openwrt
package-$(BR2_PACKAGE_ARPTABLES) += arptables
package-$(BR2_PACKAGE_BRIDGE) += bridge
package-$(BR2_PACKAGE_BUSYBOX) += busybox
+package-$(BR2_PACKAGE_CHILLISPOT) += chillispot
package-$(BR2_PACKAGE_CIFSMOUNT) += cifsmount
package-$(BR2_PACKAGE_CUPS) += cups
package-$(BR2_PACKAGE_DROPBEAR) += dropbear
diff --git a/openwrt/package/chillispot/Config.in b/openwrt/package/chillispot/Config.in
new file mode 100644
index 0000000000..217ece8c11
--- /dev/null
+++ b/openwrt/package/chillispot/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_CHILLISPOT
+ tristate "chillispot"
+ default m
+ help
+ ChilliSpot is an open source captive portal or wireless LAN
+ access point controller. It is used for authenticating users
+ of a wireless LAN. It supports web based login which is today's
+ standard for public HotSpots and it supports Wireless Protected
+ Access (WPA) which is the standard of the future. Authentication,
+ authorization and accounting (AAA) is handled by your favorite radius server.
diff --git a/openwrt/package/chillispot/Makefile b/openwrt/package/chillispot/Makefile
new file mode 100644
index 0000000000..71736aedc3
--- /dev/null
+++ b/openwrt/package/chillispot/Makefile
@@ -0,0 +1,76 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=chillispot
+PKG_VERSION:=1.0RC2
+PKG_RELEASE:=1
+PKG_MD5SUM:=1b924c0bd592253b1d13af4885ea041a
+
+PKG_SOURCE_URL:=http://www.chillispot.org/download/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+ $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+ $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
+ (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ ac_cv_func_malloc_0_nonnull=yes \
+ ac_cv_func_memcmp_working=yes \
+ ac_cv_func_setvbuf_reversed=no \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib/locate \
+ --localstatedir=/var/lib \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ $(DISABLE_NLS) \
+ );
+ touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/src/chilli: $(PKG_BUILD_DIR)/.configured
+ $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS)
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/src/chilli
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+ mkdir -p $(PKG_IPK_DIR)/usr/sbin
+ cp $(PKG_BUILD_DIR)/src/chilli $(PKG_IPK_DIR)/usr/sbin/
+ $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
+ mkdir -p $(PKG_IPK_DIR)/etc
+ cp $(PKG_BUILD_DIR)/doc/chilli.conf $(PKG_IPK_DIR)/etc
+ cp -a ./ipkg/* $(PKG_IPK_DIR)/
+ find $(PKG_IPK_DIR) -name CVS | xargs rm -rf
+ mkdir -p $(PACKAGE_DIR)
+ $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/openvpn.list: $(PKG_IPK)
+ $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/openvpn.list
+
+clean:
+ rm -rf $(PKG_BUILD_DIR)
+ rm -f $(PKG_IPK)
diff --git a/openwrt/package/chillispot/chillispot.control b/openwrt/package/chillispot/chillispot.control
new file mode 100644
index 0000000000..624dcc5532
--- /dev/null
+++ b/openwrt/package/chillispot/chillispot.control
@@ -0,0 +1,7 @@
+Package: chillispot
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot-internal
+Description: ChilliSpot is a Wireless LAN Access Point Controller.
+Depends: kmod-tun
diff --git a/openwrt/package/chillispot/ipkg/CONTROL/conffiles b/openwrt/package/chillispot/ipkg/CONTROL/conffiles
new file mode 100644
index 0000000000..08485167dd
--- /dev/null
+++ b/openwrt/package/chillispot/ipkg/CONTROL/conffiles
@@ -0,0 +1 @@
+/etc/chilli.conf
diff --git a/openwrt/package/chillispot/ipkg/etc/init.d/S60chilli b/openwrt/package/chillispot/ipkg/etc/init.d/S60chilli
new file mode 100755
index 0000000000..0fded5b137
--- /dev/null
+++ b/openwrt/package/chillispot/ipkg/etc/init.d/S60chilli
@@ -0,0 +1,16 @@
+#!/bin/sh
+case $1 in
+ start)
+ /sbin/insmod tun >/dev/null 2>&1
+ [ -d /var/run ] || mkdir -p /var/run
+ /usr/sbin/chilli
+ ;;
+ stop)
+ [ -f /var/run/chilli.pid ] && kill $(cat /var/run/chilli.pid) >/dev/null 2>&1
+ ;;
+ *)
+ echo "usage: $0 (start|stop)"
+ exit 1
+esac
+
+exit $?