aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-12-05 20:43:04 -0800
committerJohn Crispin <john@phrozen.org>2018-12-06 08:42:39 +0100
commit26dcaf58eeb4481c0fcba56eb1534a6bb08d57f5 (patch)
treee78e10080028b567fa6901eee6b4dc47ab713a5a
parente93e2b631884e233a0c00b6348e67115aa6f7f9d (diff)
downloadupstream-26dcaf58eeb4481c0fcba56eb1534a6bb08d57f5.tar.gz
upstream-26dcaf58eeb4481c0fcba56eb1534a6bb08d57f5.tar.bz2
upstream-26dcaf58eeb4481c0fcba56eb1534a6bb08d57f5.zip
comgt: Fix 3g.sh permissions
3g.sh needs to be executable. 600 is not correct for that. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--package/network/utils/comgt/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index d4d673e783..58466f498c 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=comgt
PKG_VERSION:=0.32
-PKG_RELEASE:=31
+PKG_RELEASE:=32
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
PKG_SOURCE_URL:=@SF/comgt
@@ -82,7 +82,7 @@ define Package/comgt/install
$(INSTALL_DIR) $(1)/etc/hotplug.d/tty
$(INSTALL_CONF) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
$(INSTALL_DIR) $(1)/lib/netifd/proto
- $(INSTALL_CONF) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
+ $(INSTALL_BIN) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
endef
define Package/comgt-directip/install