aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2020-06-10 16:52:27 +0200
committerFelix Fietkau <nbd@nbd.name>2020-08-06 12:36:23 +0200
commit25e0ae6bfc3bdc05795b988c0b4faec993d71157 (patch)
tree52755e21cd7439c9bf4ffba5940489f69e6b71b9
parentb92f54b919e925cf27105c22f8ffdd7585937bb1 (diff)
downloadupstream-25e0ae6bfc3bdc05795b988c0b4faec993d71157.tar.gz
upstream-25e0ae6bfc3bdc05795b988c0b4faec993d71157.tar.bz2
upstream-25e0ae6bfc3bdc05795b988c0b4faec993d71157.zip
mac80211: make cfg80211 testmode support optional (and disabled by default)
Testmode commands are typically only used for manufacturing or vendor specific debugging features, so they should not be in the default image Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--package/kernel/mac80211/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 75d9cd9e6f..6a79949612 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -35,6 +35,7 @@ PKG_DRIVERS = \
PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_kmod-mac80211 \
+ CONFIG_PACKAGE_CFG80211_TESTMODE \
CONFIG_PACKAGE_MAC80211_DEBUGFS \
CONFIG_PACKAGE_MAC80211_MESH \
CONFIG_PACKAGE_MAC80211_TRACING \
@@ -56,7 +57,6 @@ config_package=$(if $(CONFIG_PACKAGE_kmod-$(1)),m)
config-y:= \
WLAN \
- NL80211_TESTMODE \
CFG80211_WEXT \
CFG80211_CERTIFICATION_ONUS \
MAC80211_RC_MINSTREL \
@@ -80,6 +80,7 @@ config-y:= \
WLAN_VENDOR_ZYDAS \
config-$(call config_package,cfg80211) += CFG80211
+config-$(CONFIG_PACKAGE_CFG80211_TESTMODE) += NL80211_TESTMODE
config-$(call config_package,mac80211) += MAC80211
config-$(CONFIG_PACKAGE_MAC80211_MESH) += MAC80211_MESH
@@ -108,6 +109,20 @@ define KernelPackage/cfg80211/description
cfg80211 is the Linux wireless LAN (802.11) configuration API.
endef
+define KernelPackage/cfg80211/config
+ if PACKAGE_kmod-cfg80211
+
+ config PACKAGE_CFG80211_TESTMODE
+ bool "Enable testmode command support"
+ default n
+ help
+ This is typically used for tests and calibration during
+ manufacturing, or vendor specific debugging features
+
+ endif
+endef
+
+
define KernelPackage/mac80211
$(call KernelPackage/mac80211/Default)
TITLE:=Linux 802.11 Wireless Networking Stack