aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-18 03:54:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-18 03:54:09 +0000
commit25630dd5a56e3899a60247a7f63d490135d7dba0 (patch)
treefe37ef6c78aa539834e5495a27b66fb99cf1d6b5
parentf20b6c3ff9201916f2b969c042e8eb16ec57f988 (diff)
downloadupstream-25630dd5a56e3899a60247a7f63d490135d7dba0.tar.gz
upstream-25630dd5a56e3899a60247a7f63d490135d7dba0.tar.bz2
upstream-25630dd5a56e3899a60247a7f63d490135d7dba0.zip
openssl: don't fail with empty TARGET_LDFLAGS
SVN-Revision: 29770
-rw-r--r--package/openssl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index cc253d686d..48e8a427f6 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -142,7 +142,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
- $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ $(if $(TARGET_LDFLAGS),$(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc)
endef
define Package/libopenssl/install