aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2008-09-01 21:46:17 +0000
committerLars-Peter Clausen <lars@metafoo.de>2008-09-01 21:46:17 +0000
commit2552e9362b8b6ce157d3903df6477e7b35bab1ef (patch)
tree62d30d16c8f9f2a64e0bbe0ca7f842e83a0c2e75
parent0fdecd35bd47fe8ae6ec819d936dc70d88e878bd (diff)
downloadupstream-2552e9362b8b6ce157d3903df6477e7b35bab1ef.tar.gz
upstream-2552e9362b8b6ce157d3903df6477e7b35bab1ef.tar.bz2
upstream-2552e9362b8b6ce157d3903df6477e7b35bab1ef.zip
Add @GNOME download source.
SVN-Revision: 12469
-rw-r--r--include/download.mk2
-rwxr-xr-xscripts/download.pl16
2 files changed, 16 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 406afee48e..7a4d90da98 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -11,7 +11,7 @@ DOWNLOAD_RDEP:=$(STAMP_PREPARED)
define dl_method
$(strip \
$(if $(2),$(2), \
- $(if $(filter @GNU/% @KERNEL/% @SF/% ftp://% http://%,$(1)),default, \
+ $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% ftp://% http://%,$(1)),default, \
$(if $(filter git://%,$(1)),git, \
$(if $(filter svn://%,$(1)),svn, \
$(if $(filter cvs://%,$(1)),cvs, \
diff --git a/scripts/download.pl b/scripts/download.pl
index 75c4110fa5..8934c55500 100755
--- a/scripts/download.pl
+++ b/scripts/download.pl
@@ -134,7 +134,21 @@ foreach my $mirror (@ARGV) {
push @mirrors, "http://ftp.de.kernel.org/pub/$1";
push @mirrors, "ftp://ftp.fr.kernel.org/pub/$1";
push @mirrors, "http://ftp.fr.kernel.org/pub/$1";
- } else {
+ } elsif ($mirror =~ /^\@GNOME\/(.+)$/) {
+ push @mirrors, "http://ftp.gnome.org/pub/GNOME/sources/$1";
+ push @mirrors, "http://ftp.unina.it/pub/linux/GNOME/sources/$1";
+ push @mirrors, "http://fr2.rpmfind.net/linux/gnome.org/sources/$1";
+ push @mirrors, "ftp://ftp.dit.upm.es/pub/GNOME/sources/$1";
+ push @mirrors, "ftp://ftp.no.gnome.org/pub/GNOME/sources/$1";
+ push @mirrors, "http://ftp.acc.umu.se/pub/GNOME/sources/$1";
+ push @mirrors, "http://ftp.belnet.be/mirror/ftp.gnome.org/sources/$1";
+ push @mirrors, "http://linorg.usp.br/gnome/sources/$1";
+ push @mirrors, "http://mirror.aarnet.edu.au/pub/GNOME/sources/$1";
+ push @mirrors, "http://mirrors.ibiblio.org/pub/mirrors/gnome/sources/$1";
+ push @mirrors, "ftp://ftp.cse.buffalo.edu/pub/Gnome/sources/$1";
+ push @mirrors, "ftp://ftp.nara.wide.ad.jp/pub/X11/GNOME/sources/$1";
+ }
+ else {
push @mirrors, $mirror;
}
}