aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-27 13:14:12 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-27 16:53:31 +0100
commit237bd361352446669d4058e423f5e1b27c930004 (patch)
tree959e0cda93d5a9f2f6038e41bd07c0a74848073b
parent7d57db4d9be2e8c8e72108c0b8702029ba8c70de (diff)
downloadupstream-237bd361352446669d4058e423f5e1b27c930004.tar.gz
upstream-237bd361352446669d4058e423f5e1b27c930004.tar.bz2
upstream-237bd361352446669d4058e423f5e1b27c930004.zip
mvebu: put u-boot images into image staging directory
Do not put the u-boot images into the kernel build directory as this directory might get removed after kernel updates while the u-boot packages InstallDev recipe is not getting re-executed because it is still considered current, leading to image build failures later on due to missing u-boot images. To ensure that built bootloader images persist over kernel version updates in the buildroot, put them into the new STAGING_DIR_IMAGE directory. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--package/boot/uboot-mvebu/Makefile4
-rw-r--r--target/linux/mvebu/image/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index e0cd944be9..bd95f769e9 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -31,8 +31,8 @@ UBOOT_TARGETS:= \
clearfog
define Build/InstallDev
- $(INSTALL_DIR) $(KERNEL_BUILD_DIR)/
- $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(KERNEL_BUILD_DIR)/$(BUILD_VARIANT)-u-boot-spl.kwb
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+ $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-u-boot-spl.kwb
endef
$(eval $(call BuildPackage/U-Boot))
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 96df359a61..16d93340d5 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -39,7 +39,7 @@ endef
define Build/sdcard-img
ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
./gen_mvebu_sdcard_img.sh $@ \
- "$(KDIR)/clearfog-u-boot-spl.kwb" \
+ "$(STAGING_DIR_IMAGE)/clearfog-u-boot-spl.kwb" \
c 32768 $@.boot \
83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
endef