aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-08-01 17:42:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-08-01 17:42:00 +0000
commit21dd9478d76fe4fb9fd98208bbfa6aae72642420 (patch)
treedacaf0448d94a874bfbec5689d3411633d7a391f
parent0cd8805b0a0417692adbdb28a466c92acace022d (diff)
downloadupstream-21dd9478d76fe4fb9fd98208bbfa6aae72642420.tar.gz
upstream-21dd9478d76fe4fb9fd98208bbfa6aae72642420.tar.bz2
upstream-21dd9478d76fe4fb9fd98208bbfa6aae72642420.zip
mac80211: move compat_firmware_class.ko into compat.ko (fixes #9864)
SVN-Revision: 27863
-rw-r--r--package/mac80211/Makefile8
-rw-r--r--package/mac80211/patches/050-compat_firmware.patch17
2 files changed, 17 insertions, 8 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index b7c0fe0594..bc556f9230 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -55,18 +55,10 @@ define KernelPackage/cfg80211
$(call KernelPackage/mac80211/Default)
TITLE:=cfg80211 - wireless configuration API
DEPENDS+= +wireless-tools +iw +crda
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.33)),1)
FILES:= \
$(PKG_BUILD_DIR)/compat/compat.ko \
$(PKG_BUILD_DIR)/net/wireless/cfg80211.ko
AUTOLOAD:=$(call AutoLoad,20,compat cfg80211)
-else
- FILES:= \
- $(PKG_BUILD_DIR)/compat/compat.ko \
- $(PKG_BUILD_DIR)/compat/compat_firmware_class.ko \
- $(PKG_BUILD_DIR)/net/wireless/cfg80211.ko
- AUTOLOAD:=$(call AutoLoad,20,compat compat_firmware_class cfg80211)
-endif
endef
define KernelPackage/cfg80211/description
diff --git a/package/mac80211/patches/050-compat_firmware.patch b/package/mac80211/patches/050-compat_firmware.patch
new file mode 100644
index 0000000000..4d96ca9f83
--- /dev/null
+++ b/package/mac80211/patches/050-compat_firmware.patch
@@ -0,0 +1,17 @@
+--- a/compat/Makefile
++++ b/compat/Makefile
+@@ -1,10 +1,13 @@
+ obj-m += compat.o
+ #compat-objs :=
+
+-obj-$(CONFIG_COMPAT_FIRMWARE_CLASS) += compat_firmware_class.o
+
+ compat-y += main.o
+
++ifdef CONFIG_COMPAT_FIRMWARE_CLASS
++ compat-y += compat_firmware_class.o
++endif
++
+ # Compat kernel compatibility code
+ compat-$(CONFIG_COMPAT_KERNEL_2_6_14) += compat-2.6.14.o
+ compat-$(CONFIG_COMPAT_KERNEL_2_6_18) += compat-2.6.18.o