aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2005-09-21 09:55:03 +0000
committerImre Kaloz <kaloz@openwrt.org>2005-09-21 09:55:03 +0000
commit208236a70e305a127a1cd3275eb06f44746c4250 (patch)
tree5f4a68baf984d69462b04a4a71acb3e36f723791
parent7872532ac9718575b020b249bcb387deef4ab6d6 (diff)
downloadupstream-208236a70e305a127a1cd3275eb06f44746c4250.tar.gz
upstream-208236a70e305a127a1cd3275eb06f44746c4250.tar.bz2
upstream-208236a70e305a127a1cd3275eb06f44746c4250.zip
move diag module outside of kernel directory
SVN-Revision: 1968
-rw-r--r--openwrt/target/linux/Config.in6
-rw-r--r--openwrt/target/linux/linux-2.4/README3
-rw-r--r--openwrt/target/linux/linux-2.4/broadcom.mk3
-rw-r--r--openwrt/target/linux/linux-2.4/patches/brcm/004-diag_led.patch278
-rw-r--r--openwrt/target/linux/linux-2.6/broadcom.mk3
-rw-r--r--openwrt/target/linux/linux-2.6/patches/brcm/002-diag_led.patch288
-rw-r--r--openwrt/target/linux/package/Config.in1
-rw-r--r--openwrt/target/linux/package/Makefile1
-rw-r--r--openwrt/target/linux/package/diag/Config.in5
-rw-r--r--openwrt/target/linux/package/diag/Makefile37
-rw-r--r--openwrt/target/linux/package/diag/diag_led.c245
-rw-r--r--openwrt/target/linux/package/diag/ipkg/kmod-diag.control (renamed from openwrt/target/linux/control/kmod-diag.control)2
12 files changed, 290 insertions, 582 deletions
diff --git a/openwrt/target/linux/Config.in b/openwrt/target/linux/Config.in
index 4eb2a6d479..f5cf16679f 100644
--- a/openwrt/target/linux/Config.in
+++ b/openwrt/target/linux/Config.in
@@ -86,12 +86,6 @@ config BR2_PACKAGE_KMOD_CPMAC
help
Driver for the AR7 CPMAC network chip
-config BR2_PACKAGE_KMOD_DIAG
- tristate "Router LED/Button Driver"
- default y
- help
- Driver for the LEDs on Wireless Routers (diag)
-
config BR2_PACKAGE_KMOD_BRCM_WL
tristate "Broadcom Wireless Network Driver"
depends BR2_LINUX_2_4_BRCM
diff --git a/openwrt/target/linux/linux-2.4/README b/openwrt/target/linux/linux-2.4/README
index d5e2d6392e..8dff7fcccb 100644
--- a/openwrt/target/linux/linux-2.4/README
+++ b/openwrt/target/linux/linux-2.4/README
@@ -89,9 +89,6 @@ brcm/
003-bcm47xx_cache_fixes.patch
-004-diag_led.patch
- OpenWrt diag (led and reset button) driver
-
ar7/
TI AR7 specific patches
diff --git a/openwrt/target/linux/linux-2.4/broadcom.mk b/openwrt/target/linux/linux-2.4/broadcom.mk
index 4fc1424909..bde9e1491d 100644
--- a/openwrt/target/linux/linux-2.4/broadcom.mk
+++ b/openwrt/target/linux/linux-2.4/broadcom.mk
@@ -6,9 +6,6 @@
#############################################################
# broadcom specific kmod packages
-$(eval $(call KMOD_template,DIAG,diag,\
- $(MODULES_DIR)/kernel/drivers/net/diag/diag.o \
-))
$(eval $(call KMOD_template,BRCM_WL,brcm-wl,\
$(MODULES_DIR)/kernel/drivers/net/wl/wl.o \
,CONFIG_WL))
diff --git a/openwrt/target/linux/linux-2.4/patches/brcm/004-diag_led.patch b/openwrt/target/linux/linux-2.4/patches/brcm/004-diag_led.patch
deleted file mode 100644
index 7ec20df572..0000000000
--- a/openwrt/target/linux/linux-2.4/patches/brcm/004-diag_led.patch
+++ /dev/null
@@ -1,278 +0,0 @@
-diff -urN linux-2.4.30.dev/drivers/net/Makefile linux-2.4.30.dev2/drivers/net/Makefile
---- linux-2.4.30.dev/drivers/net/Makefile 2005-08-22 01:41:45.930653216 +0200
-+++ linux-2.4.30.dev2/drivers/net/Makefile 2005-08-22 01:58:04.162939304 +0200
-@@ -41,6 +41,8 @@
- obj-$(CONFIG_ISDN) += slhc.o
- endif
-
-+subdir-m += diag
-+
- subdir-$(CONFIG_HND) += hnd
- subdir-$(CONFIG_ET) += et
- subdir-$(CONFIG_WL) += wl
-diff -urN linux-2.4.30.dev/drivers/net/diag/Makefile linux-2.4.30.dev2/drivers/net/diag/Makefile
---- linux-2.4.30.dev/drivers/net/diag/Makefile 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.4.30.dev2/drivers/net/diag/Makefile 2005-08-22 00:12:23.655170000 +0200
-@@ -0,0 +1,13 @@
-+#$Id: 005-diag_led.patch,v 1.1.2.1 2005/08/22 01:56:06 nbd Exp $
-+
-+EXTRA_CFLAGS := -I$(TOPDIR)/arch/mips/bcm947xx/include -DBCMDRIVER
-+
-+O_TARGET := diag.o
-+
-+MAC_OBJS := diag_led.o
-+
-+export-objs :=
-+obj-y := $(MAC_OBJS)
-+obj-m := $(O_TARGET)
-+
-+include $(TOPDIR)/Rules.make
-diff -urN linux-2.4.30.dev/drivers/net/diag/diag_led.c linux-2.4.30.dev2/drivers/net/diag/diag_led.c
---- linux-2.4.30.dev/drivers/net/diag/diag_led.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.4.30.dev2/drivers/net/diag/diag_led.c 2005-08-22 03:37:58.112053448 +0200
-@@ -0,0 +1,245 @@
-+/*
-+ * diag_led.c - replacement diag module
-+ *
-+ * Copyright (C) 2004 Mike Baker,
-+ * Imre Kaloz <kaloz@dune.hu>
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * as published by the Free Software Foundation; either version 2
-+ * of the License, or (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program; if not, write to the Free Software
-+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-+ *
-+ * $Id: 005-diag_led.patch,v 1.1.2.1 2005/08/22 01:56:06 nbd Exp $
-+ */
-+
-+/*
-+ * ChangeLog:
-+ * 2004/03/28 initial release
-+ * 2004/08/26 asus & buffalo support added
-+ * 2005/03/14 asus wl-500g deluxe and buffalo v2 support added
-+ * 2005/04/13 added licensing informations
-+ * 2005/04/18 base reset polarity off initial readings
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/init.h>
-+#include <linux/kernel.h>
-+#include <linux/sysctl.h>
-+#include <asm/io.h>
-+#include <typedefs.h>
-+#include <bcmdevs.h>
-+#include <sbutils.h>
-+
-+extern char * nvram_get(const char *name);
-+static void *sbh;
-+
-+// v2.x - - - - -
-+#define DIAG_GPIO (1<<1)
-+#define DMZ_GPIO (1<<7)
-+
-+static void set_gpio(uint32 mask, uint32 value) {
-+ sb_gpiocontrol(sbh,mask,0);
-+ sb_gpioouten(sbh,mask,mask);
-+ sb_gpioout(sbh,mask,value);
-+}
-+
-+static void v2_set_diag(u8 state) {
-+ set_gpio(DIAG_GPIO,state);
-+}
-+static void v2_set_dmz(u8 state) {
-+ set_gpio(DMZ_GPIO,state);
-+}
-+
-+// v1.x - - - - -
-+#define LED_DIAG 0x13
-+#define LED_DMZ 0x12
-+
-+static void v1_set_diag(u8 state) {
-+ if (!state) {
-+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DIAG)=0xFF;
-+ } else {
-+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DIAG);
-+ }
-+}
-+static void v1_set_dmz(u8 state) {
-+ if (!state) {
-+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DMZ)=0xFF;
-+ } else {
-+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DMZ);
-+ }
-+}
-+
-+// - - - - -
-+static void ignore(u8 ignored) {};
-+
-+// - - - - -
-+#define BIT_DMZ 0x01
-+#define BIT_DIAG 0x04
-+
-+void (*set_diag)(u8 state);
-+void (*set_dmz)(u8 state);
-+
-+static unsigned int diag = 0;
-+
-+static void diag_change()
-+{
-+ set_diag(0xFF); // off
-+ set_dmz(0xFF); // off
-+
-+ if(diag & BIT_DIAG)
-+ set_diag(0x00); // on
-+ if(diag & BIT_DMZ)
-+ set_dmz(0x00); // on
-+}
-+
-+static int proc_diag(ctl_table *table, int write, struct file *filp,
-+ void *buffer, size_t *lenp)
-+{
-+ int r;
-+ r = proc_dointvec(table, write, filp, buffer, lenp);
-+ if (write && !r) {
-+ diag_change();
-+ }
-+ return r;
-+}
-+
-+// - - - - -
-+static unsigned char reset_gpio = 0;
-+static unsigned char reset_polarity = 0;
-+static unsigned int reset = 0;
-+
-+static int proc_reset(ctl_table *table, int write, struct file *filp,
-+ void *buffer, size_t *lenp)
-+{
-+
-+ if (reset_gpio) {
-+ sb_gpiocontrol(sbh,reset_gpio,reset_gpio);
-+ sb_gpioouten(sbh,reset_gpio,0);
-+ reset=!(sb_gpioin(sbh)&reset_gpio);
-+
-+ if (reset_polarity) reset=!reset;
-+ } else {
-+ reset=0;
-+ }
-+
-+ return proc_dointvec(table, write, filp, buffer, lenp);
-+}
-+
-+// - - - - -
-+static struct ctl_table_header *diag_sysctl_header;
-+
-+static ctl_table sys_diag[] = {
-+ {
-+ ctl_name: 2000,
-+ procname: "diag",
-+ data: &diag,
-+ maxlen: sizeof(diag),
-+ mode: 0644,
-+ proc_handler: proc_diag
-+ },
-+ {
-+ ctl_name: 2001,
-+ procname: "reset",
-+ data: &reset,
-+ maxlen: sizeof(reset),
-+ mode: 0444,
-+ proc_handler: proc_reset
-+ },
-+ { 0 }
-+};
-+
-+static int __init diag_init()
-+{
-+ char *buf;
-+ u32 board_type;
-+ sbh = sb_kattach();
-+ sb_gpiosetcore(sbh);
-+
-+ board_type = sb_boardtype(sbh);
-+ printk(KERN_INFO "diag boardtype: %08x\n",board_type);
-+
-+ set_diag=ignore;
-+ set_dmz=ignore;
-+
-+ buf=nvram_get("boardrev");
-+ if (((board_type & 0xf00) == 0x400) && strcmp(buf,"0x10")) {
-+ buf=nvram_get("boardtype")?:"";
-+ if (!strcmp(buf,"bcm94710dev")) {
-+ buf=nvram_get("boardnum")?:"";
-+ if (!strcmp(buf,"42")) {
-+ // wrt54g v1.x
-+ set_diag=v1_set_diag;
-+ set_dmz=v1_set_dmz;
-+ reset_gpio=(1<<6);
-+ }
-+ if (!strcmp(buf,"asusX")) {
-+ //asus wl-500g
-+ reset_gpio=(1<<6);
-+ }
-+ }
-+ if (!strcmp(buf,"bcm94710ap")) {
-+ buf=nvram_get("boardnum")?:"";
-+ if (!strcmp(buf,"42")) {
-+ // buffalo
-+ set_dmz=v2_set_dmz;
-+ reset_gpio=(1<<4);
-+ }
-+ if (!strcmp(buf,"44")) {
-+ //dell truemobile
-+ set_dmz=v2_set_dmz;
-+ reset_gpio=(1<<0);
-+ }
-+ }
-+ } else {
-+ buf=nvram_get("boardnum")?:"";
-+ if (!strcmp(buf,"42")) {
-+ //linksys
-+ set_diag=v2_set_diag;
-+ set_dmz=v2_set_dmz;
-+ reset_gpio=(1<<6);
-+ }
-+ if (!strcmp(buf,"44")) {
-+ //motorola
-+ reset_gpio=(1<<5);
-+ }
-+ if (!strcmp(buf,"00")) {
-+ //buffalo
-+ reset_gpio=(1<<7);
-+ }
-+ if (!strcmp(buf,"45")) {
-+ //wl-500g deluxe
-+ reset_gpio=(1<<6);
-+ }
-+ }
-+
-+
-+ sb_gpiocontrol(sbh,reset_gpio,reset_gpio);
-+ sb_gpioouten(sbh,reset_gpio,0);
-+ reset_polarity=!(sb_gpioin(sbh)&reset_gpio);
-+
-+ diag_sysctl_header = register_sysctl_table(sys_diag, 0);
-+ diag_change();
-+
-+ return 0;
-+}
-+
-+static void __exit diag_exit()
-+{
-+ unregister_sysctl_table(diag_sysctl_header);
-+}
-+
-+EXPORT_NO_SYMBOLS;
-+MODULE_AUTHOR("openwrt.org");
-+MODULE_LICENSE("GPL");
-+
-+module_init(diag_init);
-+module_exit(diag_exit);
diff --git a/openwrt/target/linux/linux-2.6/broadcom.mk b/openwrt/target/linux/linux-2.6/broadcom.mk
index 758cf063d5..f34fe6ac6a 100644
--- a/openwrt/target/linux/linux-2.6/broadcom.mk
+++ b/openwrt/target/linux/linux-2.6/broadcom.mk
@@ -1,6 +1,3 @@
# $Id$
#
# broadcom specific kmod packages
-$(eval $(call KMOD_template,DIAG,diag,\
- $(MODULES_DIR)/kernel/drivers/net/diag/diag.ko \
-))
diff --git a/openwrt/target/linux/linux-2.6/patches/brcm/002-diag_led.patch b/openwrt/target/linux/linux-2.6/patches/brcm/002-diag_led.patch
deleted file mode 100644
index a0f36e669c..0000000000
--- a/openwrt/target/linux/linux-2.6/patches/brcm/002-diag_led.patch
+++ /dev/null
@@ -1,288 +0,0 @@
-diff -Nur linux-2.6.12.5/drivers/net/Kconfig linux-2.6.12.5-diag/drivers/net/Kconfig
---- linux-2.6.12.5/drivers/net/Kconfig 2005-08-15 02:20:18.000000000 +0200
-+++ linux-2.6.12.5-diag/drivers/net/Kconfig 2005-09-10 23:08:53.209908656 +0200
-@@ -41,6 +41,11 @@
- Instead of 'dummy', the devices will then be called 'dummy0',
- 'dummy1' etc.
-
-+config DIAG_LED
-+ tristate "Led driver for Broadcom BCM97xx"
-+ ---help---
-+ Say m if you like the led to signal status of operation.
-+
- config BONDING
- tristate "Bonding driver support"
- depends on NETDEVICES
-diff -Nur linux-2.6.12.5/drivers/net/Makefile linux-2.6.12.5-diag/drivers/net/Makefile
---- linux-2.6.12.5/drivers/net/Makefile 2005-08-15 02:20:18.000000000 +0200
-+++ linux-2.6.12.5-diag/drivers/net/Makefile 2005-09-08 17:49:02.249278160 +0200
-@@ -1,6 +1,7 @@
- #
- # Makefile for the Linux network (ethercard) device drivers.
- #
-+obj-$(CONFIG_DIAG_LED) += diag/
-
- ifeq ($(CONFIG_ISDN_PPP),y)
- obj-$(CONFIG_ISDN) += slhc.o
-diff -Nur linux-2.6.12.5/drivers/net/diag/Makefile linux-2.6.12.5-diag/drivers/net/diag/Makefile
---- linux-2.6.12.5/drivers/net/diag/Makefile 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.12.5-diag/drivers/net/diag/Makefile 2005-09-10 19:45:26.596290216 +0200
-@@ -0,0 +1,5 @@
-+#$Id$
-+
-+EXTRA_CFLAGS := -I$(TOPDIR)/arch/mips/bcm947xx/include -DBCMDRIVER
-+
-+obj-$(CONFIG_DIAG_LED) += diag.o
-diff -Nur linux-2.6.12.5/drivers/net/diag/diag.c linux-2.6.12.5-diag/drivers/net/diag/diag.c
---- linux-2.6.12.5/drivers/net/diag/diag.c 1970-01-01 01:00:00.000000000 +0100
-+++ linux-2.6.12.5-diag/drivers/net/diag/diag.c 2005-09-10 18:51:02.727849016 +0200
-@@ -0,0 +1,249 @@
-+/*
-+ * diag_led.c - replacement diag module
-+ *
-+ * Copyright (C) 2004 Mike Baker,
-+ * Imre Kaloz <kaloz@dune.hu>
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * as published by the Free Software Foundation; either version 2
-+ * of the License, or (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program; if not, write to the Free Software
-+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-+ *
-+ * $Id$
-+ */
-+
-+/*
-+ * ChangeLog:
-+ * 2004/03/28 initial release
-+ * 2004/08/26 asus & buffalo support added
-+ * 2005/03/14 asus wl-500g deluxe and buffalo v2 support added
-+ * 2005/04/13 added licensing informations
-+ * 2005/04/18 base reset polarity off initial readings
-+ */
-+
-+#include <linux/module.h>
-+#include <linux/init.h>
-+#include <linux/kernel.h>
-+#include <linux/sysctl.h>
-+#include <asm/io.h>
-+#include <typedefs.h>
-+#include <bcmdevs.h>
-+#include <sbutils.h>
-+
-+extern char * nvram_get(const char *name);
-+static void *sbh;
-+
-+// v2.x - - - - -
-+#define DIAG_GPIO (1<<1)
-+#define DMZ_GPIO (1<<7)
-+
-+/*
-+static void set_gpio(uint32 mask, uint32 value) {
-+ sb_gpiocontrol(sbh,mask,0);
-+ sb_gpioouten(sbh,mask,mask);
-+ sb_gpioout(sbh,mask,value);
-+}
-+
-+static void v2_set_diag(u8 state) {
-+ set_gpio(DIAG_GPIO,state);
-+}
-+static void v2_set_dmz(u8 state) {
-+ set_gpio(DMZ_GPIO,state);
-+}
-+*/
-+
-+/*
-+// v1.x - - - - -
-+#define LED_DIAG 0x13
-+#define LED_DMZ 0x12
-+
-+static void v1_set_diag(u8 state) {
-+ if (!state) {
-+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DIAG)=0xFF;
-+ } else {
-+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DIAG);
-+ }
-+}
-+static void v1_set_dmz(u8 state) {
-+ if (!state) {
-+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DMZ)=0xFF;
-+ } else {
-+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DMZ);
-+ }
-+}
-+*/
-+
-+// - - - - -
-+static void ignore(u8 ignored) {};
-+
-+// - - - - -
-+#define BIT_DMZ 0x01
-+#define BIT_DIAG 0x04
-+
-+void (*set_diag)(u8 state);
-+void (*set_dmz)(u8 state);
-+
-+static unsigned int diag = 0;
-+
-+static void diag_change()
-+{
-+ set_diag(0xFF); // off
-+ set_dmz(0xFF); // off
-+
-+ if(diag & BIT_DIAG)
-+ set_diag(0x00); // on
-+ if(diag & BIT_DMZ)
-+ set_dmz(0x00); // on
-+}
-+
-+static int proc_diag(ctl_table *table, int write, struct file *filp,
-+ void *buffer, size_t *lenp, loff_t *ppos)
-+{
-+ int r;
-+ r = proc_dointvec(table, write, filp, buffer, lenp, ppos);
-+ if (write && !r) {
-+ diag_change();
-+ }
-+ return r;
-+}
-+
-+// - - - - -
-+static unsigned char reset_gpio = 0;
-+static unsigned char reset_polarity = 0;
-+static unsigned int reset = 0;
-+
-+static int proc_reset(ctl_table *table, int write, struct file *filp,
-+ void *buffer, size_t *lenp, loff_t *ppos)
-+{
-+
-+ if (reset_gpio) {
-+ sb_gpiocontrol(sbh,reset_gpio,reset_gpio);
-+ sb_gpioouten(sbh,reset_gpio,0);
-+ reset=!(sb_gpioin(sbh)&reset_gpio);
-+
-+ if (reset_polarity) reset=!reset;
-+ } else {
-+ reset=0;
-+ }
-+
-+ return proc_dointvec(table, write, filp, buffer, lenp, ppos);
-+}
-+
-+// - - - - -
-+static struct ctl_table_header *diag_sysctl_header;
-+
-+static ctl_table sys_diag[] = {
-+ {
-+ ctl_name: 2000,
-+ procname: "diag",
-+ data: &diag,
-+ maxlen: sizeof(diag),
-+ mode: 0644,
-+ proc_handler: proc_diag
-+ },
-+ {
-+ ctl_name: 2001,
-+ procname: "reset",
-+ data: &reset,
-+ maxlen: sizeof(reset),
-+ mode: 0444,
-+ proc_handler: proc_reset
-+ },
-+ { 0 }
-+};
-+
-+static int __init diag_init()
-+{
-+ //char *buf;
-+ u32 board_type;
-+ sbh = sb_kattach();
-+ sb_gpiosetcore(sbh);
-+
-+ board_type = sb_boardtype(sbh);
-+ printk(KERN_INFO "diag boardtype: %08x\n",board_type);
-+
-+ set_diag=ignore;
-+ set_dmz=ignore;
-+
-+ /*
-+ buf=nvram_get("boardrev");
-+ if (((board_type & 0xf00) == 0x400) && strcmp(buf,"0x10")) {
-+ buf=nvram_get("boardtype")?:"";
-+ if (!strcmp(buf,"bcm94710dev")) {
-+ buf=nvram_get("boardnum")?:"";
-+ if (!strcmp(buf,"42")) {
-+ // wrt54g v1.x
-+ set_diag=v1_set_diag;
-+ set_dmz=v1_set_dmz;
-+ reset_gpio=(1<<6);
-+ }
-+ if (!strcmp(buf,"asusX")) {
-+ //asus wl-500g
-+ reset_gpio=(1<<6);
-+ }
-+ }
-+ if (!strcmp(buf,"bcm94710ap")) {
-+ buf=nvram_get("boardnum")?:"";
-+ if (!strcmp(buf,"42")) {
-+ // buffalo
-+ set_dmz=v2_set_dmz;
-+ reset_gpio=(1<<4);
-+ }
-+ if (!strcmp(buf,"44")) {
-+ //dell truemobile
-+ set_dmz=v2_set_dmz;
-+ reset_gpio=(1<<0);
-+ }
-+ }
-+ } else {
-+ buf=nvram_get("boardnum")?:"";
-+ if (!strcmp(buf,"42")) {
-+ //linksys
-+ set_diag=v2_set_diag;
-+ set_dmz=v2_set_dmz;
-+ reset_gpio=(1<<6);
-+ }
-+ if (!strcmp(buf,"44")) {
-+ //motorola
-+ reset_gpio=(1<<5);
-+ }
-+ if (!strcmp(buf,"00")) {
-+ //buffalo
-+ reset_gpio=(1<<7);
-+ }
-+ if (!strcmp(buf,"45")) {
-+ //wl-500g deluxe
-+ reset_gpio=(1<<6);
-+ }
-+ }
-+
-+ */
-+ sb_gpiocontrol(sbh,reset_gpio,reset_gpio);
-+ sb_gpioouten(sbh,reset_gpio,0);
-+ reset_polarity=!(sb_gpioin(sbh)&reset_gpio);
-+
-+ diag_sysctl_header = register_sysctl_table(sys_diag, 0);
-+ diag_change();
-+
-+ return 0;
-+}
-+
-+static void __exit diag_exit()
-+{
-+ unregister_sysctl_table(diag_sysctl_header);
-+}
-+
-+MODULE_AUTHOR("openwrt.org");
-+MODULE_LICENSE("GPL");
-+
-+module_init(diag_init);
-+module_exit(diag_exit);
diff --git a/openwrt/target/linux/package/Config.in b/openwrt/target/linux/package/Config.in
index 69fc1466b2..b08debb777 100644
--- a/openwrt/target/linux/package/Config.in
+++ b/openwrt/target/linux/package/Config.in
@@ -1,4 +1,5 @@
source "target/linux/package/wlcompat/Config.in"
+source "target/linux/package/diag/Config.in"
source "target/linux/package/madwifi/Config.in"
source "target/linux/package/fuse/Config.in"
source "target/linux/package/mini_fo/Config.in"
diff --git a/openwrt/target/linux/package/Makefile b/openwrt/target/linux/package/Makefile
index e55cc54d4b..d1cf0f7832 100644
--- a/openwrt/target/linux/package/Makefile
+++ b/openwrt/target/linux/package/Makefile
@@ -10,6 +10,7 @@ package-y += openwrt
ifeq ($(BOARD)-$(KERNEL),brcm-2.4)
package-$(BR2_PACKAGE_KMOD_WLCOMPAT) += wlcompat
+package-$(BR2_PACKAGE_KMOD_DIAG) += diag
wlcompat-compile: openwrt-compile
endif
diff --git a/openwrt/target/linux/package/diag/Config.in b/openwrt/target/linux/package/diag/Config.in
new file mode 100644
index 0000000000..b58a99e62f
--- /dev/null
+++ b/openwrt/target/linux/package/diag/Config.in
@@ -0,0 +1,5 @@
+config BR2_PACKAGE_KMOD_DIAG
+ tristate "kmod-diag"
+ default y
+ help
+ Driver for router LEDs and Buttons
diff --git a/openwrt/target/linux/package/diag/Makefile b/openwrt/target/linux/package/diag/Makefile
new file mode 100644
index 0000000000..826fd07a82
--- /dev/null
+++ b/openwrt/target/linux/package/diag/Makefile
@@ -0,0 +1,37 @@
+# Makefile for the diag module
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME := kmod-diag
+PKG_RELEASE := 1
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,KMOD_DIAG,$(PKG_NAME),$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE),$(ARCH),kernel ($(LINUX_VERSION)-$(BOARD)-$(KERNEL_RELEASE))))
+
+ifeq ($(KERNEL_DIR),)
+KERNEL_DIR:=$(LINUX_DIR)
+endif
+
+DIAG_FLAGS:=$(TARGET_CFLAGS) -D__KERNEL__ -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \
+ -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 \
+ -Wa,-mips32 -Wa,--trap -Wstrict-prototypes -Wno-trigraphs -DMODULE -mlong-calls -fno-common -I. -I linux-2.4 -nostdinc \
+ -iwithprefix include -I$(KERNEL_DIR)/include -I$(KERNEL_DIR)/include/asm/gcc -c -I$(KERNEL_DIR)/arch/mips/bcm947xx/include -DBCMDRIVER
+
+$(PKG_BUILD_DIR)/.prepared:
+ mkdir -p $(PKG_BUILD_DIR)
+ touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/diag.o
+ touch $@
+
+$(PKG_BUILD_DIR)/diag.o: $(PKG_BUILD_DIR)/.prepared
+ $(TARGET_CC) $(DIAG_FLAGS) -o $@ diag_led.c
+
+$(IPKG_KMOD_DIAG): $(PKG_BUILD_DIR)/diag.o
+ mkdir -p $(IDIR_KMOD_DIAG)/lib/modules/$(LINUX_VERSION)
+ cp $(PKG_BUILD_DIR)/diag.o $(IDIR_KMOD_DIAG)/lib/modules/$(LINUX_VERSION)/
+ $(IPKG_BUILD) $(IDIR_KMOD_DIAG) $(PACKAGE_DIR)
diff --git a/openwrt/target/linux/package/diag/diag_led.c b/openwrt/target/linux/package/diag/diag_led.c
new file mode 100644
index 0000000000..cc2bc8a24e
--- /dev/null
+++ b/openwrt/target/linux/package/diag/diag_led.c
@@ -0,0 +1,245 @@
+/*
+ * diag_led.c - replacement diag module
+ *
+ * Copyright (C) 2004 Mike Baker,
+ * Imre Kaloz <kaloz@dune.hu>
+ *
+ * This program is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ *
+ * $Id$
+ */
+
+/*
+ * ChangeLog:
+ * 2004/03/28 initial release
+ * 2004/08/26 asus & buffalo support added
+ * 2005/03/14 asus wl-500g deluxe and buffalo v2 support added
+ * 2005/04/13 added licensing informations
+ * 2005/04/18 base reset polarity off initial readings
+ */
+
+#include <linux/module.h>
+#include <linux/init.h>
+#include <linux/kernel.h>
+#include <linux/sysctl.h>
+#include <asm/io.h>
+#include <typedefs.h>
+#include <bcmdevs.h>
+#include <sbutils.h>
+
+extern char * nvram_get(const char *name);
+static void *sbh;
+
+// v2.x - - - - -
+#define DIAG_GPIO (1<<1)
+#define DMZ_GPIO (1<<7)
+
+static void set_gpio(uint32 mask, uint32 value) {
+ sb_gpiocontrol(sbh,mask,0);
+ sb_gpioouten(sbh,mask,mask);
+ sb_gpioout(sbh,mask,value);
+}
+
+static void v2_set_diag(u8 state) {
+ set_gpio(DIAG_GPIO,state);
+}
+static void v2_set_dmz(u8 state) {
+ set_gpio(DMZ_GPIO,state);
+}
+
+// v1.x - - - - -
+#define LED_DIAG 0x13
+#define LED_DMZ 0x12
+
+static void v1_set_diag(u8 state) {
+ if (!state) {
+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DIAG)=0xFF;
+ } else {
+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DIAG);
+ }
+}
+static void v1_set_dmz(u8 state) {
+ if (!state) {
+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DMZ)=0xFF;
+ } else {
+ *(volatile u8*)(KSEG1ADDR(BCM4710_EUART)+LED_DMZ);
+ }
+}
+
+// - - - - -
+static void ignore(u8 ignored) {};
+
+// - - - - -
+#define BIT_DMZ 0x01
+#define BIT_DIAG 0x04
+
+void (*set_diag)(u8 state);
+void (*set_dmz)(u8 state);
+
+static unsigned int diag = 0;
+
+static void diag_change()
+{
+ set_diag(0xFF); // off
+ set_dmz(0xFF); // off
+
+ if(diag & BIT_DIAG)
+ set_diag(0x00); // on
+ if(diag & BIT_DMZ)
+ set_dmz(0x00); // on
+}
+
+static int proc_diag(ctl_table *table, int write, struct file *filp,
+ void *buffer, size_t *lenp)
+{
+ int r;
+ r = proc_dointvec(table, write, filp, buffer, lenp);
+ if (write && !r) {
+ diag_change();
+ }
+ return r;
+}
+
+// - - - - -
+static unsigned char reset_gpio = 0;
+static unsigned char reset_polarity = 0;
+static unsigned int reset = 0;
+
+static int proc_reset(ctl_table *table, int write, struct file *filp,
+ void *buffer, size_t *lenp)
+{
+
+ if (reset_gpio) {
+ sb_gpiocontrol(sbh,reset_gpio,reset_gpio);
+ sb_gpioouten(sbh,reset_gpio,0);
+ reset=!(sb_gpioin(sbh)&reset_gpio);
+
+ if (reset_polarity) reset=!reset;
+ } else {
+ reset=0;
+ }
+
+ return proc_dointvec(table, write, filp, buffer, lenp);
+}
+
+// - - - - -
+static struct ctl_table_header *diag_sysctl_header;
+
+static ctl_table sys_diag[] = {
+ {
+ ctl_name: 2000,
+ procname: "diag",
+ data: &diag,
+ maxlen: sizeof(diag),
+ mode: 0644,
+ proc_handler: proc_diag
+ },
+ {
+ ctl_name: 2001,
+ procname: "reset",
+ data: &reset,
+ maxlen: sizeof(reset),
+ mode: 0444,
+ proc_handler: proc_reset
+ },
+ { 0 }
+};
+
+static int __init diag_init()
+{
+ char *buf;
+ u32 board_type;
+ sbh = sb_kattach();
+ sb_gpiosetcore(sbh);
+
+ board_type = sb_boardtype(sbh);
+ printk(KERN_INFO "diag boardtype: %08x\n",board_type);
+
+ set_diag=ignore;
+ set_dmz=ignore;
+
+ buf=nvram_get("boardrev");
+ if (((board_type & 0xf00) == 0x400) && strcmp(buf,"0x10")) {
+ buf=nvram_get("boardtype")?:"";
+ if (!strcmp(buf,"bcm94710dev")) {
+ buf=nvram_get("boardnum")?:"";
+ if (!strcmp(buf,"42")) {
+ // wrt54g v1.x
+ set_diag=v1_set_diag;
+ set_dmz=v1_set_dmz;
+ reset_gpio=(1<<6);
+ }
+ if (!strcmp(buf,"asusX")) {
+ //asus wl-500g
+ reset_gpio=(1<<6);
+ }
+ }
+ if (!strcmp(buf,"bcm94710ap")) {
+ buf=nvram_get("boardnum")?:"";
+ if (!strcmp(buf,"42")) {
+ // buffalo
+ set_dmz=v2_set_dmz;
+ reset_gpio=(1<<4);
+ }
+ if (!strcmp(buf,"44")) {
+ //dell truemobile
+ set_dmz=v2_set_dmz;
+ reset_gpio=(1<<0);
+ }
+ }
+ } else {
+ buf=nvram_get("boardnum")?:"";
+ if (!strcmp(buf,"42")) {
+ //linksys
+ set_diag=v2_set_diag;
+ set_dmz=v2_set_dmz;
+ reset_gpio=(1<<6);
+ }
+ if (!strcmp(buf,"44")) {
+ //motorola
+ reset_gpio=(1<<5);
+ }
+ if (!strcmp(buf,"00")) {
+ //buffalo
+ reset_gpio=(1<<7);
+ }
+ if (!strcmp(buf,"45")) {
+ //wl-500g deluxe
+ reset_gpio=(1<<6);
+ }
+ }
+
+
+ sb_gpiocontrol(sbh,reset_gpio,reset_gpio);
+ sb_gpioouten(sbh,reset_gpio,0);
+ reset_polarity=!(sb_gpioin(sbh)&reset_gpio);
+
+ diag_sysctl_header = register_sysctl_table(sys_diag, 0);
+ diag_change();
+
+ return 0;
+}
+
+static void __exit diag_exit()
+{
+ unregister_sysctl_table(diag_sysctl_header);
+}
+
+EXPORT_NO_SYMBOLS;
+MODULE_AUTHOR("openwrt.org");
+MODULE_LICENSE("GPL");
+
+module_init(diag_init);
+module_exit(diag_exit);
diff --git a/openwrt/target/linux/control/kmod-diag.control b/openwrt/target/linux/package/diag/ipkg/kmod-diag.control
index 8e7603cf00..7a4e9ae111 100644
--- a/openwrt/target/linux/control/kmod-diag.control
+++ b/openwrt/target/linux/package/diag/ipkg/kmod-diag.control
@@ -1,6 +1,6 @@
Package: kmod-diag
Priority: essential
Section: sys
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Maintainer: OpenWrt Developer Team <bugs@openwrt.org>
Source: buildroot internal
Description: Driver for Router LEDs and Buttons