aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-06 18:18:49 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-06 18:18:49 +0000
commit202bd581be73e10869f3d3b845d68ce07b48ec26 (patch)
treeaa69607ea696425b6edbd0a08982597ebcd0cc33
parent433125c1a631ef33db9d438d92c1af132c135b69 (diff)
downloadupstream-202bd581be73e10869f3d3b845d68ce07b48ec26.tar.gz
upstream-202bd581be73e10869f3d3b845d68ce07b48ec26.tar.bz2
upstream-202bd581be73e10869f3d3b845d68ce07b48ec26.zip
build: add new option to add disabled feeds commented out to opkg.conf
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> Backport of r42004 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42018 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/base-files/image-config.in7
-rw-r--r--package/system/opkg/Makefile5
2 files changed, 12 insertions, 0 deletions
diff --git a/package/base-files/image-config.in b/package/base-files/image-config.in
index d745369a2c..3029648d85 100644
--- a/package/base-files/image-config.in
+++ b/package/base-files/image-config.in
@@ -216,6 +216,13 @@ menuconfig PER_FEED_REPO
If set, a separate repository is generated within bin/*/packages/
for the core packages and each enabled feed.
+ config PER_FEED_REPO_ADD_DISABLED
+ bool "Add installed but disabled feeds to opkg.conf"
+ default y
+ depends on PER_FEED_REPO
+ help
+ Add installed but disabled feeds as commented out source lines to opkg.conf.
+
source "tmp/.config-feeds.in"
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 5dfabc2ca2..8a63fb4352 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -111,6 +111,11 @@ define Package/opkg/Default/install
for d in base $(FEEDS_ENABLED); do \
echo "src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
done
+ ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
+ for d in $(FEEDS_DISABLED); do \
+ echo "# src/gz %n_$$$$d %U/$$$$d" >> $(1)/etc/opkg.conf; \
+ done
+ endif
endif
$(VERSION_SED) $(1)/etc/opkg.conf
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/opkg-cl $(1)/bin/opkg