aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-19 23:50:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-19 23:50:09 +0000
commit1c490b441123124f2123c0269900abd4557f30d6 (patch)
tree5773a5c3a230c5e4bbd910e115cb5aee58ac7254
parent098c15a3797c89deb580a3bef74496f284270fc6 (diff)
downloadupstream-1c490b441123124f2123c0269900abd4557f30d6.tar.gz
upstream-1c490b441123124f2123c0269900abd4557f30d6.tar.bz2
upstream-1c490b441123124f2123c0269900abd4557f30d6.zip
cns3xxx: build images for the old boot loader and the new one (default to the new one)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33488 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/cns3xxx/image/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/target/linux/cns3xxx/image/Makefile b/target/linux/cns3xxx/image/Makefile
index 0265d7c545..271d5ea198 100644
--- a/target/linux/cns3xxx/image/Makefile
+++ b/target/linux/cns3xxx/image/Makefile
@@ -7,12 +7,18 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define mkimage
+ mkimage -A arm -O linux -T kernel -C none -a $(2) -e $(2) -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/uImage-$(1)
+endef
+
define Image/Prepare
- cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+ $(call mkimage,old,0x00008000)
+ $(call mkimage,new,0x20008000)
endef
define Image/BuildKernel
- cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+ cp $(KDIR)/uImage-old $(BIN_DIR)/openwrt-$(BOARD)-old-uboot-uImage
+ cp $(KDIR)/uImage-new $(BIN_DIR)/openwrt-$(BOARD)-uImage
endef
define Image/Build