aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-11 19:47:33 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-11 19:48:09 +0100
commit1ad30be982e953a36e4677d3022248a962f039b9 (patch)
tree64acc60d0995d82544b45b577d88744a5067842d
parentfbe522d1204149b6c128d55e360bfc15fa8258e1 (diff)
downloadupstream-1ad30be982e953a36e4677d3022248a962f039b9.tar.gz
upstream-1ad30be982e953a36e4677d3022248a962f039b9.tar.bz2
upstream-1ad30be982e953a36e4677d3022248a962f039b9.zip
Revert the recent dependency and metadata scanning rework
This reverts the following commits: fbe522d1204149b6c128d55e360bfc15fa8258e1 278ad007ee03c4455c3507322e34b0e3e6ec050d 863888e44f7a1fb1675a2e7a2eaabfec3561d2a2 96daf6352f6e04bc22789466cb5409b93fbec191 cfd83555fc4f0bab18a26f6812da18e64df46ff3 This seems to trigger some mconf bugs when built with all feeds packages, so I will try to find a less intrusive solution before the release. Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--package/network/utils/comgt/Makefile2
-rw-r--r--package/network/utils/umbim/Makefile2
-rw-r--r--package/network/utils/uqmi/Makefile2
-rw-r--r--package/system/mountd/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index 2b39de648a..9ddc61758f 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -39,7 +39,7 @@ endef
define Package/comgt-directip
$(call Package/comgt/Default)
TITLE:=Sierra Wireless Direct-IP support
- DEPENDS:=+comgt +USB_SUPPORT:kmod-usb-serial +USB_SUPPORT:kmod-usb-serial-sierrawireless +USB_SUPPORT:kmod-usb-net +USB_SUPPORT:kmod-usb-net-sierrawireless
+ DEPENDS:=+comgt +kmod-usb-serial +kmod-usb-serial-sierrawireless +kmod-usb-net +kmod-usb-net-sierrawireless
endef
define Package/comgt-ncm
diff --git a/package/network/utils/umbim/Makefile b/package/network/utils/umbim/Makefile
index 0c02f897ce..42d4b85eaa 100644
--- a/package/network/utils/umbim/Makefile
+++ b/package/network/utils/umbim/Makefile
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/cmake.mk
define Package/umbim
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+libubox +USB_SUPPORT:kmod-usb-net +USB_SUPPORT:kmod-usb-net-cdc-mbim +wwan
+ DEPENDS:=+libubox +kmod-usb-net +kmod-usb-net-cdc-mbim +wwan
TITLE:=Control utility for mobile broadband modems
endef
diff --git a/package/network/utils/uqmi/Makefile b/package/network/utils/uqmi/Makefile
index d559197bd3..41db1e7671 100644
--- a/package/network/utils/uqmi/Makefile
+++ b/package/network/utils/uqmi/Makefile
@@ -22,7 +22,7 @@ define Package/uqmi
SECTION:=net
CATEGORY:=Network
SUBMENU:=WWAN
- DEPENDS:=+libubox +libblobmsg-json +USB_SUPPORT:kmod-usb-net +USB_SUPPORT:kmod-usb-net-qmi-wwan +wwan
+ DEPENDS:=+libubox +libblobmsg-json +kmod-usb-net +kmod-usb-net-qmi-wwan +wwan
TITLE:=Control utility for mobile broadband modems
endef
diff --git a/package/system/mountd/Makefile b/package/system/mountd/Makefile
index 28172b3d7b..6922f2f5a0 100644
--- a/package/system/mountd/Makefile
+++ b/package/system/mountd/Makefile
@@ -23,7 +23,7 @@ define Package/mountd
SECTION:=utils
CATEGORY:=Utilities
TITLE:=OpenWrt automount daemon
- DEPENDS:=+USB_SUPPORT:kmod-usb-storage +uci +kmod-fs-autofs4
+ DEPENDS:=@USB_SUPPORT +uci +kmod-usb-storage +kmod-fs-autofs4
URL:=http://www.openwrt.org
endef