aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-12-06 11:52:18 +0000
committerNicolas Thill <nico@openwrt.org>2005-12-06 11:52:18 +0000
commit1a996c03259075e74e4c77ec42a1cba9c762c4be (patch)
treee2ef37419b6d2c792e45c15bf2ac4c3f43ac6f6d
parent9d8a63a125acfb95812f50a79afe0cd7d8ccc99b (diff)
downloadupstream-1a996c03259075e74e4c77ec42a1cba9c762c4be.tar.gz
upstream-1a996c03259075e74e4c77ec42a1cba9c762c4be.tar.bz2
upstream-1a996c03259075e74e4c77ec42a1cba9c762c4be.zip
update lighttpd to new upstream release (v1.4.8), add a mod-accesslog sub-package.
SVN-Revision: 2581
-rw-r--r--openwrt/package/lighttpd/Config.in6
-rw-r--r--openwrt/package/lighttpd/Makefile6
-rw-r--r--openwrt/package/lighttpd/ipkg/lighttpd-mod-accesslog.control5
3 files changed, 15 insertions, 2 deletions
diff --git a/openwrt/package/lighttpd/Config.in b/openwrt/package/lighttpd/Config.in
index 997036c57a..cf9dedf395 100644
--- a/openwrt/package/lighttpd/Config.in
+++ b/openwrt/package/lighttpd/Config.in
@@ -13,6 +13,12 @@ config BR2_PACKAGE_LIGHTTPD
Depends: libopenssl, libpcre
+config BR2_PACKAGE_LIGHTTPD_MOD_ACCESSLOG
+ prompt "lighttpd-mod-accesslog.......... Access logging module"
+ tristate
+ default m if CONFIG_DEVEL
+ depends BR2_PACKAGE_LIGHTTPD
+
config BR2_PACKAGE_LIGHTTPD_MOD_ALIAS
prompt "lighttpd-mod-alias.............. Directory alias module"
tristate
diff --git a/openwrt/package/lighttpd/Makefile b/openwrt/package/lighttpd/Makefile
index 486f851b35..65a8d35141 100644
--- a/openwrt/package/lighttpd/Makefile
+++ b/openwrt/package/lighttpd/Makefile
@@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lighttpd
-PKG_VERSION:=1.4.7
+PKG_VERSION:=1.4.8
PKG_RELEASE:=1
-PKG_MD5SUM:=4d1b02e2008e5f35e4df7defee186fdd
+PKG_MD5SUM:=7d7790ef95ff5755f73bfcda4f13696d
PKG_SOURCE_URL:=http://www.lighttpd.net/download/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -27,6 +27,7 @@ $$(IPKG_$(1)):
endef
$(eval $(call PKG_template,LIGHTTPD,lighttpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_ACCESSLOG,lighttpd-mod-accesslog,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,LIGHTTPD_MOD_ALIAS,lighttpd-mod-alias,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,LIGHTTPD_MOD_AUTH,lighttpd-mod-auth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,LIGHTTPD_MOD_CGI,lighttpd-mod-cgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -41,6 +42,7 @@ $(eval $(call PKG_template,LIGHTTPD_MOD_SSI,lighttpd-mod-ssi,$(PKG_VERSION)-$(PK
$(eval $(call PKG_template,LIGHTTPD_MOD_STATUS,lighttpd-mod-status,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,LIGHTTPD_MOD_USERTRACK,lighttpd-mod-usertrack,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ACCESSLOG,accesslog))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_AUTH,auth))
$(eval $(call PKG_mod_template,LIGHTTPD_MOD_CGI,cgi))
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-accesslog.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-accesslog.control
new file mode 100644
index 0000000000..640122652c
--- /dev/null
+++ b/openwrt/package/lighttpd/ipkg/lighttpd-mod-accesslog.control
@@ -0,0 +1,5 @@
+Package: lighttpd-mod-accesslog
+Priority: optional
+Section: net
+Description: an access logging module for lighttpd
+Depends: lighttpd