aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-04-18 14:19:38 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-04-18 14:19:38 +0800
commit19d9db5a96d61780af6f9ca542db9593abd78526 (patch)
tree0347ae2f7a5ec606c92598ef4e01764f0d77823d
parent1e5d014ba237cf47092c41cf3657ec64d3b99b41 (diff)
downloadupstream-19d9db5a96d61780af6f9ca542db9593abd78526.tar.gz
upstream-19d9db5a96d61780af6f9ca542db9593abd78526.tar.bz2
upstream-19d9db5a96d61780af6f9ca542db9593abd78526.zip
ramips: mt7621: use lzma-loader for newifi d1/d2/thunder timecloud
These devices failed to properly extract kernel. enable lzma loader for them. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
-rw-r--r--target/linux/ramips/image/mt7621.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index a72f758c96..aa6836d50a 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -229,6 +229,7 @@ endef
TARGET_DEVICES += dlink_dir-860l-b1
define Device/d-team_newifi-d2
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Newifi
DEVICE_MODEL := D2
@@ -460,6 +461,7 @@ endef
TARGET_DEVICES += jcg_jhr-ac876m
define Device/lenovo_newifi-d1
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Newifi
DEVICE_MODEL := D1
@@ -746,6 +748,7 @@ endef
TARGET_DEVICES += telco-electronics_x1
define Device/thunder_timecloud
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Thunder
DEVICE_MODEL := Timecloud