aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Audia <graysky@archlinux.us>2021-05-28 10:59:12 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2021-05-29 18:31:49 +0200
commit19bf1642912b120403d52bf685818b10e3736079 (patch)
tree3b04ece0cd7f349199543ceb455547395a3d0ee5
parent03bd089950d78b75d18bb434888e859c618db36c (diff)
downloadupstream-19bf1642912b120403d52bf685818b10e3736079.tar.gz
upstream-19bf1642912b120403d52bf685818b10e3736079.tar.bz2
upstream-19bf1642912b120403d52bf685818b10e3736079.zip
kernel: bump 5.4 to 5.4.123
All patches automatically rebased. Build system: x86_64 Build-tested: ipq806x/R7800 Run-tested: ipq806x/R7800 No dmesg regressions, everything functional Signed-off-by: John Audia <graysky@archlinux.us>
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/layerscape/patches-5.4/820-usb-0005-usb-dwc3-add-otg-properties-update.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 83af264c45..7ea028d9d3 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
endif
-LINUX_VERSION-5.4 = .122
+LINUX_VERSION-5.4 = .123
LINUX_VERSION-5.10 = .41
-LINUX_KERNEL_HASH-5.4.122 = 37652a41c18e4f1fff30b999ddad177c3b1e162aa4e9e2a16e8dc75cfdd0e601
+LINUX_KERNEL_HASH-5.4.123 = 8efe33fffb661d14422877b775fb38de373e04ad640f5d0c8f57144ddb1022de
LINUX_KERNEL_HASH-5.10.41 = f604759de80767c4f8bdc500eec730dc161bc914a48bd366b748c176701a6771
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
diff --git a/target/linux/layerscape/patches-5.4/820-usb-0005-usb-dwc3-add-otg-properties-update.patch b/target/linux/layerscape/patches-5.4/820-usb-0005-usb-dwc3-add-otg-properties-update.patch
index 5c567ccbf8..9d3f2ecfda 100644
--- a/target/linux/layerscape/patches-5.4/820-usb-0005-usb-dwc3-add-otg-properties-update.patch
+++ b/target/linux/layerscape/patches-5.4/820-usb-0005-usb-dwc3-add-otg-properties-update.patch
@@ -54,7 +54,7 @@ Signed-off-by: Peter Chen <peter.chen@nxp.com>
* All 3.1 IP version constants are greater than the 3.0 IP
--- a/drivers/usb/dwc3/gadget.c
+++ b/drivers/usb/dwc3/gadget.c
-@@ -3570,6 +3570,10 @@ int dwc3_gadget_init(struct dwc3 *dwc)
+@@ -3574,6 +3574,10 @@ int dwc3_gadget_init(struct dwc3 *dwc)
dwc->gadget.sg_supported = true;
dwc->gadget.name = "dwc3-gadget";
dwc->gadget.lpm_capable = true;