aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2019-06-30 17:07:56 +0200
committerJohn Crispin <john@phrozen.org>2019-07-01 16:01:10 +0200
commit18e2053becb8e295eae4439c2e107a98b88f9155 (patch)
tree4014f1cf88cd7607aa2f9836ae91e9557b6fe5f0
parentb50aef8272634088ee3a330a674756eeec005b79 (diff)
downloadupstream-18e2053becb8e295eae4439c2e107a98b88f9155.tar.gz
upstream-18e2053becb8e295eae4439c2e107a98b88f9155.tar.bz2
upstream-18e2053becb8e295eae4439c2e107a98b88f9155.zip
gemini: Add StorLink SL93512r images
This adds image generation for the StorLink reference design SL93512r. This board is now supported upstream in kernel v4.19. As this image structure is identical to SQ201 and Raidsonic, we simply refer to this as "storlink-reference" from now on. Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
-rw-r--r--target/linux/gemini/image/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index 5901bbf0c9..7b5faa04fd 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -74,14 +74,15 @@ define Build/wiligear-image
mv $@.new $@
endef
-# Create the special NAS4220B and Itian Square One SQ201 image
-# format with the squashfs and overlay inside the "rd.gz" file.
+# Create the default image format used by the StorLink reference design
+# SL93512r, Raidsonic NAS4220B and Itian Square One SQ201
+# with the squashfs and overlay inside the "rd.gz" file.
# We pad it out to 6144K which is the size of the initramfs partition.
#
# The "application" partition is just blank. You can put anything
# there when using OpenWRT. We just use that to create the
# "sysupgrade" firmware image.
-define Build/nas4220b-sq201-images
+define Build/storlink-default-images
mkdir -p $@.tmp
mv $@ $@.tmp/rd.gz
@@ -162,15 +163,16 @@ define Device/dlink_dns-313
endef
TARGET_DEVICES += dlink_dns-313
-define Device/itian-raidsonic
+# Default images setup used by the StorLink reference designs
+define Device/storlink-reference
IMAGES := factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 6144k | \
- nas4220b-sq201-images $(1)
+ storlink-default-images $(1)
DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
endef
define Device/itian_sq201
- $(Device/itian-raidsonic)
+ $(Device/storlink-reference)
DEVICE_TITLE := ITian Square One SQ201
DEVICE_DTS := gemini-sq201
DEVICE_PACKAGES += kmod-rt61-pci kmod-usb2-pci
@@ -178,13 +180,21 @@ endef
TARGET_DEVICES += itian_sq201
define Device/raidsonic_ib-4220-b
- $(Device/itian-raidsonic)
+ $(Device/storlink-reference)
DEVICE_TITLE := Raidsonic NAS IB-4220-B
DEVICE_DTS := gemini-nas4220b
DEVICE_TYPE := nas
endef
TARGET_DEVICES += raidsonic_ib-4220-b
+define Device/storlink-sl93512r
+ $(Device/storlink-reference)
+ DEVICE_TITLE := StorLink SL93512r
+ DEVICE_DTS := gemini-sl93512r
+endef
+TARGET_DEVICES += storlink_sl93512r
+
+
# The wiliboard images need some changes to be functional and buildable.
#
# The dts would need to use the ecoscentric,redboot-fis-partitions partition