aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPau Escrich <p4u@dabax.net>2018-01-12 16:36:25 +0100
committerDaniel Golle <daniel@makrotopia.org>2018-11-15 19:49:51 +0100
commit15f16bf05b8441aed0e0c6000740996b75724ac1 (patch)
tree497db6a28495edfdf3d0d144e711e63ddc4157ad
parentc6a1bcac16f92afa1e41eaceafc85075d97a74cd (diff)
downloadupstream-15f16bf05b8441aed0e0c6000740996b75724ac1.tar.gz
upstream-15f16bf05b8441aed0e0c6000740996b75724ac1.tar.bz2
upstream-15f16bf05b8441aed0e0c6000740996b75724ac1.zip
ar71xx: add support for Gainstrong MiniBox V3.2
Adds MiniBox V3.2 ar71xx target (QCA99531 + QCA9887) Info: http://oolite.cn/minibox-v3-2-qca9531-qca9887-module-pin-specification.html Reference patch: http://oolite.cn/wp-content/uploads/2017/09/minibox_v3_cc15.05_20160325.patch Installation: Upload firmware to uboot via HTTP at 192.168.1.1 (press button for 5 seconds) Signed-off-by: Pau Escrich <p4u@dabax.net> Signed-off-by: Daniel Golle <daniel@makrotopia.org> (daniel@makrotopia.org: rebased and fixed conflicts, fixed LED name, added ath10k eeprom)
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh1
-rw-r--r--target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata1
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.141
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt12
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-gs-minibox-v32.c121
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/generic/config-default1
-rw-r--r--target/linux/ar71xx/image/generic.mk10
11 files changed, 153 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index fafdcce8f7..3c9f17d8c3 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -30,6 +30,7 @@ get_status_led() {
e750g-v8|\
eap120|\
minibox-v1|\
+ minibox-v3.2|\
packet-squirrel|\
som9331|\
sr3200|\
diff --git a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index e08df23df6..ed92f87b20 100644
--- a/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -76,6 +76,7 @@ case "$FIRMWARE" in
dlan-pro-1200-ac|\
e1700ac-v2|\
e600gac-v2|\
+ minibox-v3.2|\
oolite-v5.2|\
oolite-v5.2-dev|\
sr3200|\
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 05f497fcbf..b11d2cf926 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -829,6 +829,9 @@ ar71xx_board_detect() {
*"MiniBox V1.0")
name="minibox-v1"
;;
+ *"Minibox V3.2")
+ name="minibox-v3.2"
+ ;;
*"MR12")
name="mr12"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index e2d9aafec0..21ad3075bd 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -415,6 +415,7 @@ platform_check_image() {
lan-turtle|\
mc-mac1200r|\
minibox-v1|\
+ minibox-v3.2|\
omy-g1|\
omy-x1|\
onion-omega|\
diff --git a/target/linux/ar71xx/config-4.14 b/target/linux/ar71xx/config-4.14
index 535b5195cd..9a524fae43 100644
--- a/target/linux/ar71xx/config-4.14
+++ b/target/linux/ar71xx/config-4.14
@@ -130,6 +130,7 @@ CONFIG_ATH79=y
# CONFIG_ATH79_MACH_GL_INET is not set
# CONFIG_ATH79_MACH_GL_MIFI is not set
# CONFIG_ATH79_MACH_GL_USB150 is not set
+# CONFIG_ATH79_MACH_GS_MINIBOX_V32 is not set
# CONFIG_ATH79_MACH_GS_OOLITE_V1 is not set
# CONFIG_ATH79_MACH_GS_OOLITE_V5_2 is not set
# CONFIG_ATH79_MACH_HIVEAP_121 is not set
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index f60825a6dd..a5a8452e6d 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -924,6 +924,18 @@ config ATH79_MACH_EAP300V2
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_GS_MINIBOX_V32
+ bool "Gainstrong Minibox V3.2 support"
+ select SOC_QCA953X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_SPI
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+ select ATH79_DEV_ETH
+ select ATH79_DEV_M25P80
+
config ATH79_MACH_GS_OOLITE_V1
bool "GainStrong Oolite/Minibox V1.0 support"
select SOC_AR933X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 0a2fc9c17d..0265b3d818 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -140,6 +140,7 @@ obj-$(CONFIG_ATH79_MACH_GL_DOMINO) += mach-gl-domino.o
obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
obj-$(CONFIG_ATH79_MACH_GL_MIFI) += mach-gl-mifi.o
obj-$(CONFIG_ATH79_MACH_GL_USB150) += mach-gl-usb150.o
+obj-$(CONFIG_ATH79_MACH_GS_MINIBOX_V32) += mach-gs-minibox-v32.o
obj-$(CONFIG_ATH79_MACH_GS_OOLITE_V1) += mach-gs-oolite-v1.o
obj-$(CONFIG_ATH79_MACH_GS_OOLITE_V5_2) += mach-gs-oolite-v5-2.o
obj-$(CONFIG_ATH79_MACH_HIVEAP_121) += mach-hiveap-121.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-gs-minibox-v32.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-gs-minibox-v32.c
new file mode 100644
index 0000000000..469c6f39ea
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-gs-minibox-v32.c
@@ -0,0 +1,121 @@
+/*
+ * Atheros GS_MINIBOX_V3.2 reference board support
+ *
+ * Copyright (c) 2018 OpenWRT.org
+ * Copyright (c) 2013 The Linux Foundation. All rights reserved.
+ * Copyright (c) 2012 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include <linux/pci.h>
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-ap9x-pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-spi.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+#include "pci.h"
+
+#define GS_MINIBOX_V3_GPIO_LED_STATUS 14
+#define GS_MINIBOX_V3_GPIO_BTN_RST 17
+#define GS_MINIBOX_V3_KEYS_POLL_INTERVAL 20 /* msecs */
+#define GS_MINIBOX_V3_KEYS_DEBOUNCE_INTERVAL (3 * GS_MINIBOX_V3_KEYS_POLL_INTERVAL)
+#define GS_MINIBOX_V3_MAC0_OFFSET 0
+#define GS_MINIBOX_V3_MAC1_OFFSET 6
+#define GS_MINIBOX_V3_WMAC_CALDATA_OFFSET 0x1000
+
+static const char *gs_minibox_v3_part_probes[] = {
+ "tp-link",
+ NULL,
+};
+
+static struct flash_platform_data gs_minibox_v3_flash_data = {
+ .part_probes = gs_minibox_v3_part_probes,
+};
+
+static struct gpio_led gs_minibox_v3_leds_gpio[] __initdata = {
+ {
+ .name = "minibox_v3.2:green:system",
+ .gpio = GS_MINIBOX_V3_GPIO_LED_STATUS,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button gs_minibox_v3_gpio_keys[] __initdata = {
+ {
+ .desc = "reset button",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = GS_MINIBOX_V3_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = GS_MINIBOX_V3_GPIO_BTN_RST,
+ .active_low = 1,
+ },
+};
+
+static void __init gs_minibox_v3_gpio_led_setup(void)
+{
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(gs_minibox_v3_leds_gpio),
+ gs_minibox_v3_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, GS_MINIBOX_V3_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(gs_minibox_v3_gpio_keys),
+ gs_minibox_v3_gpio_keys);
+}
+
+static void __init gs_minibox_v3_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ath79_register_m25p80(&gs_minibox_v3_flash_data);
+ gs_minibox_v3_gpio_led_setup();
+
+ ath79_register_usb();
+
+ ath79_register_wmac(art + GS_MINIBOX_V3_WMAC_CALDATA_OFFSET, NULL);
+ ath79_register_mdio(0, 0x0);
+ ath79_register_mdio(1, 0x0);
+
+ ath79_init_mac(ath79_eth0_data.mac_addr, art + GS_MINIBOX_V3_MAC0_OFFSET, 0);
+ ath79_init_mac(ath79_eth1_data.mac_addr, art + GS_MINIBOX_V3_MAC1_OFFSET, 0);
+
+ /* WAN port */
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.speed = SPEED_100;
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.phy_mask = BIT(4);
+ ath79_register_eth(0);
+
+ /* LAN ports */
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+ ath79_eth1_data.speed = SPEED_1000;
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+ ath79_switch_data.phy_poll_mask |= BIT(4);
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_register_eth(1);
+
+ ath79_register_pci();
+}
+
+MIPS_MACHINE(ATH79_MACH_GS_MINIBOX_V32, "MINIBOX-V3.2", "Minibox V3.2",
+ gs_minibox_v3_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 987e80bb1f..c4a7fa350a 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -138,6 +138,7 @@ enum ath79_mach_type {
ATH79_MACH_GL_MIFI, /* GL-MIFI support */
ATH79_MACH_GL_USB150, /* GL.iNet GL-USB150 */
ATH79_MACH_GS_MINIBOX_V1, /* GainStrong MiniBox V1.0 */
+ ATH79_MACH_GS_MINIBOX_V32, /* Gainstrong MiniBox V3.2 */
ATH79_MACH_GS_OOLITE_V1, /* GainStrong Oolite V1.0 */
ATH79_MACH_GS_OOLITE_V5_2, /* GainStrong Oolite V5.2 */
ATH79_MACH_GS_OOLITE_V5_2_DEV, /* GainStrong Oolite V5.2-Dev */
diff --git a/target/linux/ar71xx/generic/config-default b/target/linux/ar71xx/generic/config-default
index 26717b107c..25b58ae91e 100644
--- a/target/linux/ar71xx/generic/config-default
+++ b/target/linux/ar71xx/generic/config-default
@@ -99,6 +99,7 @@ CONFIG_ATH79_MACH_GL_DOMINO=y
CONFIG_ATH79_MACH_GL_INET=y
CONFIG_ATH79_MACH_GL_MIFI=y
CONFIG_ATH79_MACH_GL_USB150=y
+CONFIG_ATH79_MACH_GS_MINIBOX_V32=y
CONFIG_ATH79_MACH_GS_OOLITE_V1=y
CONFIG_ATH79_MACH_GS_OOLITE_V5_2=y
CONFIG_ATH79_MACH_HIWIFI_HC6361=y
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 269865af92..18f0379845 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -895,6 +895,16 @@ define Device/minibox-v1
endef
TARGET_DEVICES += minibox-v1
+define Device/minibox-v3.2
+ $(Device/tplink-16mlzma)
+ DEVICE_TITLE := Gainstrong MiniBox V3.2
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k ath10k-firmware-qca9887 -swconfig
+ BOARDNAME := MINIBOX-V3.2
+ DEVICE_PROFILE := MINIBOXV32
+ TPLINK_HWID := 0x3C00010C
+endef
+TARGET_DEVICES += minibox-v3.2
+
define Device/oolite-v1
$(Device/minibox-v1)
DEVICE_TITLE := GainStrong Oolite V1.0