aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Dobrovolsky <dobrovolskiy.alexey@gmail.com>2020-04-08 21:43:36 +0300
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-12 13:46:04 +0200
commit14c8ea0245318878f4033dddb86d051a7b6e4bd0 (patch)
tree3dc0360181733a0f36d991ee87a94b7c0cf8dfcb
parent5b9b833f8c4dc973f557e90f1038d7d3f1d2042b (diff)
downloadupstream-14c8ea0245318878f4033dddb86d051a7b6e4bd0.tar.gz
upstream-14c8ea0245318878f4033dddb86d051a7b6e4bd0.tar.bz2
upstream-14c8ea0245318878f4033dddb86d051a7b6e4bd0.zip
ramips: use full 8MB flash on ZyXEL Keenetic
ZyXEL Keenetic has 8MB flash, but OpenWrt uses only 4MB. This commit fixes the problem. WikiDevi page [1] says that ZyXEL Keenetic has FLA1: 8 MiB, there is an article with specs [2] (in Russian). [1] https://wikidevi.wi-cat.ru/ZyXEL_Keenetic [2] https://3dnews.ru/608774/page-2.html Fixes: FS#2487 Fixes: a7cbf59e0e04 ("ramips: add new device ZyXEL Keenetic as kn") Signed-off-by: Alexey Dobrovolsky <dobrovolskiy.alexey@gmail.com> (cherry picked from commit fea232ae8feb6af780fd4fa78ebe9231778bf75a)
-rw-r--r--target/linux/ramips/dts/kn.dts2
-rw-r--r--target/linux/ramips/image/rt305x.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ramips/dts/kn.dts b/target/linux/ramips/dts/kn.dts
index 1f9928e59a..baa24a961f 100644
--- a/target/linux/ramips/dts/kn.dts
+++ b/target/linux/ramips/dts/kn.dts
@@ -48,7 +48,7 @@
partition@50000 {
compatible = "denx,uimage";
label = "firmware";
- reg = <0x50000 0x3b0000>;
+ reg = <0x50000 0x7b0000>;
};
};
};
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index f59a748949..739656cc40 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -905,7 +905,7 @@ TARGET_DEVICES += xdxrn502j
define Device/kn
DTS := kn
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE_SIZE := 7872k
DEVICE_TITLE := ZyXEL Keenetic
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
DEFAULT := n