aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-05-30 16:36:05 +0200
committerPetr Štetiar <ynezz@true.cz>2023-06-12 22:10:19 +0200
commit145d485d51330c40deccce8e249a1da4b1c283ca (patch)
treed77820633c1241de62c9b170c6fe44c48917c354
parent03455e79d7a4a0da5399618851168dfadebf416e (diff)
downloadupstream-145d485d51330c40deccce8e249a1da4b1c283ca.tar.gz
upstream-145d485d51330c40deccce8e249a1da4b1c283ca.tar.bz2
upstream-145d485d51330c40deccce8e249a1da4b1c283ca.zip
ipq807x: image: factor out common eMMC bits
For better maintainability and reusability. Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit a9be186466fdb4987c158916781d99329d1c3712)
-rw-r--r--target/linux/ipq807x/image/generic.mk21
1 files changed, 12 insertions, 9 deletions
diff --git a/target/linux/ipq807x/image/generic.mk b/target/linux/ipq807x/image/generic.mk
index 609c6690d1..f4a872ce09 100644
--- a/target/linux/ipq807x/image/generic.mk
+++ b/target/linux/ipq807x/image/generic.mk
@@ -10,6 +10,13 @@ define Device/FitImageLzma
KERNEL_NAME := Image
endef
+define Device/EmmcImage
+ IMAGES += factory.bin sysupgrade.bin
+ IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k
+ IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to 64k | sysupgrade-tar rootfs=$$$$@ | append-metadata
+ DEVICE_PACKAGES := e2fsprogs kmod-fs-ext4 losetup
+endef
+
define Device/UbiFit
KERNEL_IN_UBI := 1
IMAGES := factory.ubi sysupgrade.bin
@@ -90,16 +97,14 @@ TARGET_DEVICES += netgear_wax218
define Device/qnap_301w
$(call Device/FitImage)
+ $(call Device/EmmcImage)
DEVICE_VENDOR := QNAP
DEVICE_MODEL := 301w
DEVICE_DTS_CONFIG := config@hk01
KERNEL_SIZE := 16384k
BLOCKSIZE := 512k
SOC := ipq8072
- IMAGES += factory.bin sysupgrade.bin
- IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k
- IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to 64k | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := ipq-wifi-qnap_301w e2fsprogs kmod-fs-ext4 losetup
+ DEVICE_PACKAGES += ipq-wifi-qnap_301w
endef
TARGET_DEVICES += qnap_301w
@@ -150,16 +155,14 @@ TARGET_DEVICES += xiaomi_ax9000
define Device/zyxel_nbg7815
$(call Device/FitImage)
+ $(call Device/EmmcImage)
DEVICE_VENDOR := ZYXEL
DEVICE_MODEL := NBG7815
DEVICE_DTS_CONFIG := config@nbg7815
BLOCKSIZE := 128k
PAGESIZE := 2048
SOC := ipq8074
- IMAGES += factory.bin sysupgrade.bin
- IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k
- IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to 64k | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := ipq-wifi-zyxel_nbg7815 kmod-ath11k-pci e2fsprogs kmod-fs-ext4 losetup \
- kmod-hwmon-tmp103 kmod-bluetooth
+ DEVICE_PACKAGES += ipq-wifi-zyxel_nbg7815 kmod-ath11k-pci kmod-hwmon-tmp103 \
+ kmod-bluetooth
endef
TARGET_DEVICES += zyxel_nbg7815