aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-01-29 21:26:43 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-01-29 21:26:43 +0000
commit1430462520bb27fd0f60495be00a3f3fb6d4b04e (patch)
tree969af184f3123a8cfe999a223ff900cbc918b328
parentc6c07d95f226a1621274437202d82fb4868e542f (diff)
downloadupstream-1430462520bb27fd0f60495be00a3f3fb6d4b04e.tar.gz
upstream-1430462520bb27fd0f60495be00a3f3fb6d4b04e.tar.bz2
upstream-1430462520bb27fd0f60495be00a3f3fb6d4b04e.zip
upgrade libvorbis to v1.1.2, spca5xx to v20060101 and add gcc4 fix for shfs
SVN-Revision: 3068
-rw-r--r--openwrt/package/libvorbis/Makefile4
-rw-r--r--openwrt/package/libvorbis/patches/100-no_examples.patch12
-rw-r--r--openwrt/package/libvorbis/patches/libvorbis-1.1.1-gcc4-1.patch60
-rw-r--r--openwrt/target/linux/package/shfs/patches/102-gcc4_fix.patch23
-rw-r--r--openwrt/target/linux/package/spca5xx/Makefile4
5 files changed, 39 insertions, 64 deletions
diff --git a/openwrt/package/libvorbis/Makefile b/openwrt/package/libvorbis/Makefile
index dc7e5e09e0..204d137ecf 100644
--- a/openwrt/package/libvorbis/Makefile
+++ b/openwrt/package/libvorbis/Makefile
@@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libvorbis
-PKG_VERSION:=1.1.1
+PKG_VERSION:=1.1.2
PKG_RELEASE:=1
-PKG_MD5SUM:=b77270c24840af4de54bea5ad1c0b252
+PKG_MD5SUM:=37847626b8e1b53ae79a34714c7b3211
PKG_SOURCE_URL:=http://downloads.xiph.org/releases/vorbis/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/openwrt/package/libvorbis/patches/100-no_examples.patch b/openwrt/package/libvorbis/patches/100-no_examples.patch
new file mode 100644
index 0000000000..35c50a4c59
--- /dev/null
+++ b/openwrt/package/libvorbis/patches/100-no_examples.patch
@@ -0,0 +1,12 @@
+diff -ur libvorbis-1.1.2/Makefile.in libvorbis-1.1.2-owrt/Makefile.in
+--- libvorbis-1.1.2/Makefile.in 2005-11-28 06:43:44.000000000 +0100
++++ libvorbis-1.1.2-owrt/Makefile.in 2006-01-29 21:55:23.000000000 +0100
+@@ -217,7 +217,7 @@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
+ AUTOMAKE_OPTIONS = foreign dist-zip
+-SUBDIRS = lib include doc examples vq
++SUBDIRS = lib include doc vq
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = vorbis.m4
+ pkgconfigdir = $(libdir)/pkgconfig
diff --git a/openwrt/package/libvorbis/patches/libvorbis-1.1.1-gcc4-1.patch b/openwrt/package/libvorbis/patches/libvorbis-1.1.1-gcc4-1.patch
deleted file mode 100644
index 480172fcf9..0000000000
--- a/openwrt/package/libvorbis/patches/libvorbis-1.1.1-gcc4-1.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-Submitted By: Steffen Knollmann <sknolli at astro.physik.uni-goettingen.de>
-Date: 2005-11-09
-Initial Package Version: 1.1.1
-Upstream Status: From Upstream
-Origin: msmith, courtesy of upstream SVN
-Description: Fixes an optimization problem with gcc-4.0.x that results in
- dysfunctional library that will produce bigger encoded files
- with a poor audio quality. Detailed description at:
- http://trac.xiph.org/cgi-bin/trac.cgi/ticket/583
-
-$LastChangedBy: randy $
-$Date: 2005-11-18 08:12:42 -0700 (Fri, 18 Nov 2005) $
-
-
---- libvorbis-1.1.1/lib/scales.h (revision 9958)
-+++ libvorbis-1.1.1/lib/scales.h (revision 9959)
-@@ -26,20 +26,24 @@
- #ifdef VORBIS_IEEE_FLOAT32
-
- static float unitnorm(float x){
-- ogg_uint32_t *ix=(ogg_uint32_t *)&x;
-- *ix=(*ix&0x80000000UL)|(0x3f800000UL);
-- return(x);
--}
--
--static float FABS(float *x){
-- ogg_uint32_t *ix=(ogg_uint32_t *)x;
-- *ix&=0x7fffffffUL;
-- return(*x);
-+ union {
-+ ogg_uint32_t i;
-+ float f;
-+ } ix;
-+ ix.f = x;
-+ ix.i = (ix.i & 0x80000000U) | (0x3f800000U);
-+ return ix.f;
- }
-
- /* Segher was off (too high) by ~ .3 decibel. Center the conversion correctly. */
- static float todB(const float *x){
-- return (float)((*(ogg_int32_t *)x)&0x7fffffff) * 7.17711438e-7f -764.6161886f;
-+ union {
-+ ogg_uint32_t i;
-+ float f;
-+ } ix;
-+ ix.f = *x;
-+ ix.i = ix.i&0x7fffffff;
-+ return (float)(ix.i * 7.17711438e-7f -764.6161886f);
- }
-
- #define todB_nn(x) todB(x)
-@@ -51,8 +55,6 @@
- return(1.f);
- }
-
--#define FABS(x) fabs(*(x))
--
- #define todB(x) (*(x)==0?-400.f:log(*(x)**(x))*4.34294480f)
- #define todB_nn(x) (*(x)==0.f?-400.f:log(*(x))*8.6858896f)
-
diff --git a/openwrt/target/linux/package/shfs/patches/102-gcc4_fix.patch b/openwrt/target/linux/package/shfs/patches/102-gcc4_fix.patch
new file mode 100644
index 0000000000..c4fd36629b
--- /dev/null
+++ b/openwrt/target/linux/package/shfs/patches/102-gcc4_fix.patch
@@ -0,0 +1,23 @@
+diff -ur shfs-0.35/shfs/Linux-2.6/dir.c shfs-0.35-new/shfs/Linux-2.6/dir.c
+--- shfs-0.35/shfs/Linux-2.6/dir.c 2004-06-01 09:16:19.000000000 -0400
++++ shfs-0.35-new/shfs/Linux-2.6/dir.c 2005-02-11 18:12:00.000000000 -0500
+@@ -19,6 +19,8 @@
+ #include "shfs_debug.h"
+ #include "proc.h"
+
++static struct dentry_operations shfs_dentry_operations;
++
+ static int
+ shfs_dir_open(struct inode *inode, struct file *filp)
+ {
+diff -ur shfs-0.35/shfs/Linux-2.6/shfs_fs.h shfs-0.35-new/shfs/Linux-2.6/shfs_fs.h
+--- shfs-0.35/shfs/Linux-2.6/shfs_fs.h 2004-06-01 09:16:19.000000000 -0400
++++ shfs-0.35-new/shfs/Linux-2.6/shfs_fs.h 2005-02-11 18:12:03.000000000 -0500
+@@ -50,7 +50,6 @@
+ #define ROUND_TO_MINS(x) do { (x).tv_sec = ((x).tv_sec / 60) * 60; (x).tv_nsec = 0; } while (0)
+
+ /* shfs/dir.c */
+-extern struct dentry_operations shfs_dentry_operations;
+ extern struct file_operations shfs_dir_operations;
+ extern struct inode_operations shfs_dir_inode_operations;
+ extern void shfs_new_dentry(struct dentry *dentry);
diff --git a/openwrt/target/linux/package/spca5xx/Makefile b/openwrt/target/linux/package/spca5xx/Makefile
index 8dc193ae13..95ffe5966f 100644
--- a/openwrt/target/linux/package/spca5xx/Makefile
+++ b/openwrt/target/linux/package/spca5xx/Makefile
@@ -4,9 +4,9 @@ include $(TOPDIR)/rules.mk
include ../../rules.mk
PKG_NAME:=spca5xx
-PKG_VERSION:=20051212
+PKG_VERSION:=20060101
PKG_RELEASE:=1
-PKG_MD5SUM:=f8212aa6f5e412201eefd328c3608c8d
+PKG_MD5SUM:=2a4dc191262c16c14bfd2fd563c3e8a1
PKG_SOURCE_URL:=http://mxhaard.free.fr/spca50x/Download/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz