aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-08-07 16:08:08 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-08-07 16:08:08 +0000
commit136aed85e3e522fb89e053641cb42ae8875b0098 (patch)
tree8179ba9ef1179c4c6316fb8856cf6e94a360692b
parent6fea07e8547297af80a243a70be73dac249cbe80 (diff)
downloadupstream-136aed85e3e522fb89e053641cb42ae8875b0098.tar.gz
upstream-136aed85e3e522fb89e053641cb42ae8875b0098.tar.bz2
upstream-136aed85e3e522fb89e053641cb42ae8875b0098.zip
[package] w1-gpio-custom: set enable_external_pullup to null (#8952)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33034 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/w1-gpio-custom/Makefile4
-rw-r--r--package/w1-gpio-custom/src/w1-gpio-custom.c1
2 files changed, 3 insertions, 2 deletions
diff --git a/package/w1-gpio-custom/Makefile b/package/w1-gpio-custom/Makefile
index c1441e9caa..bf50d1a50f 100644
--- a/package/w1-gpio-custom/Makefile
+++ b/package/w1-gpio-custom/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=w1-gpio-custom
-PKG_RELEASE:=2
+PKG_RELEASE:=3
include $(INCLUDE_DIR)/package.mk
diff --git a/package/w1-gpio-custom/src/w1-gpio-custom.c b/package/w1-gpio-custom/src/w1-gpio-custom.c
index 8f739d49fd..96cfcabc61 100644
--- a/package/w1-gpio-custom/src/w1-gpio-custom.c
+++ b/package/w1-gpio-custom/src/w1-gpio-custom.c
@@ -112,6 +112,7 @@ static int __init w1_gpio_custom_add_one(unsigned int id, unsigned int *params)
pdata.pin = params[BUS_PARAM_PIN];
pdata.is_open_drain = params[BUS_PARAM_OD] ? 1:0;
+ pdata.enable_external_pullup = NULL;
err = platform_device_add_data(pdev, &pdata, sizeof(pdata));
if (err)