aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-03 22:36:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-03 22:36:45 +0000
commit12fc04238eb091cfa9e8b4469c50b72ff220d1e7 (patch)
tree7e0add9ec2278f5b132aa4adc3a3a20157edd759
parentc96e173c287dcbce1813420940e79900f030c467 (diff)
downloadupstream-12fc04238eb091cfa9e8b4469c50b72ff220d1e7.tar.gz
upstream-12fc04238eb091cfa9e8b4469c50b72ff220d1e7.tar.bz2
upstream-12fc04238eb091cfa9e8b4469c50b72ff220d1e7.zip
enable preinit in a few other platforms
SVN-Revision: 6482
-rw-r--r--target/linux/aruba-2.6/patches/000-aruba.patch2
-rw-r--r--target/linux/au1000-2.6/config/default2
-rw-r--r--target/linux/ixp4xx-2.6/config/default2
-rwxr-xr-xtarget/linux/rb532-2.6/base-files/default/sbin/cf2nand2
-rw-r--r--target/linux/rb532-2.6/image/Makefile6
5 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/aruba-2.6/patches/000-aruba.patch b/target/linux/aruba-2.6/patches/000-aruba.patch
index 07e1470273..9954a492bd 100644
--- a/target/linux/aruba-2.6/patches/000-aruba.patch
+++ b/target/linux/aruba-2.6/patches/000-aruba.patch
@@ -630,10 +630,10 @@ diff -Nur linux-2.6.17/arch/mips/aruba/prom.c linux-2.6.17-owrt/arch/mips/aruba/
+
+/* Kernel Boot parameters */
+static unsigned char bootparm[] =
++ "init=/etc/preinit "
+ "mtdparts=physmap-flash.0:3520k@0x080000(zImage),2752k@0x140000(JFFS2),8k@0x3f8000(NVRAM) "
+ "console=ttyS0,9600 root=/dev/mtdblock1 rootfstype=jffs2 ";
+
-+
+extern unsigned long mips_machgroup;
+extern unsigned long mips_machtype;
+
diff --git a/target/linux/au1000-2.6/config/default b/target/linux/au1000-2.6/config/default
index 351d6fda31..967703ab50 100644
--- a/target/linux/au1000-2.6/config/default
+++ b/target/linux/au1000-2.6/config/default
@@ -7,7 +7,7 @@ CONFIG_64BIT_PHYS_ADDR=y
CONFIG_BASE_SMALL=0
# CONFIG_CC_OPTIMIZE_FOR_SIZE is not set
CONFIG_CHR_DEV_SG=m
-CONFIG_CMDLINE="root=/dev/mtdblock0 rootfstype=jffs2"
+CONFIG_CMDLINE="root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit"
# CONFIG_CPU_BIG_ENDIAN is not set
CONFIG_CPU_HAS_LLSC=y
CONFIG_CPU_HAS_PREFETCH=y
diff --git a/target/linux/ixp4xx-2.6/config/default b/target/linux/ixp4xx-2.6/config/default
index 7c9fec0d37..0acfdf4649 100644
--- a/target/linux/ixp4xx-2.6/config/default
+++ b/target/linux/ixp4xx-2.6/config/default
@@ -57,7 +57,7 @@ CONFIG_BASE_SMALL=0
# CONFIG_BSD_DISKLABEL is not set
# CONFIG_BT is not set
# CONFIG_CIFS_STATS is not set
-CONFIG_CMDLINE="root=/dev/mtdblock2 rootfstype=jffs2 noinitrd console=ttyS0,115200"
+CONFIG_CMDLINE="root=/dev/mtdblock2 rootfstype=jffs2 noinitrd console=ttyS0,115200 init=/etc/preinit"
# CONFIG_CONFIGFS_FS is not set
CONFIG_CPU_32=y
CONFIG_CPU_32v5=y
diff --git a/target/linux/rb532-2.6/base-files/default/sbin/cf2nand b/target/linux/rb532-2.6/base-files/default/sbin/cf2nand
index 9cb216ca82..74ac89402b 100755
--- a/target/linux/rb532-2.6/base-files/default/sbin/cf2nand
+++ b/target/linux/rb532-2.6/base-files/default/sbin/cf2nand
@@ -45,7 +45,7 @@ mount -t yaffs2 "$boot" /tmp/cf2nand/p1
mount -t yaffs2 "$main" /tmp/cf2nand/p2
echo "Copying kernel..."
-copy_kernel /dev/cf/card0/part1 /tmp/cf2nand/p1/kernel "root=/dev/mtdblock1 rootfstype=yaffs2 " 2>/dev/null >/dev/null
+copy_kernel /dev/cf/card0/part1 /tmp/cf2nand/p1/kernel "root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit " 2>/dev/null >/dev/null
umount /tmp/cf2nand/p1
rmdir /tmp/cf2nand/p1
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index e6794c036d..149a7e2734 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -38,15 +38,15 @@ define Image/BuildKernel
endef
define Image/cmdline/jffs2-64k
-block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=jffs2
+block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
endef
define Image/cmdline/jffs2-128k
-block2mtd.block2mtd=/dev/cfa2,131072 root=/dev/mtdblock0 rootfstype=jffs2
+block2mtd.block2mtd=/dev/cfa2,131072 root=/dev/mtdblock0 rootfstype=jffs2 init=/etc/preinit
endef
define Image/cmdline/ext2
-root=/dev/cfa2 rootfstype=ext2
+root=/dev/cfa2 rootfstype=ext2 init=/etc/preinit
endef
define Image/Build