aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-09-11 11:40:58 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-09-11 11:40:58 +0000
commit12da1b14298f6938c2221e40897911e26befc255 (patch)
treea5b4062af62609a6d5e732aab4adf204b25316e5
parentccc9de809c6705c520c9076a1e3db58a69d78110 (diff)
downloadupstream-12da1b14298f6938c2221e40897911e26befc255.tar.gz
upstream-12da1b14298f6938c2221e40897911e26befc255.tar.bz2
upstream-12da1b14298f6938c2221e40897911e26befc255.zip
add mpd from dave, thx
SVN-Revision: 1902
-rw-r--r--openwrt/package/Config.in1
-rw-r--r--openwrt/package/Makefile1
-rw-r--r--openwrt/package/mpd/Config.in19
-rw-r--r--openwrt/package/mpd/Makefile81
-rw-r--r--openwrt/package/mpd/ipkg/mpd.conffiles1
-rw-r--r--openwrt/package/mpd/ipkg/mpd.control6
-rw-r--r--openwrt/package/mpd/patches/configure.patch11
-rw-r--r--openwrt/package/mpd/patches/devices.patch33
8 files changed, 153 insertions, 0 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index faad94e898..58c24c6a32 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -173,6 +173,7 @@ source "package/irssi/Config.in"
comment "Multimedia ---"
source "package/gmediaserver/Config.in"
source "package/mt-daapd/Config.in"
+source "package/mpd/Config.in"
comment "Serial communications & terminal emulation ---"
source "package/microcom/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 337df83a79..2cb00f2409 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -97,6 +97,7 @@ package-$(BR2_PACKAGE_MICROPERL) += microperl
package-$(BR2_PACKAGE_MINI_HTTPD) += mini_httpd
package-$(BR2_PACKAGE_MINI_SENDMAIL) += mini_sendmail
package-$(BR2_PACKAGE_MONIT) += monit
+package-$(BR2_PACKAGE_MPD) += mpd
package-$(BR2_PACKAGE_MT_DAAPD) += mt-daapd
package-$(BR2_PACKAGE_MTD) += mtd
package-$(BR2_PACKAGE_MYSQL) += mysql
diff --git a/openwrt/package/mpd/Config.in b/openwrt/package/mpd/Config.in
new file mode 100644
index 0000000000..fd9b8459df
--- /dev/null
+++ b/openwrt/package/mpd/Config.in
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_MPD
+ tristate "MPD - Music Player Daemon (flac support)"
+ default m if CONFIG_DEVEL
+ help
+ MPD is a music player supporting flac, mp3 and ogg.
+ It is typically controlled over a network using one of it's many
+ clients including mpc(console), gmpc(gnome), phpmp(php) etc.
+
+config BR2_PACKAGE_MPD_MP3
+ bool "MP3 Support - Enable mp3 support (experimental)"
+ depends BR2_PACKAGE_MPD
+ help
+ Enable builtin mp3 support (mad). Not well tested, may crash your mpd!
+
+config BR2_PACKAGE_MPD_OGG
+ bool "OGG Support - Enable ogg support (experimental)"
+ depends BR2_PACKAGE_MPD
+ help
+ Enable builtin ogg support (tremor).
diff --git a/openwrt/package/mpd/Makefile b/openwrt/package/mpd/Makefile
new file mode 100644
index 0000000000..90278c83d2
--- /dev/null
+++ b/openwrt/package/mpd/Makefile
@@ -0,0 +1,81 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpd
+PKG_VERSION:=-uclinux--1--patch-10.normalperson-05
+PKG_RELEASE:=1
+PKG_MD5SUM:=c707bb24a4acaa7c6a07fd6e4cda1f7c
+
+PKG_SOURCE_URL:=http://mpd.bogomips.org/mpd--uclinux
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+PKG_CONFIGURE_OPTIONS := \
+ --disable-http \
+ --with-audio=oss \
+ --disable-alsa \
+ --disable-shout \
+ --disable-id3 \
+ --disable-mod \
+ --disable-audiofile \
+ --enable-static --disable-shared \
+ --enable-flac --enable-mpd-flac \
+ --disable-sse --disable-3dnow \
+ --enable-uclinux
+
+ifneq ($(BR2_PACKAGE_MPD_MP3),)
+PKG_CONFIGURE_OPTIONS += \
+ --enable-mp3 --enable-mpd-mad
+else
+PKG_CONFIGURE_OPTIONS += --disable-mp3
+endif
+
+ifneq ($(BR2_PACKAGE_MPD_OGG),)
+PKG_CONFIGURE_OPTIONS += \
+ --enable-ogg --enable-mpd-ivorbis
+else
+PKG_CONFIGURE_OPTIONS += --disable-ogg
+endif
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,MPD,mpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+ (cd $(PKG_BUILD_DIR); \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ $(PKG_CONFIGURE_OPTIONS) \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ rm -rf $(PKG_INSTALL_DIR)
+ mkdir -p $(PKG_INSTALL_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ all install
+ touch $@
+
+$(IPKG_MPD):
+ install -d -m0755 $(IDIR_MPD)/usr/bin
+ install -d -m0755 $(IDIR_MPD)/etc
+ cp -fp $(PKG_INSTALL_DIR)/usr/bin/mpd $(IDIR_MPD)/usr/bin
+ cp -fp $(PKG_BUILD_DIR)/doc/mpdconf.example $(IDIR_MPD)/etc/mpd.conf
+ $(RSTRIP) $(IDIR_MPD)
+ $(IPKG_BUILD) $(IDIR_MPD) $(PACKAGE_DIR)
+
+mostlyclean:
+ make -C $(PKG_BUILD_DIR) clean
+ rm $(PKG_BUILD_DIR)/.built
diff --git a/openwrt/package/mpd/ipkg/mpd.conffiles b/openwrt/package/mpd/ipkg/mpd.conffiles
new file mode 100644
index 0000000000..a8d69760e1
--- /dev/null
+++ b/openwrt/package/mpd/ipkg/mpd.conffiles
@@ -0,0 +1 @@
+/etc/mpd.conf
diff --git a/openwrt/package/mpd/ipkg/mpd.control b/openwrt/package/mpd/ipkg/mpd.control
new file mode 100644
index 0000000000..2daf4838d5
--- /dev/null
+++ b/openwrt/package/mpd/ipkg/mpd.control
@@ -0,0 +1,6 @@
+Package: mpd
+Priority: optional
+Section: net
+Maintainer: David Collett <daveco@users.sourceforge.net>
+Source: http://mpd.wikicities.com/wiki/MusicPlayerDaemonUclinuxBranch
+Description: A music player for flac, mp3 and ogg.
diff --git a/openwrt/package/mpd/patches/configure.patch b/openwrt/package/mpd/patches/configure.patch
new file mode 100644
index 0000000000..79bf83a72e
--- /dev/null
+++ b/openwrt/package/mpd/patches/configure.patch
@@ -0,0 +1,11 @@
+diff -rNu mpd--uclinux--1--patch-10.normalperson-05.OLD/configure mpd--uclinux--1--patch-10.normalperson-05/configure
+--- mpd--uclinux--1--patch-10.normalperson-05.OLD/configure 2005-07-03 19:00:33.000000000 +1000
++++ mpd--uclinux--1--patch-10.normalperson-05/configure 2005-09-11 13:56:23.992755032 +1000
+@@ -21756,7 +21756,6 @@
+ #define NDEBUG 1
+ _ACEOF
+
+- CC="arm-elf-gcc"
+ enable_iconv=no
+ enable_http=no
+ enable_ipv6=no
diff --git a/openwrt/package/mpd/patches/devices.patch b/openwrt/package/mpd/patches/devices.patch
new file mode 100644
index 0000000000..0440a63741
--- /dev/null
+++ b/openwrt/package/mpd/patches/devices.patch
@@ -0,0 +1,33 @@
+diff -rNu mpd--uclinux--1--patch-10.normalperson-05.OLD/src/audio_oss.c mpd--uclinux--1--patch-10.normalperson-05/src/audio_oss.c
+--- mpd--uclinux--1--patch-10.normalperson-05.OLD/src/audio_oss.c 2005-07-03 21:23:39.000000000 +1000
++++ mpd--uclinux--1--patch-10.normalperson-05/src/audio_oss.c 2005-09-11 13:58:44.074459376 +1000
+@@ -179,7 +179,7 @@
+ copyAudioFormat(&audio_format,audioFormat);
+
+ blockSignals();
+- audio_device = open("/dev/dsp", O_WRONLY);
++ audio_device = open("/dev/sound/dsp", O_WRONLY);
+
+ if (audio_device < 0) err |= 1;
+
+@@ -199,7 +199,7 @@
+ unblockSignals();
+
+ if (err)
+- ERROR("Error opening /dev/dsp: 0x%x\n");
++ ERROR("Error opening /dev/sound/dsp: 0x%x\n");
+ if (!audio_device)
+ return -1;
+ #endif
+diff -rNu mpd--uclinux--1--patch-10.normalperson-05.OLD/src/volume.c mpd--uclinux--1--patch-10.normalperson-05/src/volume.c
+--- mpd--uclinux--1--patch-10.normalperson-05.OLD/src/volume.c 2005-05-05 18:19:03.000000000 +1000
++++ mpd--uclinux--1--patch-10.normalperson-05/src/volume.c 2005-09-11 14:04:17.013844896 +1000
+@@ -41,7 +41,7 @@
+ #define VOLUME_MIXER_TYPE_ALSA 2
+
+ #define VOLUME_MIXER_SOFTWARE_DEFAULT ""
+-#define VOLUME_MIXER_OSS_DEFAULT "/dev/mixer"
++#define VOLUME_MIXER_OSS_DEFAULT "/dev/sound/mixer"
+ #define VOLUME_MIXER_ALSA_DEFAULT "default"
+ #define VOLUME_MIXER_ALSA_CONTROL_DEFAULT "PCM"
+