aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-04-05 13:51:26 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-04-05 13:51:26 +0000
commit12c856173613d7c0328a3218ef3b373b7bd89973 (patch)
tree8b0ebfa1344bfca67b85bef051c05e3cecc5a55d
parent9ea87948afff3cb5f558e55c74aba182faed1111 (diff)
downloadupstream-12c856173613d7c0328a3218ef3b373b7bd89973.tar.gz
upstream-12c856173613d7c0328a3218ef3b373b7bd89973.tar.bz2
upstream-12c856173613d7c0328a3218ef3b373b7bd89973.zip
[package] switch: explicitely clear port mappings in unsused vlans (#7082)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20717 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/switch/Makefile2
-rw-r--r--package/switch/files/switch.sh6
2 files changed, 7 insertions, 1 deletions
diff --git a/package/switch/Makefile b/package/switch/Makefile
index a9b881c40e..74e42e6d93 100644
--- a/package/switch/Makefile
+++ b/package/switch/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=kmod-switch
-PKG_RELEASE:=2
+PKG_RELEASE:=3
include $(INCLUDE_DIR)/package.mk
diff --git a/package/switch/files/switch.sh b/package/switch/files/switch.sh
index f0bd8ce60f..6517ca9853 100644
--- a/package/switch/files/switch.sh
+++ b/package/switch/files/switch.sh
@@ -15,6 +15,12 @@ setup_switch_hw() {
echo "$evlan" > "$proc/enable_vlan"
[ -f "$proc/enable" ] && echo "$enable" > "$proc/enable"
}
+
+ local vlan
+ for vlan in `seq 0 15`; do
+ proc="/proc/switch/$dev/vlan/$vlan/ports"
+ [ -f "$proc" ] && echo "" > "$proc"
+ done
}
setup_switch_vlan() {