aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-05-11 17:09:07 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-09-04 22:35:22 +0200
commit1184e1f2b68573f72b25699dd413fa755bdc4aef (patch)
tree208a0afeef251f9311a678bbcfdb79a28ba467da
parent169152c8d118408ba62788a1e6b9eae368dc8b79 (diff)
downloadupstream-1184e1f2b68573f72b25699dd413fa755bdc4aef.tar.gz
upstream-1184e1f2b68573f72b25699dd413fa755bdc4aef.tar.bz2
upstream-1184e1f2b68573f72b25699dd413fa755bdc4aef.zip
uboot-envtools: Update to U-Boot version 2019.07
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/boot/uboot-envtools/Makefile8
-rw-r--r--package/boot/uboot-envtools/patches/001-compile.patch6
2 files changed, 7 insertions, 7 deletions
diff --git a/package/boot/uboot-envtools/Makefile b/package/boot/uboot-envtools/Makefile
index 71b842b96e..4be043dcab 100644
--- a/package/boot/uboot-envtools/Makefile
+++ b/package/boot/uboot-envtools/Makefile
@@ -9,16 +9,16 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-envtools
PKG_DISTNAME:=u-boot
-PKG_VERSION:=2018.03
-PKG_RELEASE:=3
+PKG_VERSION:=2019.07
+PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_SUBDIR:=$(PKG_DISTNAME)-$(PKG_VERSION)
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_DISTNAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=https://git.denx.de/u-boot.git
-PKG_SOURCE_VERSION:=f95ab1fb6e37f0601f397091bb011edf7a98b890
-PKG_MIRROR_HASH:=b50d8b6fe0d90b92c8c147457b1b4c2ed1cdb03191085cfc57fdad77c0bfffab
+PKG_SOURCE_VERSION:=e5aee22e4be75e75a854ab64503fc80598bc2004
+PKG_MIRROR_HASH:=58c1ecaf901b6bf65c5e872b5449b642694ae5acebf61f91f0d4bc20b4c654b7
PKG_BUILD_DEPENDS:=fstools
diff --git a/package/boot/uboot-envtools/patches/001-compile.patch b/package/boot/uboot-envtools/patches/001-compile.patch
index f7ec9130d6..34072f309d 100644
--- a/package/boot/uboot-envtools/patches/001-compile.patch
+++ b/package/boot/uboot-envtools/patches/001-compile.patch
@@ -1,6 +1,6 @@
--- a/tools/env/Makefile
+++ b/tools/env/Makefile
-@@ -10,6 +10,10 @@
+@@ -8,6 +8,10 @@
# with "CC" here for the maximum code reuse of scripts/Makefile.host.
override HOSTCC = $(CC)
@@ -9,5 +9,5 @@
+endif
+
# Compile for a hosted environment on the target
- HOST_EXTRACFLAGS = $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
- -idirafter $(srctree)/tools/env \
+ HOST_EXTRACFLAGS = -I$(srctree)/tools \
+ $(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \