aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2010-08-09 04:22:39 +0000
committerAndy Boyett <agb@openwrt.org>2010-08-09 04:22:39 +0000
commit0f5d0f69ab14d9817c16147cef0a1a537a1cc8c4 (patch)
tree4ad748c4f0fc2b472e44fc2c07730a002579b47d
parentff4351866973d1395543ef36b23a81a37782f56d (diff)
downloadupstream-0f5d0f69ab14d9817c16147cef0a1a537a1cc8c4.tar.gz
upstream-0f5d0f69ab14d9817c16147cef0a1a537a1cc8c4.tar.bz2
upstream-0f5d0f69ab14d9817c16147cef0a1a537a1cc8c4.zip
image: use internal qemu-img for vmdk and vdi images drop host dependencies on qemu-utils and VirtualBox
SVN-Revision: 22553
-rw-r--r--target/linux/x86/image/Config.in4
-rw-r--r--target/linux/x86/image/Makefile14
2 files changed, 1 insertions, 17 deletions
diff --git a/target/linux/x86/image/Config.in b/target/linux/x86/image/Config.in
index b89980c638..308f85cca4 100644
--- a/target/linux/x86/image/Config.in
+++ b/target/linux/x86/image/Config.in
@@ -36,8 +36,6 @@ config X86_VDI_IMAGES
depends TARGET_x86_generic
depends TARGET_ROOTFS_EXT2FS
select PACKAGE_kmod-pcnet32
- help
- Requires VBoxManage installed on the build system.
config X86_VMDK_IMAGES
bool "Build VMware image files (VMDK)"
@@ -45,8 +43,6 @@ config X86_VMDK_IMAGES
depends TARGET_x86_generic
depends TARGET_ROOTFS_EXT2FS
select PACKAGE_kmod-e1000
- help
- Requires qemu-img installed on the build system.
config OLPC_BOOTSCRIPT_IMAGES
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 338c8e0a74..b5297bbff8 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -143,7 +143,7 @@ ifneq ($(CONFIG_X86_VDI_IMAGES),)
# left here because the image builder doesnt need these
ifeq ($(1),ext2)
rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
- VBoxManage convertfromraw -format VDI \
+ qemu-img convert -f raw -O vdi \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
# XXX: VBoxManage insists on setting perms to 0600
@@ -191,15 +191,3 @@ define Image/Build
endef
$(eval $(call BuildImage))
-
-ifneq ($(CONFIG_X86_VDI_IMAGES),)
- $(eval $(call RequireCommand,VBoxManage, \
- You need VBoxManage to generate VirtualBox images. \
- ))
-endif
-
-ifneq ($(CONFIG_X86_VMDK_IMAGES),)
- $(eval $(call RequireCommand,qemu-img, \
- You need qemu-img to generate VMware images. \
- ))
-endif