aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-03 15:09:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-03 15:09:05 +0000
commit0f46e35d7908849dfb1ad6ba4127b36b2e7cb08a (patch)
tree9a975668dbbdfa01d365f1abd75e0aee866450bb
parent6526ac63f07018b6335837586bc486d3ebf66a44 (diff)
downloadupstream-0f46e35d7908849dfb1ad6ba4127b36b2e7cb08a.tar.gz
upstream-0f46e35d7908849dfb1ad6ba4127b36b2e7cb08a.tar.bz2
upstream-0f46e35d7908849dfb1ad6ba4127b36b2e7cb08a.zip
add less
SVN-Revision: 1324
-rw-r--r--openwrt/package/Config.in1
-rw-r--r--openwrt/package/Makefile2
-rw-r--r--openwrt/package/less/Config.in9
-rw-r--r--openwrt/package/less/Makefile61
-rw-r--r--openwrt/package/less/ipkg/less.control7
5 files changed, 80 insertions, 0 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index dd4a1163cf..0e5d5a8d66 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -12,6 +12,7 @@ source "package/iptables/Config.in"
comment "Applications"
source "package/haserl/Config.in"
source "package/lcd4linux/Config.in"
+source "package/less/Config.in"
source "package/lua/Config.in"
source "package/microperl/Config.in"
source "package/monit/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index f065259440..751b5e5e0e 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -39,6 +39,7 @@ package-$(BR2_PACKAGE_IRSSI) += irssi
package-$(BR2_PACKAGE_KISMET) += kismet
package-$(BR2_PACKAGE_L2TPD) += l2tpd
package-$(BR2_PACKAGE_LCD4LINUX) += lcd4linux
+package-$(BR2_PACKAGE_LESS) += less
package-$(BR2_PACKAGE_LIBDB) += libdb
package-$(BR2_PACKAGE_LIBELF) += libelf
package-$(BR2_PACKAGE_LIBEVENT) += libevent
@@ -147,6 +148,7 @@ fprobe-compile: libpcap-compile
gdbserver-compile: ncurses-compile
gnutls-compile: libgcrypt-compile opencdk-compile libtasn1-compile
kismet-compile: uclibc++-compile libpcap-compile ncurses-compile
+less-compile: ncurses-compile
lcd4linux-compile: ncurses-compile
libgcrypt-compile: libgpg-error-compile
libgd-compile: libpng-compile
diff --git a/openwrt/package/less/Config.in b/openwrt/package/less/Config.in
new file mode 100644
index 0000000000..80de80f2ae
--- /dev/null
+++ b/openwrt/package/less/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LESS
+ tristate "less - a text file viewer."
+ default m if CONFIG_DEVEL
+ select BR2_PACKAGE_LIBNCURSES
+ help
+ less - less is a pager. A pager usually displays text files.
+
+ http://www.greenwoodsoftware.com/less/
+
diff --git a/openwrt/package/less/Makefile b/openwrt/package/less/Makefile
new file mode 100644
index 0000000000..f958ed4205
--- /dev/null
+++ b/openwrt/package/less/Makefile
@@ -0,0 +1,61 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=less
+PKG_VERSION:=381
+PKG_RELEASE:=1
+PKG_MD5SUM:=40c2dd4ac137b61b6a55a6478817daf4
+
+PKG_SOURCE_URL:=http://www.greenwoodsoftware.com/less
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,LESS,less,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+ (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="-I$(STAGING_DIR)/usr/include $(TARGET_CFLAGS)" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
+ $(DISABLE_NLS) \
+ --enable-shared \
+ --disable-static \
+ --without-regex \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+ $(MAKE) -C $(PKG_BUILD_DIR)
+ touch $@
+
+$(IPKG_LESS):
+ install -d -m0755 $(IDIR_LESS)/usr/bin
+ install -m0755 $(PKG_BUILD_DIR)/less $(IDIR_LESS)/usr/bin/
+ $(RSTRIP) $(IDIR_LESS)
+ $(IPKG_BUILD) $(IDIR_LESS) $(PACKAGE_DIR)
diff --git a/openwrt/package/less/ipkg/less.control b/openwrt/package/less/ipkg/less.control
new file mode 100644
index 0000000000..e36454a8d6
--- /dev/null
+++ b/openwrt/package/less/ipkg/less.control
@@ -0,0 +1,7 @@
+Package: less
+Priority: optional
+Section: misc
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Depends: libncurses
+Description: A text mode pager