aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYunhui Fu <yhfudev@gmail.com>2017-10-13 14:32:40 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2017-10-15 00:24:22 +0200
commit0f061af98ed74a9170c70eab2e5e359b188dff62 (patch)
tree534fb8773b1efcd5348effd6933b07d6a76afed7
parentd67979b9d61e4b726431ba97bfed325ad31b3e97 (diff)
downloadupstream-0f061af98ed74a9170c70eab2e5e359b188dff62.tar.gz
upstream-0f061af98ed74a9170c70eab2e5e359b188dff62.tar.bz2
upstream-0f061af98ed74a9170c70eab2e5e359b188dff62.zip
wpan-tools: add the wpan-ping to test the 6LoWPAN network
This patch adds the help tool wpan-ping to test the 6LoWPAN network to help the user debug network problem. Signed-off-by: Yunhui Fu <yhfudev@gmail.com>
-rw-r--r--package/network/utils/wpan-tools/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/network/utils/wpan-tools/Makefile b/package/network/utils/wpan-tools/Makefile
index ff65375724..e57223dee4 100644
--- a/package/network/utils/wpan-tools/Makefile
+++ b/package/network/utils/wpan-tools/Makefile
@@ -31,6 +31,7 @@ endef
define Package/wpan-tools/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iwpan $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wpan-ping/wpan-ping $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,wpan-tools))