aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-07-06 08:04:52 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-07-06 08:04:52 +0000
commit0dc18d8586670bc6fa1f6bcc899d9695aed4efc0 (patch)
treed1367c9109185fad3b8d1e6cd0f97119c23be223
parent533067b8f547b86133b248ced99afccb58d27015 (diff)
downloadupstream-0dc18d8586670bc6fa1f6bcc899d9695aed4efc0.tar.gz
upstream-0dc18d8586670bc6fa1f6bcc899d9695aed4efc0.tar.bz2
upstream-0dc18d8586670bc6fa1f6bcc899d9695aed4efc0.zip
ramips: create factory image for the WHR-G300N board
SVN-Revision: 27474
-rw-r--r--target/linux/ramips/image/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index b1e856d893..2a841efce8 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -67,6 +67,28 @@ define BuildFirmware/Generic
fi; fi
endef
+define BuildFirmware/Buffalo
+ $(call PatchKernelLzma,$(2),board=$(3) $($(4)))
+ $(call MkImage,lzma,"$(KDIR)/vmlinux-$(2).bin.lzma","$(KDIR)/vmlinux-$(2).uImage")
+ if [ `stat -c%s "$(KDIR)/vmlinux-$(2).uImage"` -gt $(5) ]; then \
+ echo "Warning: $(KDIR)/vmlinux-$(2).uImage is too big"; \
+ else if [ `stat -c%s $(KDIR)/root.$(1)` -gt $(6) ]; then \
+ echo "Warning: $(KDIR)/root.$(1) is too big"; \
+ else \
+ buffalo-enc -p $(3) -v 1.76 \
+ -i $(KDIR)/vmlinux-$(2).uImage \
+ -o $(KDIR)/vmlinux-$(2).uImage.enc; \
+ buffalo-enc -p $(3) -v 1.76 \
+ -i $(KDIR)/root.$(1) \
+ -o $(KDIR)/root.$(1).enc; \
+ buffalo-tag -b $(3) -p $(3) -a ram -v 1.76 -m 1.01 \
+ -l mlang8 -f 1 -r EU \
+ -i $(KDIR)/vmlinux-$(2).uImage.enc \
+ -i $(KDIR)/root.$(2).enc \
+ -o $(call imgname,$(1),$(2))-factory-EU.bin; \
+ fi; fi
+endef
+
mtdlayout_4M=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
define Image/Build/Template/GENERIC_4M
$(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_4M,851968,3014656)
@@ -103,8 +125,10 @@ define Image/Build/Profile/V22RW2X2
$(call Image/Build/Template/GENERIC_4M,$(1),v22rw-2x2,V22RW-2X2)
endef
+mtdlayout_whrg300n=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,960k(kernel),2752k(rootfs),64k(user)ro,3712k@0x50000(firmware)
define Image/Build/Profile/WHRG300N
$(call Image/Build/Template/GENERIC_4M,$(1),whr-g300n,WHR-G300N)
+ $(call BuildFirmware/Buffalo,$(1),whr-g300n,WHR-G300N,mtdlayout_whrg300n,983040,3801088)
endef
define Image/Build/Profile/HW5503G