aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-06-06 00:35:17 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-06-06 22:25:53 +0200
commit0c0bb629992d3cc2fe277a2348e8cf70fa429567 (patch)
tree6b5a1d0a0b55881041af98f1a2e00287f25d4c47
parentc57e182b560e4c93377270d470600095c2b580fe (diff)
downloadupstream-0c0bb629992d3cc2fe277a2348e8cf70fa429567.tar.gz
upstream-0c0bb629992d3cc2fe277a2348e8cf70fa429567.tar.bz2
upstream-0c0bb629992d3cc2fe277a2348e8cf70fa429567.zip
ar71xx: switch CPE/WBS 210/510 to okli-loader
We recently increased the kernel partition size of the CPE/WBS 210/510. This works fine for new installations of the factory image, but on sysupgrades, the partition table read by the bootloader is not adjusted. This limits the maximum size of the kernel loaded by the bootloader to the old partition size. While adjusting the partition table would be a cleanest solution, such a migration would have to happen before an upgrade to a new version with a newer kernel. This is error-prone and would require a two-step upgrade, as we mark the partition table partition read-only. Instead, switch from the lzma-loader with embedded kernel to the okli-loader, so only the tiny lzma-loader is loaded by the bootloader as "kernel", and the lzma-loader will then load the rest of the kernel by itself. Fixes: e39847ea2f70 ("ar71xx: increase kernel partition size for CPE/WBS 210/510") Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
-rw-r--r--target/linux/ar71xx/image/generic-tp-link.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/generic-tp-link.mk b/target/linux/ar71xx/image/generic-tp-link.mk
index b3b5fdf190..429540a52c 100644
--- a/target/linux/ar71xx/image/generic-tp-link.mk
+++ b/target/linux/ar71xx/image/generic-tp-link.mk
@@ -150,7 +150,10 @@ define Device/cpe510-520-v1
TPLINK_BOARD_ID := CPE510
DEVICE_PROFILE := CPE510
LOADER_TYPE := elf
- KERNEL := kernel-bin | patch-cmdline | lzma | loader-kernel
+ LOADER_FLASH_OFFS := 0x43000
+ COMPILE := loader-$(1).elf
+ COMPILE/loader-$(1).elf := loader-okli-compile
+ KERNEL := kernel-bin | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) 12288
IMAGES := sysupgrade.bin factory.bin
IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
IMAGE/factory.bin := append-rootfs | tplink-safeloader factory