aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-03-06 14:35:58 +0000
committerNicolas Thill <nico@openwrt.org>2005-03-06 14:35:58 +0000
commit0b4c7cb994f38f5c8d202067c0c8410347079509 (patch)
treec4ff0146d31cc37ea1a7f800c639d7182e6d8714
parentce041c793573b71498f202d89cad41c94f64b8c0 (diff)
downloadupstream-0b4c7cb994f38f5c8d202067c0c8410347079509.tar.gz
upstream-0b4c7cb994f38f5c8d202067c0c8410347079509.tar.bz2
upstream-0b4c7cb994f38f5c8d202067c0c8410347079509.zip
Remove packages when cleaning
SVN-Revision: 319
-rw-r--r--openwrt/package/arptables/Makefile1
-rw-r--r--openwrt/package/bridge/Makefile1
-rw-r--r--openwrt/package/ebtables/Makefile1
-rw-r--r--openwrt/package/iproute2/Makefile1
-rw-r--r--openwrt/package/iptables/Makefile2
-rw-r--r--openwrt/package/matrixssl/Makefile2
-rw-r--r--openwrt/package/openssl/Makefile2
-rw-r--r--openwrt/package/openvpn/Makefile1
8 files changed, 8 insertions, 3 deletions
diff --git a/openwrt/package/arptables/Makefile b/openwrt/package/arptables/Makefile
index 03c6322fe1..3058fa18e1 100644
--- a/openwrt/package/arptables/Makefile
+++ b/openwrt/package/arptables/Makefile
@@ -44,3 +44,4 @@ install: $(IPKG_STATE_DIR)/info/arptables.list
clean:
rm -rf $(PKG_BUILD_DIR)
+ rm -f $(PKG_IPK)
diff --git a/openwrt/package/bridge/Makefile b/openwrt/package/bridge/Makefile
index 4381b1d40a..708666cd3b 100644
--- a/openwrt/package/bridge/Makefile
+++ b/openwrt/package/bridge/Makefile
@@ -70,3 +70,4 @@ install: $(IPKG_STATE_DIR)/info/bridge.list
clean:
rm -rf $(PKG_BUILD_DIR)
+ rm -f $(PKG_IPK)
diff --git a/openwrt/package/ebtables/Makefile b/openwrt/package/ebtables/Makefile
index fd168a8a18..5bfbaa17a0 100644
--- a/openwrt/package/ebtables/Makefile
+++ b/openwrt/package/ebtables/Makefile
@@ -44,3 +44,4 @@ install: $(IPKG_STATE_DIR)/info/ebtables.list
clean:
rm -rf $(PKG_BUILD_DIR)
+ rm -f $(PKG_IPK)
diff --git a/openwrt/package/iproute2/Makefile b/openwrt/package/iproute2/Makefile
index ad2ba0094d..6c786eacfe 100644
--- a/openwrt/package/iproute2/Makefile
+++ b/openwrt/package/iproute2/Makefile
@@ -91,3 +91,4 @@ install: $(INSTALL_TARGETS)
clean:
rm -rf $(PKG_BUILD_DIR)
+ rm -f $(PKG_IP) $(PKG_TC)
diff --git a/openwrt/package/iptables/Makefile b/openwrt/package/iptables/Makefile
index 67e4a2d737..b0c1f7786b 100644
--- a/openwrt/package/iptables/Makefile
+++ b/openwrt/package/iptables/Makefile
@@ -104,4 +104,4 @@ install: $(INSTALL_TARGETS)
clean:
rm -rf $(PKG_BUILD_DIR)
- rm -f $(PKG_IPT)
+ rm -f $(PKG_IPT) $(PKG_IPT_EXTRA) $(PKG_IP6T)
diff --git a/openwrt/package/matrixssl/Makefile b/openwrt/package/matrixssl/Makefile
index 4775c121e7..2352742b9a 100644
--- a/openwrt/package/matrixssl/Makefile
+++ b/openwrt/package/matrixssl/Makefile
@@ -52,5 +52,5 @@ install: $(PKG_ZLIB) $(IPKG_STATE_DIR)/info/libmatrixssl.list
clean:
rm -rf $(PKG_BUILD_DIR)
rm -f $(STAGING_DIR)/lib/libmatrixssl* $(STAGING_DIR)/include/matrixssl*
- rm -f $(PACKAGE_DIR)/matrixssl\*.ipk
+ rm -f $(PKG_IPK)
diff --git a/openwrt/package/openssl/Makefile b/openwrt/package/openssl/Makefile
index eb566c53f5..4d30be3ef2 100644
--- a/openwrt/package/openssl/Makefile
+++ b/openwrt/package/openssl/Makefile
@@ -72,5 +72,5 @@ clean:
rm -rf $(PKG_BUILD_DIR)
rm -f $(STAGING_DIR)/lib/libssl*
rm -f $(STAGING_DIR)/lib/libcrypto*
- rm -f $(PACKAGE_DIR)/$(PKG_NAME)\*.ipk
+ rm -f $(PKG_IPK)
diff --git a/openwrt/package/openvpn/Makefile b/openwrt/package/openvpn/Makefile
index 94bee618d6..e9a9cf4fa6 100644
--- a/openwrt/package/openvpn/Makefile
+++ b/openwrt/package/openvpn/Makefile
@@ -70,3 +70,4 @@ install: $(IPKG_STATE_DIR)/info/openvpn.list
clean:
rm -rf $(PKG_BUILD_DIR)
+ rm -f $(PKG_IPK)