aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-04-06 16:45:10 +0000
committerNicolas Thill <nico@openwrt.org>2009-04-06 16:45:10 +0000
commit0a2efdd06a0c5973fe25c8cef2034c3a543d8279 (patch)
treec88cb089404d727158b8913b6ee2795e88a93e1b
parent7b6729e101f5ee99e71b7317a21c9c0bb417faf6 (diff)
downloadupstream-0a2efdd06a0c5973fe25c8cef2034c3a543d8279.tar.gz
upstream-0a2efdd06a0c5973fe25c8cef2034c3a543d8279.tar.bz2
upstream-0a2efdd06a0c5973fe25c8cef2034c3a543d8279.zip
add a patch to disable compile-time buffer checks enabled by default on Ubuntu 8.10 and later (closes: #4826)
SVN-Revision: 15119
-rw-r--r--target/linux/uml/patches/002-gcc4_unfortify_source.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/uml/patches/002-gcc4_unfortify_source.patch b/target/linux/uml/patches/002-gcc4_unfortify_source.patch
new file mode 100644
index 0000000000..b13e5df521
--- /dev/null
+++ b/target/linux/uml/patches/002-gcc4_unfortify_source.patch
@@ -0,0 +1,11 @@
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
+@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+
++# disable compile-time buffer checks, enabled by default on Ubuntu 8.10
++# and later
++KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
++
+ KBUILD_CFLAGS += $(cflags-y)