aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2022-02-03 00:10:04 +0900
committerSungbo Eo <mans0n@gorani.run>2022-02-08 23:23:53 +0900
commit09f383465e0780cf285a02704eb30f1c3d88aa4b (patch)
tree074f867968ab09d7d71170985e37f6aad87cd17c
parenta0ad07ea039c125c28b5b3893c6f935cf68dfdd5 (diff)
downloadupstream-09f383465e0780cf285a02704eb30f1c3d88aa4b.tar.gz
upstream-09f383465e0780cf285a02704eb30f1c3d88aa4b.tar.bz2
upstream-09f383465e0780cf285a02704eb30f1c3d88aa4b.zip
ramips: move KERNEL_LOADADDR into Device/Default
Commit f4a79148f8cb ("ramips: add support for ipTIME AX2004M") was reverted due to KERNEL_LOADADDR leakage, and it seems the problem can be mitigated by moving the variable definition into Device/Default. By this, KERNEL_LOADADDR redefined in a device recipe will not be leaked into the subsequent device recipes anymore and thus will remain as a per-device variable. Ref: cd6a6e3030ff ("Revert "ramips: add support for ipTIME AX2004M"") Signed-off-by: Sungbo Eo <mans0n@gorani.run>
-rw-r--r--target/linux/ramips/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 241b620941..f481e6e447 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -22,7 +22,6 @@ ldrplatform-$(CONFIG_TARGET_ramips_mt7621) := mt7621
ldrflashstart-y := 0x1c000000
ldrflashstart-$(CONFIG_TARGET_ramips_mt7621) := 0x1fc00000
-KERNEL_LOADADDR := $(loadaddr-y)
LOADER_PLATFORM := $(ldrplatform-y)
LOADER_FLASH_START := $(ldrflashstart-y)
@@ -176,6 +175,7 @@ endef
define Device/Default
PROFILES = Default
KERNEL := $(KERNEL_DTB) | uImage lzma
+ KERNEL_LOADADDR := $(loadaddr-y)
SOC := $(DEFAULT_SOC)
DEVICE_DTS_DIR := ../dts
DEVICE_DTS = $$(SOC)_$(1)