aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-09-26 19:01:50 +0000
committerNicolas Thill <nico@openwrt.org>2009-09-26 19:01:50 +0000
commit08938e63d023858f52e0df71a335a6106d9cbdfb (patch)
treecd9df016e4376de1b244336ccbc11e003bba160b
parentf859299d85abafdaa2194935d1a0a3ca08236f07 (diff)
downloadupstream-08938e63d023858f52e0df71a335a6106d9cbdfb.tar.gz
upstream-08938e63d023858f52e0df71a335a6106d9cbdfb.tar.bz2
upstream-08938e63d023858f52e0df71a335a6106d9cbdfb.zip
add _GNU_SOURCE to CPPFLAGS required to include <bits/socket.h> on recent eglibc revisions
SVN-Revision: 17749
-rw-r--r--package/swconfig/Makefile1
-rw-r--r--package/wprobe/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/package/swconfig/Makefile b/package/swconfig/Makefile
index bec94a1ca0..a7bed73174 100644
--- a/package/swconfig/Makefile
+++ b/package/swconfig/Makefile
@@ -21,6 +21,7 @@ define Package/swconfig
endef
TARGET_CPPFLAGS := \
+ -D_GNU_SOURCE \
-I$(STAGING_DIR)/usr/include/libnl-tiny \
-I$(LINUX_DIR)/include \
-I$(PKG_BUILD_DIR) \
diff --git a/package/wprobe/Makefile b/package/wprobe/Makefile
index 02e9919aa2..536a85eb2a 100644
--- a/package/wprobe/Makefile
+++ b/package/wprobe/Makefile
@@ -61,6 +61,7 @@ define Build/Prepare
endef
TARGET_CPPFLAGS := \
+ -D_GNU_SOURCE \
-I$(STAGING_DIR)/usr/include/libnl-tiny \
$(TARGET_CPPFLAGS)