aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-05-20 18:51:23 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-05-20 18:51:23 +0000
commit07009a08e09829f777d6390cd35e2c25e4cbfb2c (patch)
tree919631bd2c2ec81c05d1af8585bf53dbd367249f
parentee1c03f7d650faca6c9ed6c0efed3e4f19def878 (diff)
downloadupstream-07009a08e09829f777d6390cd35e2c25e4cbfb2c.tar.gz
upstream-07009a08e09829f777d6390cd35e2c25e4cbfb2c.tar.bz2
upstream-07009a08e09829f777d6390cd35e2c25e4cbfb2c.zip
give Aruba some love - add support for the combined flash layout
SVN-Revision: 7283
-rw-r--r--target/linux/aruba-2.6/Makefile2
-rw-r--r--target/linux/aruba-2.6/config/default3
-rw-r--r--target/linux/aruba-2.6/image/Makefile9
-rw-r--r--target/linux/aruba-2.6/patches/000-aruba.patch6
4 files changed, 14 insertions, 6 deletions
diff --git a/target/linux/aruba-2.6/Makefile b/target/linux/aruba-2.6/Makefile
index c53964da8a..35645b8102 100644
--- a/target/linux/aruba-2.6/Makefile
+++ b/target/linux/aruba-2.6/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=mips
BOARD:=aruba
BOARDNAME:=Aruba
-FEATURES:=jffs2
+FEATURES:=squashfs jffs2
define Target/Description
Build firmware images for Aruba boards
diff --git a/target/linux/aruba-2.6/config/default b/target/linux/aruba-2.6/config/default
index 9c5ec0750d..6ff30a9d84 100644
--- a/target/linux/aruba-2.6/config/default
+++ b/target/linux/aruba-2.6/config/default
@@ -67,7 +67,7 @@ CONFIG_MACH_ARUBA=y
# CONFIG_MACH_DECSTATION is not set
# CONFIG_MACH_JAZZ is not set
# CONFIG_MACH_VR41XX is not set
-CONFIG_MINI_FO=m
+CONFIG_MINI_FO=y
CONFIG_MIPS=y
# CONFIG_MIPS_ATLAS is not set
# CONFIG_MIPS_BOSPORUS is not set
@@ -151,6 +151,7 @@ CONFIG_MTD_PHYSMAP_START=0x1fc00000
# CONFIG_MTD_REDBOOT_PARTS is not set
# CONFIG_MTD_ROM is not set
# CONFIG_MTD_SLRAM is not set
+CONFIG_MTD_SPLIT_ROOTFS=y
CONFIG_NATSEMI=y
# CONFIG_NE2K_PCI is not set
# CONFIG_NET_VENDOR_3COM is not set
diff --git a/target/linux/aruba-2.6/image/Makefile b/target/linux/aruba-2.6/image/Makefile
index e486b30ef2..7773f6a49e 100644
--- a/target/linux/aruba-2.6/image/Makefile
+++ b/target/linux/aruba-2.6/image/Makefile
@@ -31,11 +31,18 @@ define Image/BuildKernel
endef
define Image/Build/jffs2-64k
- @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=655360 conv=sync
+ @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=786432 conv=sync
@cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
mv $(KDIR)/image.tmp $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(patsubst jffs2-%,jffs2,$(1)).bin
endef
+define Image/Build/squashfs
+ @dd if=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL).ari of=$(KDIR)/image.tmp bs=786432 conv=sync
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ @cat $(KDIR)/root.$(1) >> $(KDIR)/image.tmp
+ @dd if=$(KDIR)/image.tmp of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin bs=64k conv=sync
+endef
+
define Image/Build
$(call Image/Build/$(1),$(1))
endef
diff --git a/target/linux/aruba-2.6/patches/000-aruba.patch b/target/linux/aruba-2.6/patches/000-aruba.patch
index 9954a492bd..1f61424b49 100644
--- a/target/linux/aruba-2.6/patches/000-aruba.patch
+++ b/target/linux/aruba-2.6/patches/000-aruba.patch
@@ -630,9 +630,9 @@ diff -Nur linux-2.6.17/arch/mips/aruba/prom.c linux-2.6.17-owrt/arch/mips/aruba/
+
+/* Kernel Boot parameters */
+static unsigned char bootparm[] =
-+ "init=/etc/preinit "
-+ "mtdparts=physmap-flash.0:3520k@0x080000(zImage),2752k@0x140000(JFFS2),8k@0x3f8000(NVRAM) "
-+ "console=ttyS0,9600 root=/dev/mtdblock1 rootfstype=jffs2 ";
++ "init=/etc/preinit noinitrd "
++ "mtdparts=physmap-flash.0:3520k@0x080000(kernel),2752k@0x140000(rootfs),8k@0x3f8000(NVRAM) "
++ "console=ttyS0,9600 root=/dev/mtdblock1 rootfstype=squashfs,jffs2 ";
+
+extern unsigned long mips_machgroup;
+extern unsigned long mips_machtype;