aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-01-26 22:38:12 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-01-26 22:38:12 +0000
commit066daaac0aa150c07ec2df4bdba2fac31f47430c (patch)
tree6429256f34d154d431512503db4e55d7658f000f
parentcc13c60980666ec74c0ddefcdf71b4378ea938b0 (diff)
downloadupstream-066daaac0aa150c07ec2df4bdba2fac31f47430c.tar.gz
upstream-066daaac0aa150c07ec2df4bdba2fac31f47430c.tar.bz2
upstream-066daaac0aa150c07ec2df4bdba2fac31f47430c.zip
Added clinkc, an embedded UPnP library for audio/video equipments (mediaserver and so on)
SVN-Revision: 3048
-rw-r--r--openwrt/package/Config.in1
-rw-r--r--openwrt/package/Makefile2
-rw-r--r--openwrt/package/clinkc/Config.in10
-rw-r--r--openwrt/package/clinkc/Makefile63
-rw-r--r--openwrt/package/clinkc/ipkg/clinkc.control5
5 files changed, 81 insertions, 0 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index ce27676ed1..488680ccf4 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -178,6 +178,7 @@ source "package/libamsel/Config.in"
source "package/libao/Config.in"
source "package/libart/Config.in"
source "package/libcli/Config.in"
+source "package/clinkc/Config.in"
source "package/curl/Config.in" # libcurl
source "package/libdaemon/Config.in"
source "package/libdb/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 0f1645873e..4f3cb2ae59 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -21,6 +21,7 @@ package-$(BR2_PACKAGE_BWM) += bwm
package-$(BR2_PACKAGE_CGILIB) += cgilib
package-$(BR2_PACKAGE_CHILLISPOT) += chillispot
package-$(BR2_PACKAGE_CIFSMOUNT) += cifsmount
+package-$(BR2_PACKAGE_CLINKC) += clinkc
package-$(BR2_PACKAGE_COLLECTD) += collectd
package-$(BR2_PACKAGE_CUPS) += cups
package-$(BR2_COMPILE_CURL) += curl
@@ -268,6 +269,7 @@ arpd-compile: libpcap-compile libdnet-compile libevent-compile
arpwatch-compile: libpcap-compile
avahi-compile: libdaemon-compile expat-compile libgdbm-compile
bind-compile: openssl-compile
+clinkc-compile: expat-compile
curl-compile: openssl-compile zlib-compile
cyrus-sasl-compile: openssl-compile
deco-compile: ncurses-compile
diff --git a/openwrt/package/clinkc/Config.in b/openwrt/package/clinkc/Config.in
new file mode 100644
index 0000000000..6805564295
--- /dev/null
+++ b/openwrt/package/clinkc/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_CLINKC
+ prompt "clinkc............................ Embedded UPnP library"
+ tristate
+ default m if CONFIG_DEVEL
+ select BR2_PACKAGE_LIBEXPAT
+ help
+ CyberLink for C is a UPnP library using C for small and embedded platforms.
+
+ http://sourceforge.net/projects/clinkc
+
diff --git a/openwrt/package/clinkc/Makefile b/openwrt/package/clinkc/Makefile
new file mode 100644
index 0000000000..4669bb9b34
--- /dev/null
+++ b/openwrt/package/clinkc/Makefile
@@ -0,0 +1,63 @@
+# $Id: Makefile 1640 2005-08-13 20:32:32Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=clinkc
+PKG_VERSION:=101
+PKG_RELEASE:=1
+PKG_MD5SUM:=4c8ac54a15da47203a86daf77fbc2664
+
+PKG_SOURCE_URL:=@SF/clinkc/
+PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/CyberLinkC
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,CLINKC,clinkc,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ --with-gnu-ld \
+ );
+ chmod +x $(PKG_BUILD_DIR)/config/install-sh
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ rm -rf $(PKG_INSTALL_DIR)
+ mkdir -p $(PKG_INSTALL_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ all install
+ touch $@
+
+$(IPKG_CLINKC):
+ cp -fpR $(PKG_INSTALL_DIR) $(IDIR_CLINKC)
+ $(RSTRIP) $(IDIR_CLINKC)
+ $(IPKG_BUILD) $(IDIR_CLINKC) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/clinkc/ipkg/clinkc.control b/openwrt/package/clinkc/ipkg/clinkc.control
new file mode 100644
index 0000000000..cf835874cc
--- /dev/null
+++ b/openwrt/package/clinkc/ipkg/clinkc.control
@@ -0,0 +1,5 @@
+Package: clinkc
+Priority: optional
+Section: net
+Description: CyberLink for C is a UPnP library using C for small and embedded platforms.
+Priority: optional